Repository 32bit  Forum
Repository 64bit  Wiki

Googlearth non si avvia più

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Googlearth non si avvia più

Messaggioda roberto67 » mar feb 05, 2013 18:08

Come da oggetto. L'unica recente variazione che ho apportato alla mia slackware64-14.0 multilib sono i drivers nvidia, che hanno sostituito quelli standard:
Codice: Seleziona tutto
nvidia-linux-310.19-x86_64-1sl.txz  nvidia-vdpau-310.19-x86_64-1sl.txz


altro non ho fatto e questo crashlog non mi dice nulla
Codice: Seleziona tutto
Major Version 6
Minor Version 0
Build Number 0003
Build Date May 17 2011
Build Time 00:40:40
OS Type 3
OS Major Version 3
OS Minor Version 2
OS Build Version 29
OS Patch Version 0
Crash Signal 11
Crash Time 1360083148
Up Time 1.30406

Stacktrace from glibc:
./libgoogleearth_free.so(+0xab953)[0xf7745953]
./libgoogleearth_free.so(+0xabad3)[0xf7745ad3]
linux-gate.so.1(__kernel_sigreturn+0x0)[0xffffe400]
/usr/lib/libGL.so.1(glXMakeContextCurrent+0x3f5)[0xf6588f65]
/usr/lib/libGL.so.1(glXMakeCurrent+0x23)[0xf6589033]
./libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext19internalMakeCurrentEv+0x33)[0xf436d033]
./libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext21internalCreateContextEv+0x1af)[0xf436f38f]
./libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext4openEv+0x93)[0xf4378373]
/opt/google/earth/free/libevll.so(_ZN5earth4evll13VisualContext11OpenContextEN3Gap3Gfx25igRenderDestinationFormatERKNS0_8InitI
nfoE+0xff)[0xf0e04bff]
/opt/google/earth/free/libevll.so(_ZN5earth4evll13VisualContext4initERKNS0_8InitInfoE+0x18e)[0xf0e075fe]
/opt/google/earth/free/libevll.so(_ZN5earth4evll17RenderContextImpl4initERKNS0_8InitInfoE+0x7e)[0xf0cfd21e]
./librender.so(_ZN12RenderWidget6SetApiEPN5earth4evll3APIE+0x47)[0xf4ad6ae7]
./librender.so(_ZN5earth6render12RenderWindow12createWidgetEv+0x16a)[0xf4abb38a]
./libgoogleearth_free.so(_ZN5earth6client12ModuleWidget9showEventEP10QShowEvent+0x8d)[0xf772044d]
./libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0x770)[0xf6ad4a60]
./libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xac)[0xf6a7169c]
./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x484)[0xf6a7c6c4]
./libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x78)[0xf7509ba8]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x145)[0xf6ad66d5]
./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveEv+0x7d)[0xf6ad63cd]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0xc5)[0xf6ad64b5]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0xf6ad65f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xf6ad6a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x170)[0xf6ad6560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0xf6ad65f1]
./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveEv+0x7d)[0xf6ad63cd]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0xc5)[0xf6ad64b5]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0xf6ad65f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xf6ad6a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x170)[0xf6ad6560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0xf6ad65f1]
./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveEv+0x7d)[0xf6ad63cd]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0xc5)[0xf6ad64b5]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0xf6ad65f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xf6ad6a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x170)[0xf6ad6560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0xf6ad65f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xf6ad6a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x170)[0xf6ad6560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0xf6ad65f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xf6ad6a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x170)[0xf6ad6560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0xf6ad65f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xf6ad6a2b]
./libQtGui.so.4(_ZN7QWidget10showNormalEv+0x5c)[0xf6ac416c]
./libgoogleearth_free.so(_ZN10MainWindow18readScreensizeInfoEv+0xd2f)[0xf7712bbf]
./libgoogleearth_free.so(_ZN5earth6client11Application12SetupMainWinENS0_3Kvw7ProductEb+0x31c)[0xf774c8cc]
./libgoogleearth_free.so(_ZN5earth6client11Application3runEv+0x50e)[0xf774faae]
./libgoogleearth_free.so(+0xaa40b)[0xf774440b]
./libgoogleearth_free.so(earthmain+0x247)[0xf7745587]
./googleearth-bin[0x804872b]
/lib/libc.so.6(__libc_start_main+0xf5)[0xf52685a5]


questi i miei pacchetti:
Codice: Seleziona tutto
googleearth-6.0.3.2197-i386-1sl.txz
wine-1.5.5-x86_64-1alien.tgz


grazie per ogni consiglio ;)
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: Googlearth non si avvia più

Messaggioda 414N » mar feb 05, 2013 18:26

wine non ti serve a niente con googleearth.
Controlla che i driver nvidia abbiano effettivamente installato anche il driver a 32 bit sotto /usr/lib.
Puoi controllare al volo tramite un
Codice: Seleziona tutto
grep usr/lib/ /var/log/packages/nvidia-linux-310.19-x86_64-1sl
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Googlearth non si avvia più

Messaggioda roberto67 » mar feb 05, 2013 18:32

414N ha scritto:wine non ti serve a niente con googleearth.
Controlla che i driver nvidia abbiano effettivamente installato anche il driver a 32 bit sotto /usr/lib.
Puoi controllare al volo tramite un
Codice: Seleziona tutto
grep usr/lib/ /var/log/packages/nvidia-linux-310.19-x86_64-1sl


e infatti non ci sono..
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: Googlearth non si avvia più

Messaggioda 414N » mar feb 05, 2013 18:46

Mi pare che il pacchetto dei driver nvidia sia quello presente qui su slacky.
Scarica l'analoga pacchetto per Slackware a 32 bit e convertilo in versione compat32 con convertpkg-compat32 (è nel pacchetto compat32-tools di alien):
Codice: Seleziona tutto
convertpkg-compat32 -i /path/del/pacchetto/nvidia/a/32/bit

Dopodiché installa il pacchetto compat32 così creato e dovrebbe andare.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Googlearth non si avvia più

Messaggioda roberto67 » mar feb 05, 2013 22:09

414N ha scritto:Mi pare che il pacchetto dei driver nvidia sia quello presente qui su slacky.
Scarica l'analoga pacchetto per Slackware a 32 bit e convertilo in versione compat32 con convertpkg-compat32 (è nel pacchetto compat32-tools di alien):
Codice: Seleziona tutto
convertpkg-compat32 -i /path/del/pacchetto/nvidia/a/32/bit

Dopodiché installa il pacchetto compat32 così creato e dovrebbe andare.


fatto (in realtà ho installato il pacchetto che era già disponibile su slacky), ma google-earth crasha ancora
Codice: Seleziona tutto
$ google-earth
/usr/bin/google-earth: line 43: 16449 Segmentation fault      LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH ./googleearth-bin "$@"
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: Googlearth non si avvia più

Messaggioda 414N » gio feb 07, 2013 9:47

Ora che mi ci fai pensare, tempo fa avevo scaricato e provato a far andare l'ultima versione di google earth (la 7.x mi pare) ma anche a me dava un segfault all'avvio e, dato che la cosa non mi sembrava facilmente risolvibile, ho lasciato perdere.
Potresti comunque provare ad eseguire googleearth tramite strace e/o gdb per capire da quale parte del codice venga scatenato il SEGFAULT.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Googlearth non si avvia più

Messaggioda roberto67 » gio feb 07, 2013 14:31

414N ha scritto:Ora che mi ci fai pensare, tempo fa avevo scaricato e provato a far andare l'ultima versione di google earth (la 7.x mi pare) ma anche a me dava un segfault all'avvio e, dato che la cosa non mi sembrava facilmente risolvibile, ho lasciato perdere.
Potresti comunque provare ad eseguire googleearth tramite strace e/o gdb per capire da quale parte del codice venga scatenato il SEGFAULT.


non trova selinux, ma non mi è chiaro a cosa serva qui.. tra l'altro non vedo pacchetti per slackware in giro, o meglio sembra non sia proprio supportato (?). sto continuando a cercare comunque

Codice: Seleziona tutto
[...]
7719  open("/usr/lib/libselinux.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
7719  stat64("/usr/lib", {st_mode=S_IFDIR|0755, st_size=61440, ...}) = 0
7719  munmap(0xf777f000, 246827)        = 0
7719  getpid()                          = 7719
7719  getpid()                          = 7719
7719  --- SIGSEGV (Segmentation fault) @ 0 (0) ---
7709  <... chroot resumed> )            = 7719
7709  open("/usr/share/locale/en_US/LC_MESSAGES/bash.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
7709  open("/usr/share/locale/en/LC_MESSAGES/bash.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
7709  open("/usr/share/locale/en_US/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
7709  open("/usr/share/locale/en/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
7709  write(2, "/usr/bin/google-earth: line 43: "..., 120) = 120
7709  rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
7709  --- SIGCHLD (Child exited) @ 0 (0) ---
7709  wait4(-1, 0x7fff8a5f02d8, WNOHANG, NULL) = -1 ECHILD (No child processes)
7709  rt_sigreturn(0xffffffffffffffff)  = 0
7709  rt_sigaction(SIGINT, {SIG_DFL, [], SA_RESTORER, 0x7f756ed0aaa0}, {0x444c70, [], SA_RESTORER, 0x7f756ed0aaa0}, 8) = 0
7709  rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
7709  read(255, "", 1112)               = 0
7709  exit_group(139)                   = ?


grazie per il suggerimento, 414N ;)
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: Googlearth non si avvia più

Messaggioda 414N » ven feb 08, 2013 13:05

Forse è colpa di una font persiana...
Prova a leggere qua.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Googlearth non si avvia più

Messaggioda roberto67 » ven feb 08, 2013 14:21

414N ha scritto:Forse è colpa di una font persiana...
Prova a leggere qua.


grazie, 414N
purtroppo continua a crashare sempre allo stesso modo. Però mi pare che quel crashlog sia diverso dal mio, a me va in segfault dopo che non trova libselinux..
sono dubbioso se provare a installarlo, perchè mi pare da quel che leggo sia un po' invasivo e ad alcuni abbia messo a soqquadro il sistema, e perchè non mi è chiaro cosa se ne faccia google-earth...
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: Googlearth non si avvia più

Messaggioda 414N » ven feb 08, 2013 14:26

Credo sia una modifica piuttosto invasiva (come minimo devi ricompilare il kernel) e non credo ne valga la pena.
Da quel che ho letto in giro, Google Earth ha avuto qualche problema con SELinux in passato ed è probabile che abbiano aggiunto del codice per rilevare la presenza di SELinux ed agire di conseguenza.
Credo che il tuo problema sia più a fondo di SELinux, invece... Prova con gdb a vedere se riesci ad ottenere un backtrace un po' più illuminante.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Googlearth non si avvia più

Messaggioda roberto67 » ven feb 08, 2013 15:17

414N ha scritto:Credo sia una modifica piuttosto invasiva (come minimo devi ricompilare il kernel) e non credo ne valga la pena.
Da quel che ho letto in giro, Google Earth ha avuto qualche problema con SELinux in passato ed è probabile che abbiano aggiunto del codice per rilevare la presenza di SELinux ed agire di conseguenza.
Credo che il tuo problema sia più a fondo di SELinux, invece... Prova con gdb a vedere se riesci ad ottenere un backtrace un po' più illuminante.


Codice: Seleziona tutto
$ /usr/bin/google-earth
GNU gdb (GDB) 7.5
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-slackware-linux".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /opt/google/earth/free/googleearth-bin...(no debugging symbols found)...done.
(gdb) run
Starting program: /opt/google/earth/free/googleearth-bin
warning: Could not load shared library symbols for linux-gate.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
0xf4e68caa in _nv015tls () from /usr/lib/libnvidia-tls.so.310.19
(gdb) quit


a me non dice nulla.. ma almeno mi conferma che è successo qualcosa nel momento in cui ho cambiato i drivers nvidia,
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: Googlearth non si avvia più

Messaggioda 414N » sab feb 09, 2013 16:31

Dopo il segmentation fault, usa il comando bt per vedere un backtrace un po' più completo.
Comunque sembra ci sia qualche problema con i driver nvidia...
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Googlearth non si avvia più

Messaggioda roberto67 » sab feb 09, 2013 17:34

414N ha scritto:Dopo il segmentation fault, usa il comando bt per vedere un backtrace un po' più completo.
Comunque sembra ci sia qualche problema con i driver nvidia...


Eccolo. Continuo a non capire che succeda. sto usando il vecchio pacchetto della versione 6.0 di google-earth scaricato da questo sito e una slackware64-14 multilib standard.. nessun altro ha questo problema con i drivers nvidia-linux?
Codice: Seleziona tutto
$ /usr/bin/google-earth
GNU gdb (GDB) 7.5
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-slackware-linux".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /opt/google/earth/free/googleearth-bin...(no debugging symbols found)...done.
(gdb) run
Starting program: /opt/google/earth/free/googleearth-bin
warning: Could not load shared library symbols for linux-gate.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
0xf4e68caa in _nv015tls () from /usr/lib/libnvidia-tls.so.310.19
(gdb) bt
#0  0xf4e68caa in _nv015tls () from /usr/lib/libnvidia-tls.so.310.19
#1  0xf6d76535 in ?? () from /usr/lib/libGL.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
(gdb) quit
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: Googlearth non si avvia più

Messaggioda 414N » sab feb 09, 2013 17:46

Io per la versione 6.x ho usato lo SlackBuild su SBo e mi funziona, dopo aver fatto quanto specificato nel readme (serve un link simbolico che in Slackware non c'è normalmente).
Magari prova a farti un pacchetto con suddetto SlackBuild e guarda se funziona.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Googlearth non si avvia più

Messaggioda roberto67 » sab feb 09, 2013 17:59

414N ha scritto:Io per la versione 6.x ho usato lo SlackBuild su SBo e mi funziona, dopo aver fatto quanto specificato nel readme (serve un link simbolico che in Slackware non c'è normalmente).
Magari prova a farti un pacchetto con suddetto SlackBuild e guarda se funziona.


fatto. l'errore nel debug è identico a prima..
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 1 ospite