Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] filesystem in read only

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] filesystem in read only

Messaggioda JimboJambo » ven gen 03, 2014 14:18

in principio: Ciao, da oggi il mio Slackware non accede più a supporti usb.
Anche modificando il file fstab non sono riuscito a visualizzare il contenuto di ciò che con mount mi dice sia già montato.
Cosa posso fare?

ma subito dopo: umount dava dev/sda1 in uso, così ho cercato di vedere i processi attivi prima con lsof la cui risposta fu illeggibile,
in seguito stupidamente scrivendo questo fuser /dev/sda1

dopodiché ho riavviato il pc... bene..
filesystem in read only, il sistema operativo non poteva essere decompresso e inizializzato se non in modalità mantainance.

Come posso riportare tutto alla normalità e finalmente poter accedere alle rimovibili pennette usb?
Ultima modifica di JimboJambo il mar gen 07, 2014 13:29, modificato 5 volte in totale.
HP OmniBook XE3 - Pentium 3 - 256 MB ram
JimboJambo
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: lun nov 25, 2013 0:07
Slackware: 14.1

Re: aiuto

Messaggioda Vito » ven gen 03, 2014 15:23

faresti bene a postare come hai formattato il tuo HD ed il tuo fstab.

P.S. Non postare troppi messaggi di fila, il topic risulterebbe decisamente poco leggibile.
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4131
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: aiuto

Messaggioda JimboJambo » ven gen 03, 2014 15:44

si, grazie.
allora ecco il fstab:
Codice: Seleziona tutto

/dev/sda     /mnt/usb        auto       noauto,user         0       0
/dev/sdb     /mnt/usb        auto       noauto,user         0       0
#/dev/cdrom       /mnt/cdrom     auto     noauto,owner,ro,comment=x-gvfs-show  0     0
#/dev/fd0     /mnt/floppy        auto      noauto,owner       0        0
devpts        /dev/pts            devpts       gid=5,mode=620     0        0
proc       /proc         proc          defaults                    0      0
tmpfs       /dev/shm       tmpfs      defaults         0        0
 

credo l'hard disk sia ext2 non ricordo bene, dove posso vedere?
HP OmniBook XE3 - Pentium 3 - 256 MB ram
JimboJambo
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: lun nov 25, 2013 0:07
Slackware: 14.1

Re: aiuto

Messaggioda waka_jawaka » ven gen 03, 2014 16:40

Sembra che tu abbia sputtanato fstab. Mancano i riferimenti alla root, allo swap e, forse, alla /home (se hai scelto di piazzarla su un filesystem a parte).
Non potendo montare "/ " il kernel non può avviare il sistema operativo e ti parte una console di emergenza,
Inoltre su fstab devi mettere i riferimenti a partizioni (sdax, sdbx ecc). Sda e sdb indicano dischi non partizioni.
Consiglio: se non sei assolutamente sicuro di ciò che fai, prima di editare qualunque file dai
Codice: Seleziona tutto
cp nomefile nomefile_old

In modo da potere ritornare indietro.
Con una live (va bene anche il dvd di slackware) dai
Codice: Seleziona tutto
fdisk -l

e posta l'output qui, in modo da capire come è messo a livello partizioni il tuo pc.
Ciao
Avatar utente
waka_jawaka
Linux 2.6
Linux 2.6
 
Messaggi: 769
Iscritto il: mar ago 09, 2005 23:00
Nome Cognome: Alberto Palillo
Kernel: 2.6.35
Desktop: KDE 4.5
Distribuzione: Archlinux

Re: aiuto

Messaggioda JimboJambo » ven gen 03, 2014 16:50

ti ringrazio, lo farò in serata.
che poi quando editai fstab non cancellai nulla di quello che era scritto, ho solamente aggiunto sda e sdb. eppure girava tutto.... comunque farò come mi hai detto ma sta sera.
HP OmniBook XE3 - Pentium 3 - 256 MB ram
JimboJambo
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: lun nov 25, 2013 0:07
Slackware: 14.1

Re: aiuto

Messaggioda navajo » ven gen 03, 2014 20:13

Scusami se mi presento in modo poco gentile, ma vorrei ricordarti che ci sono delle regole che andrebbero rispettate.
quando si decide di postare una richiesta di aiuto, bisogna tener presente alcune piccole regole, che non procurano fastidio o fatica a chi scrive, ma che aiuta a chi legge il forum a capire prima e meglio la richiesta, inoltre, si mantiene il forum in ordine.
Quindi:
1) fare una ricerca sul forum per vedere ci sono problemi simili
2) postare nella sezione giusta
3) EVITARE DI DARE UN TITOLO INSIGNIFICANTE COME "AIUTO" ma cercare di essere chiari e concisi
4) usare i codici phb che trovi in alto, come quote o code in caso di listati di codici
5) quando si è alla soluzione del problema, editare il titolo del primo 3D con il Tag [risolto]
Grazie :)
Avatar utente
navajo
Staff
Staff
 
Messaggi: 3769
Iscritto il: gio gen 08, 2004 0:00
Località: Roma
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)

Re: problemi formattazione hard disk

Messaggioda JimboJambo » sab gen 04, 2014 0:00

scusami navajo ma il problema si è evoluto così rapidamente che mi ha disorientato, inizialmente la ricerca per montare una partizione usb l'ho fatta sia sul forum che su Slack4Dummies ma pare che abbia sortito l'effetto peggiore :shock:
adesso mentre decomprime il sistema operativo scrive questo
Codice: Seleziona tutto
Testing root filesystem status: read-only filesystem
Checking root filesystem:
fsck from util-linux 2.21.2
/sbin/e2fsck: Is a directory while trying to open /
/:
The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
           e2fsck -b 8193 <device>

*******************************************************************
** An error occurred during the root filesystem check. **
** You will now be given a chance to log into the         **
** system in single-user mode to fix the problem.         **
**                                                                              **
** If you are using he ext2 filesystem, running             **
** 'e2fsck -v -y <partition>' might help.                       **
*******************************************************************


Ho provato a fare il boot tramite dvd slackware, ma pare che non mi dia retta neanche il bios.
Quindi andando a spegnere il pc dice che salva le variabili per urandom come sempre, spegne la swap e poi... attenzione...
:!: :!: :!: :!: :!: :!: :!:
Codice: Seleziona tutto
Unmounting local file systems.
/dev/sda1 has been unmounted
Remounting root filesystem read-only.
[    77.098673] EXT4-fs (sda1): re-mounted.
/dev/sda1 on / type ext4 (ro)

:thumbright: :thumbright: :thumbright:

In questo forum -> http://www.redhat.com/archives/linux-lvm/2007-January/msg00028.html
dicono che basterebbe commentare i mount /dev/sda-sdb dalla fstab per risolvere il problema
HP OmniBook XE3 - Pentium 3 - 256 MB ram
JimboJambo
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: lun nov 25, 2013 0:07
Slackware: 14.1

Re: filesystem in read only

Messaggioda ZeroUno » dom gen 05, 2014 10:01

quando ti da quel messaggio ti da la possibilità di inserire user/password.
Entra come root poi dai:
Codice: Seleziona tutto
mount -o rw,remount /dev/sda1 /

edita la /etc/fstab e commenta i device /dev/sda-sdb e poi aggiungici
Codice: Seleziona tutto
/dev/sda1    /    ext4       defaults    1  1

salva e rebootta.


P.S. Il messaggio che hai postato dopo 'attenzione' é più che normale e se fosse diverso ci sarebbe qualche problema.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4304
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: filesystem in read only

Messaggioda JimboJambo » mar gen 07, 2014 0:11

Grazie jawaka e ZeroUno,
ho dato fdisk -l ed ecco la risposta
Codice: Seleziona tutto
Disk /dev/sda: 40.0GB, 400000000...0000 bytes
255 testine, 63 settori/tracce, 4864 cilindri, totale 782837659 settori
UnitA = sectors di 1 * 512 = 512 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size(minimum/optimal): 512 / 512 bytes
Identificativo disco: 0x0000bthe

Dispositivo   
/dev/sda1 boot  Start 2048   End 7629456  Blocks 3892465  Id 83  System Linux
/dev/sda2 (noboot) Start 760395467  End 76320457 Blocks 3947 Id 5 System Esteso
/dev/sda5 (noboot) Start 97620  End 97609  Blocks 076543  Id 82  System Linux swap


L'hard disk è partizionato in circa 38 giga sda1, il rimanente lo chiama esteso id5 e poi all'interno di esteso c'è la Linux Swap.

Inoltre ho provato a montare nuovamente /dev/sda1 con mount -rw /dev/sda1 /
Codice: Seleziona tutto
mount: /dev/sda1 già montato o / occupato
mount: secondo mtab, /dev/sda1 è già montato su /

Tuttavia ho provato chmod +w -R /
e dopo aver cercato di riscrivere i permessi di tutto / non mi ha comunque fatto editare fstab [-X [-X

Allora sono andato a leggermi questo file /proc/mounts
sono 17 righe con tutti i filesystem montati scritto come la fstab, hanno tutti i permessi rw tranne
Codice: Seleziona tutto
/dev/root  /  ext4 ro,relatime,size=117296k,nr_inodes=29324, mode=755 0     0

Potrei aver individuato il problema?
HP OmniBook XE3 - Pentium 3 - 256 MB ram
JimboJambo
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: lun nov 25, 2013 0:07
Slackware: 14.1

Re: filesystem in read only

Messaggioda waka_jawaka » mar gen 07, 2014 1:36

'Azz seguire il filo del tuo discorso non è facile (almeno per me)
Se monti / in read only mode (modalità sola lettura, capisci a me), come pensi di potere editare fstab?
Non ho la minima idea di come il tuo sistema possa arrivare a quel punto. Ma con l'fstab che hai postato non penso proprio che partirà mai in maniera corretta. Devi sistemarlo e ZeroUno ti ha detto come fare.
Devi digitare l'esatto comando postato da ZeroUno
Codice: Seleziona tutto
mount -o rw,remount /dev/sda1 /

e non
Codice: Seleziona tutto
mount -rw /dev/sda1 /

Non devi montare / dato che è gia montata (e non riesco a capire come diavolo succeda), devi dire al sistema che vuoi rimontare / in lettura-scrittura. Se nemmeno segui i consigli che ti si danno, che posti a fare?
Altra consiglio: evita categoricamente di ravanare con i permessi del filesystem. Il comando chmod usalo su singoli file e solo se sai perfettamente quello che stai facendo
Avatar utente
waka_jawaka
Linux 2.6
Linux 2.6
 
Messaggi: 769
Iscritto il: mar ago 09, 2005 23:00
Nome Cognome: Alberto Palillo
Kernel: 2.6.35
Desktop: KDE 4.5
Distribuzione: Archlinux

Re: filesystem in read only

Messaggioda JimboJambo » mar gen 07, 2014 13:27

chiedo umilmente perdono, avevo scritto male il comando postatomi da zerouno.
Ha funzionato perfettamente, ho creduto che -o rw,remount mi andasse sulle opzioni.
Grazie. :mille: :read2:
Inizialmente stavo cercando di visualizzare una pennetta usb.. ora sto studiando udev
Giuro che tutti i comandi che mi avete dato li studierò e me li scriverò da qualche parte
HP OmniBook XE3 - Pentium 3 - 256 MB ram
JimboJambo
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: lun nov 25, 2013 0:07
Slackware: 14.1

Re: [RISOLTO] filesystem in read only

Messaggioda JimboJambo » mer gen 08, 2014 13:03

Ya huuu! ahahah ho montato una pennetta usb ahahahahh
Ho scoperto che udev non ha la libreria che dice di avere in usr/lib/udev per scrivere le informazioni sui device. Tuttavia udisks è venuto in soccorso.
Credete che possa mettere a posto udev per farlo funzionare o devo reinstallarlo?
HP OmniBook XE3 - Pentium 3 - 256 MB ram
JimboJambo
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: lun nov 25, 2013 0:07
Slackware: 14.1


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron