penna usb e /dev/sda0

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
nikez
Linux 0.x
Linux 0.x
Messaggi: 48
Iscritto il: ven gen 02, 2004 0:00

penna usb e /dev/sda0

Messaggioda nikez » mar giu 01, 2004 13:31

ciao a tutti <BR>ho reinstallato da poco la mia slack 9.1 <BR>devo aver sbagliato qualcosina xchè ora non ho più il device /dev/sda0 al quale era collegata la penna usb. <BR>il fatto è che i moduli hotplug vengono caricati. <BR>come si fa a far tornare il buon vecchio sda0? <BR> <BR>grazie<br>

ZIOLele
Linux 0.x
Linux 0.x
Messaggi: 84
Iscritto il: mar giu 01, 2004 0:00

penna usb e /dev/sda0

Messaggioda ZIOLele » mar giu 01, 2004 19:03

Se usi il kernel vanilla, non ci sono problemi ti basta montare /dev/sda1 (non credo che /dev/dsda0 esista) se hai ricompilato il kernel ricordati che devi aver compilato anche: <BR> <BR>- scsi disk support <BR>-USB Mass Storage Support <BR> <BR>Almeno, di solito questi sono i due che mi scordo io 8-) :-] <BR> <BR>ZIOLele<br>

samiel
Staff
Staff
Messaggi: 5510
Iscritto il: ven gen 16, 2004 0:00
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian
Località: Venezia

penna usb e /dev/sda0

Messaggioda samiel » mar giu 01, 2004 20:44

Esistono /dev/sda, quindi /dev/sda1 ecc. <BR>Non esiste /dev/sda0. <BR>Ma cos´è, non riesci a montarla? <BR> <BR>M.<br>

giuppy
Linux 0.x
Linux 0.x
Messaggi: 23
Iscritto il: mer mag 12, 2004 0:00

penna usb e /dev/sda0

Messaggioda giuppy » mar giu 01, 2004 21:53

<BR>Dopo avere collegato la "penna" USB controlla nel file /var/log/messages la presenza delle seguenti righe. <BR> <BR>Jun 1 21:09:32 darkstar kernel: hub.c: new USB device 00:02.0-3, assigned address 2 <BR>Jun 1 21:09:35 darkstar kernel: Initializing USB Mass Storage driver... <BR>Jun 1 21:09:35 darkstar kernel: usb.c: registered new driver usb-storage <BR>Jun 1 21:09:35 darkstar kernel: scsi1 : SCSI emulation for USB Mass Storage devices <BR>Jun 1 21:09:35 darkstar kernel: sda: sda1 <BR>Jun 1 21:09:35 darkstar kernel: USB Mass Storage support registered. <BR> <BR>Come puoi vedere al dispositivo e´ stato assegnato il device sda (sda1 rappresenta la prima partizione sul dispositivo) <BR> <BR>Ti bastera´ utilizzare il seguente comano per montare il dispositivo <BR> <BR>mount -t vfat /dev/sda1 /mnt/memory (la directory "memory" deve essere creata precedentemente) <BR> <BR>Se non risci a montare il dispositivo controlla la il filesystem presente sulla tua chiavetta ed eventualmente sostituisci "vfat", nel precedente comando, con quello trovato. <BR> <BR>Controlla che sia caricato il modulo usb-storage (lsmod) ed eventualmente caricalo col comando modprobe usb-storage. <BR> <BR>Se non riesci proprio a utilizzare la chiavetta USB controlla la configurazione del kernel. Ti trascrivo una parte di un articolo, trovato su Linux Pratico, che ho seguito per fare funzionare la mia USB memory. <BR> <BR>Controlla che sia impostato a Y "Support for hot-pluggable devices" in General Setup, abbilita il supporto per lo SCSI ed i moduli "SCSI disk support", "SCSI generic support" e "SCSI logging facility" nella sezione SCSI Support. <BR> <BR>Aggiungi i moduli dei filesystem FAT e VFAT in Filesystem ed abilita "USB Support" e "USB device filesystem" oltre ai moduli per "UHCI", "OHCI" e "USB Mass Storage Support" (attivando tutte le voci che riguardano quest´ultima). <BR> <BR>Se non trovi il device file puoi crearlo con il seguente comando <BR> <BR># mknod /dev/sda1 b 8 1 <BR> <BR>Un saluto <BR> Giuseppe <BR><br>

nikez
Linux 0.x
Linux 0.x
Messaggi: 48
Iscritto il: ven gen 02, 2004 0:00

penna usb e /dev/sda0

Messaggioda nikez » mer giu 02, 2004 12:50

mi sono fatto fregare dallo scsi :-D <BR>ora funzina tutto perfettamente <BR> <BR>grazie a tutti <BR>grande slacky!<br>

Avatar utente
gek
Linux 0.x
Linux 0.x
Messaggi: 69
Iscritto il: gio mar 25, 2004 0:00
Slackware: 12
Contatta:

penna usb e /dev/sda0

Messaggioda gek » mer giu 09, 2004 15:03

Salve a tutti! <BR>Anche io ho alcuni problemi con la chiavetta: <BR>ho gia seguito i passi riportati ma tutto quello che ottengo e´: <BR>mount: /dev/sda1 non un dispositivo di blocchi valido <BR>ho dato un occhiata a /var/messages ed ecco cosa ho trovato: <BR>Jun 9 14:17:49 darkstar kernel: usb.c: registered new driver usbdevfs <BR>Jun 9 14:17:49 darkstar kernel: usb.c: registered new driver hub <BR>Jun 9 14:17:49 darkstar kernel: Initializing USB Mass Storage driver... <BR>Jun 9 14:17:49 darkstar kernel: usb.c: registered new driver usb-storage <BR>Jun 9 14:17:49 darkstar kernel: USB Mass Storage support registered. <BR>Jun 9 14:23:01 darkstar init: Switching to runlevel: 6 <BR> <BR>aiuto! cosa devo fare?<br>

ZIOLele
Linux 0.x
Linux 0.x
Messaggi: 84
Iscritto il: mar giu 01, 2004 0:00

penna usb e /dev/sda0

Messaggioda ZIOLele » mer giu 09, 2004 16:15

controlla scsi disk support<br>

Avatar utente
gek
Linux 0.x
Linux 0.x
Messaggi: 69
Iscritto il: gio mar 25, 2004 0:00
Slackware: 12
Contatta:

penna usb e /dev/sda0

Messaggioda gek » mer giu 09, 2004 17:51

Deve essere "Option is enabled" o "Compiled as a module"???<br>

Avatar utente
gek
Linux 0.x
Linux 0.x
Messaggi: 69
Iscritto il: gio mar 25, 2004 0:00
Slackware: 12
Contatta:

penna usb e /dev/sda0

Messaggioda gek » gio giu 10, 2004 8:49

Ho scoperto una cosa nuova! <BR>Non mi vede le usb. Ho provato a fare dmesg |grep usb e non ottengo nessun risultato... cosa devo fare?<br>

nikez
Linux 0.x
Linux 0.x
Messaggi: 48
Iscritto il: ven gen 02, 2004 0:00

penna usb e /dev/sda0

Messaggioda nikez » gio giu 10, 2004 19:30

controlla magari anche di aver inserito "scsi emulation". <BR>io l´ho inserito x sicurezza :-] <BR>ma come fa a non riconoscerti le usb che nel post precedente c´era il tuo dmesg con le usb riconosciute? <BR> <BR>ciao ciao<br>