Pagina 1 di 2

Accelerazione grafica e kernel 2.6.7

Inviato: sab giu 19, 2004 20:51
da samiel
ATTENZIONE BATTAGLIONE! <BR>Per installare i driver ATI <BR>per l´accelerazione grafica, <BR>col kernel 2.6.7 <BR>è necessario modificare a manina <BR>i file apgart_be.c <BR>e firegl_public.c <BR>dopo aver installato il pacchetto dei driver, <BR>in modo che "count" <BR>(se non preceduto da . o da _) <BR>risulti _count. <BR>Altrimenti non si riesce <BR>a compilare i driver. <BR>Solo dopo questa modifica, <BR>lanciare il make.sh e il make_install.sh <BR> <BR>Mauro<br>

Accelerazione grafica e kernel 2.6.7

Inviato: lun giu 21, 2004 0:12
da petzy
Samiel, <BR>grazie per la dritta. Un´informazione: io ho una Radeon 9200 e con i driver ATI sul 3d noto dei fastidiosi (anche perchè numerosi) disturbi orizzontali che riproducono l´immagine accelerata ma fuori dalla finestra (ad es. in glxgear). Hai mai notato una cosa simile? A te funziona l´estensione XVideo? <BR>Thanks! <BR>Petzy<br>

Accelerazione grafica e kernel 2.6.7

Inviato: lun giu 21, 2004 8:58
da salbutamolo
Ciao samiel, <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE> è necessario modificare a manina <BR>i file apgart_be.c <BR>e firegl_public.c <BR>dopo aver installato il pacchetto dei driver, <BR>in modo che "count" <BR>(se non preceduto da . o da _) <BR>risulti _count. </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>Anche io avevo notato i problemi dei drivers sul kernel 2.6.7; non sono sicuro di avere capito bene che genere di modifica bisogna si debba effettuare sui files che hai menzionato. Potresti spiegarmela meglio? Ho fatto una ricerca nei file usando "count" come chiave e trova molte cose. Vanno modificate tutte oppure ne esiste una che risolve il problema. Tanto per tagliare la testa al toro, potresti postare un esempio del file prima e dopo la cura? :-D :-D <BR>Complimenti comunque per avere risolto il problema! ;-) <BR>Have a nice day<br>

Accelerazione grafica e kernel 2.6.7

Inviato: lun giu 21, 2004 9:07
da salbutamolo
Ciao Samiel, <BR>forse ho capito...dimmi se ho ragionato correttamente. Allora edito i files da te menzionati, cerco nel codice <!-- BBCode Start --><B>count</B><!-- BBCode End -->. Se nel codice <!-- BBCode Start --><B>count</B><!-- BBCode End --> non è preceduto da <!-- BBCode Start --><B>.</B><!-- BBCode End --> o da <!-- BBCode Start --><B>_</B><!-- BBCode End --> io lo trasformo in <!-- BBCode Start --><B>_count</B><!-- BBCode End -->. Questo vale per tutti i <!-- BBCode Start --><B>count</B><!-- BBCode End --> che trovo nel codice, e naturalmente vale per entrambe i files. Giusto? Have a nice day <BR> <BR><br>

Accelerazione grafica e kernel 2.6.7

Inviato: lun giu 21, 2004 9:29
da samiel
Sì, bisogna fare così. <BR>Stasera posto i dettagli, <BR>perché attualmente sono <BR>impegnato in attività lavorative... <BR> <BR>PS <BR>Anch´io in accelerazione <BR>vedo lineette luminose orizzontali <BR>sullo schermo; <BR>cercheremo di capire.... <BR> <BR>M.<br>

Accelerazione grafica e kernel 2.6.7

Inviato: lun giu 21, 2004 16:36
da beppex
per l´esattezza bisogna sostituire "count" con "_count" in <BR> <BR>agpgart_be.c:1405 <BR>agpgart_be.c:4416 <BR>firegl_public.c:2013 <BR> <BR>fatto questo il modulo si compila senza errori.. ora testo se funge :)<br>

Accelerazione grafica e kernel 2.6.7

Inviato: gio lug 08, 2004 17:45
da prometeus80
Una domanda ma questo trick funziona con i driver ufficiali della ATI? i 3.90?<br>

Accelerazione grafica e kernel 2.6.7

Inviato: gio lug 08, 2004 20:55
da samiel
Sì, io ho installato quelli. <BR> <BR>M.<br>

Accelerazione grafica e kernel 2.6.7

Inviato: sab lug 17, 2004 11:45
da banner
Ciao raga, <BR>io ho provato ad apportare queste modifiche ai due file, ma quando do il make.sh mi da errore!!!Sicuramente avrò sbagliato a fare qualcosa...potreste postare le righe dove bisogna apportare la modifica a count?! <BR>Thanks!! <BR> :-P <BR><br>

Accelerazione grafica e kernel 2.6.7

Inviato: dom lug 18, 2004 13:08
da samiel
Che errore ti da? <BR>Le righe sono indicate <BR>al n. 8.18.2 di <BR>Slackware for dummies <BR> <BR>M.<br>

Accelerazione grafica e kernel 2.6.7

Inviato: lun ago 02, 2004 12:33
da banner
ATI module generator V 2.0 <BR>========================== <BR>initializing... <BR>cleaning... <BR>patching ´highmem.h´... <BR>skipping patch for ´drmP.h´, not needed <BR>skipping patch for ´drm_os_linux.h´, not needed <BR>assuming new VMA API since we do have kernel 2.6.x... <BR>doing Makefile based build for kernel 2.6.x and higher <BR>make -C /lib/modules/2.6.6/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules <BR>make[1]: Entering directory `/usr/src/linux-2.6.6´ <BR> CC [M] /lib/modules/fglrx/build_mod/2.6.x/agpgart_be.o <BR>/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c: In function `agp_generic_alloc_page´: <BR>/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:1405: error: structure has no member named `_count´ <BR>/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c: In function `ali_alloc_page´: <BR>/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:4416: error: structure has no member named `_count´ <BR>make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.o] Error 1 <BR>make[1]: *** [/lib/modules/fglrx/build_mod/2.6.x] Error 2 <BR>make[1]: Leaving directory `/usr/src/linux-2.6.6´ <BR>make: *** [kmod_build] Error 2 <BR>build succeeded with return value 0 <BR>duplicating results into driver repository... <BR>done. <BR>============================== <BR>You must change your working directory to /lib/modules/fglrx <BR>and then call ./make_install.sh in order to install the built module. <BR>============================== <BR> <BR> <BR>??? <BR>HELP?? <BR><br>

Accelerazione grafica e kernel 2.6.7

Inviato: lun ago 02, 2004 15:27
da samiel
Non hai fatto le modifiche <BR>che dovevi o come dovevi, <BR>come si evince dal messaggio che ricevi. <BR>Hai seguito le istruzioni <BR>passo passo? <BR> <BR>M.<br>

Accelerazione grafica e kernel 2.6.7

Inviato: lun ago 02, 2004 20:11
da banner
...si...ho modificato i due file e ho dato il make.sh... <BR>mmm <BR>Dove sbaglio!?<br>

Accelerazione grafica e kernel 2.6.7

Inviato: lun ago 02, 2004 23:27
da samiel
Se lo leggi bene, <BR>il messaggio ti dice che in due righe <BR>di agpgart_be.c non trova _count, <BR>esattamente le righe 1405 e 4416. <BR>Evidentemente non le hai modificate... <BR>Controlla meglio <BR> <BR>M.<br>

Accelerazione grafica e kernel 2.6.7

Inviato: mar ago 03, 2004 11:58
da banner
Ho controllato...ma quelle due righe sono le uniche due che ho modificato con _count!!!! <BR>La trama si infittisce!!! <BR>Può influire il fatto che ho il kernel 2.6.6 e nn 2.6.7?!?!<br>