X11 7.2 contro tutti!

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
markmerenda
Linux 1.0
Linux 1.0
Messaggi: 2
Iscritto il: mer nov 29, 2006 6:15

X11 7.2 contro tutti!

Messaggioda markmerenda » mar feb 27, 2007 22:08

Salve a tutta la preziosa community! Il dilemma di oggi è che non riesco a capire per quale motivo una volta installato e compilato a dovere l' X11 7.2 oppure Zenwalk con X11 7.2 già integrato non riesca ad agganciarsi con molti programmi che invece vorrebbero un X11 versione 6.9

es. Amsn, Amule ecc... prima di essere installati richiedono di installare X11 6.9 e neanche fanno caso al 7.2, poi ovvio che una volta rimpiazzato con la versione obsoleta va tutto a farsi friggere lo "startx" :cry: :cry:

Esiste una soluzione per far capire sti dannati pacchetti di funzionare sotto X11 7.2? :?:

Meskalamdug
Iper Master
Iper Master
Messaggi: 3803
Iscritto il: ven mag 14, 2004 0:00

Re: X11 7.2 contro tutti!

Messaggioda Meskalamdug » mar feb 27, 2007 22:28

markmerenda ha scritto:Salve a tutta la preziosa community! Il dilemma di oggi è che non riesco a capire per quale motivo una volta installato e compilato a dovere l' X11 7.2 oppure Zenwalk con X11 7.2 già integrato non riesca ad agganciarsi con molti programmi che invece vorrebbero un X11 versione 6.9

es. Amsn, Amule ecc... prima di essere installati richiedono di installare X11 6.9 e neanche fanno caso al 7.2, poi ovvio che una volta rimpiazzato con la versione obsoleta va tutto a farsi friggere lo "startx" :cry: :cry:

Esiste una soluzione per far capire sti dannati pacchetti di funzionare sotto X11 7.2? :?:

Si
La soluzione e' usare slackware
e snobbare le distro con gli schiavisti
package-manager
;)
Il risultato e' sotto i tuoi occhi

x11-7.2.0-i486-1mg
x11-devel-7.2.0-i486-1mg
x11-fonts-100dpi-6.9.0-noarch-5
x11-fonts-cyrillic-6.9.0-noarch-5
x11-fonts-misc-6.9.0-noarch-5
x11-fonts-scale-6.9.0-noarch-5
amule-2.1.3-i486-3sl

Un simpatico fritto misto di versioni,tutte funzionanti!
:D

Avatar utente
IceSlack
Linux 3.x
Linux 3.x
Messaggi: 1313
Iscritto il: dom ott 30, 2005 13:27

Re: X11 7.2 contro tutti!

Messaggioda IceSlack » mer feb 28, 2007 10:18

markmerenda ha scritto:Salve a tutta la preziosa community! Il dilemma di oggi è che non riesco a capire per quale motivo una volta installato e compilato a dovere l' X11 7.2 oppure Zenwalk con X11 7.2 già integrato non riesca ad agganciarsi con molti programmi che invece vorrebbero un X11 versione 6.9

es. Amsn, Amule ecc... prima di essere installati richiedono di installare X11 6.9 e neanche fanno caso al 7.2, poi ovvio che una volta rimpiazzato con la versione obsoleta va tutto a farsi friggere lo "startx" :cry: :cry:

Esiste una soluzione per far capire sti dannati pacchetti di funzionare sotto X11 7.2? :?:

probabilmente i programmi sono stati compilati per xorg 6.9 e la 7 apporta modifiche sostanziali senza molta retro compatibilita'

Meskalamdug
Iper Master
Iper Master
Messaggi: 3803
Iscritto il: ven mag 14, 2004 0:00

Re: X11 7.2 contro tutti!

Messaggioda Meskalamdug » mer feb 28, 2007 11:24

IceSlack ha scritto:
markmerenda ha scritto:Salve a tutta la preziosa community! Il dilemma di oggi è che non riesco a capire per quale motivo una volta installato e compilato a dovere l' X11 7.2 oppure Zenwalk con X11 7.2 già integrato non riesca ad agganciarsi con molti programmi che invece vorrebbero un X11 versione 6.9

es. Amsn, Amule ecc... prima di essere installati richiedono di installare X11 6.9 e neanche fanno caso al 7.2, poi ovvio che una volta rimpiazzato con la versione obsoleta va tutto a farsi friggere lo "startx" :cry: :cry:

Esiste una soluzione per far capire sti dannati pacchetti di funzionare sotto X11 7.2? :?:

probabilmente i programmi sono stati compilati per xorg 6.9 e la 7 apporta modifiche sostanziali senza molta retro compatibilita'

Amule va benone sotto x 7.2
amsn non so

Avatar utente
Sari
Linux 2.6
Linux 2.6
Messaggi: 584
Iscritto il: mer feb 16, 2005 0:00
Slackware: 12.1
Kernel: 2.6.24
Desktop: Gnome
Località: Verona

Messaggioda Sari » mer feb 28, 2007 12:27

vedo che tutti parlate di amule su X... nessuno di voi usa amuled, il demone di amule? installate e lanciate un bel amuled -f da shell, e quando dovete gestirlo basta avviare amulegui e connetterlo al gestore web (amuleweb) che dovrete obbligatoriamente avviare con amuled (ovviamente per configurarlo basta avviare amule e configurare da interfaccia).

Vi consiglio di provare se non l'ho avete mai usato.

Avatar utente
DaNiMoTh
Linux 2.6
Linux 2.6
Messaggi: 941
Iscritto il: mar nov 30, 2004 0:00
Località: irc.syrolnet.org /// #slackware
Contatta:

Messaggioda DaNiMoTh » mer feb 28, 2007 13:55

Tralascio la parte degli 'schiavisti' package manager, tanto so che giungere ad una discussione pacifica con la maggior parte delle persone che frequentano questo sito e` pressoche` impossibile;

Dal post di markmerenda non ho capito molto.. posso assicurare, comunque, che tutti i programmi che ha citato girano a dovere anche su Xorg 7.2 ( come fatto vedere da Meska ): il problema sta in una loro errata compilazione.

Meskalamdug
Iper Master
Iper Master
Messaggi: 3803
Iscritto il: ven mag 14, 2004 0:00

Messaggioda Meskalamdug » mer feb 28, 2007 14:52

DaNiMoTh ha scritto:Tralascio la parte degli 'schiavisti' package manager, tanto so che giungere ad una discussione pacifica con la maggior parte delle persone che frequentano questo sito e` pressoche` impossibile;

Dal post di markmerenda non ho capito molto.. posso assicurare, comunque, che tutti i programmi che ha citato girano a dovere anche su Xorg 7.2 ( come fatto vedere da Meska ): il problema sta in una loro errata compilazione.

Discutiamone pure,serenamente
ci mancherebbe
Sugli schiavisti pkgmanager ho solo espresso
la mia personale opinione,basata sulla mia esperienza
puo' essere la verità..come può essere anche una
boiata
;)

Avatar utente
Vito
Staff
Staff
Messaggi: 4178
Iscritto il: mar dic 05, 2006 17:28
Nome Cognome: Vito
Distribuzione: Linux Mint 17
Località: Augsburg (DE)
Contatta:

Messaggioda Vito » gio mar 01, 2007 17:39

l'unico problema mi sa è.... ci sono i driver per le schede ATI che supportano questo Xorg??????Avevo messo Xorg 7.1 ma data l'incompatibilità con i driver ATI sono tornato al 6.9 ....
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]