kernel 2.6.23...INFERNO

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Messaggioda phobos3576 » ven ott 19, 2007 0:10

Meskalamdug ha scritto:Sul driver nvidia

http://www.nvnews.net/vbulletin/forumdi ... rune=&f=14

Leggete dei vari crash e bugs(alcuni dei quali molto
fastidiosi),per quanto riguarda la ati se non erro
sta per rilasciare o ha già rilasciato drivers open source.

Meska, il forum nVidia Linux è riservato agli utenti Linux che hanno problemi con i driver nVidia; è ovvio che li ci trovi solo richieste di aiuto per crash, freezes ed altro.

Come risulta però dai messaggi che arrivano a quel forum, nella gran parte dei casi i problemi sono legati all'uso di BIOS (sia del PC, sia della scheda video) troppo vecchi; gli altri problemi sono legati ad errori nella configurazione del kernel o del server X, all'uso di schede madri non compatibili con la scheda video, etc. Solo in minima parte si può parlare veramente di bug del driver nVidia.

Io uso gli utlimi driver con una GeForce 7600GS e devo dire che non potrei pretendere di meglio; mai un crash o un freeze e le prestazioni sono nettamente superiori a quelle del driver nVidia sotto Windows (come accade a quanto pare con tutte le nVidia della famiglia 7000).
Il kernel lo ricompilo da me in modo molto accurato e ti consiglio di fare altrettanto; non è assolutamente vero che si debbano studiare ogni volta un sacco di opzioni.
Ciò accade solo la prima volta che si ricompila il kernel; le volte successive basta riciclare il vecchio config e studiare solo le nuove opzioni che vengono aggiunte.

Meskalamdug
Iper Master
Iper Master
Messaggi: 3914
Iscritto il: ven mag 14, 2004 0:00

Messaggioda Meskalamdug » ven ott 19, 2007 2:37

phobos3576 ha scritto:
Meskalamdug ha scritto:Sul driver nvidia

http://www.nvnews.net/vbulletin/forumdi ... rune=&f=14

Leggete dei vari crash e bugs(alcuni dei quali molto
fastidiosi),per quanto riguarda la ati se non erro
sta per rilasciare o ha già rilasciato drivers open source.

Meska, il forum nVidia Linux è riservato agli utenti Linux che hanno problemi con i driver nVidia; è ovvio che li ci trovi solo richieste di aiuto per crash, freezes ed altro.

Come risulta però dai messaggi che arrivano a quel forum, nella gran parte dei casi i problemi sono legati all'uso di BIOS (sia del PC, sia della scheda video) troppo vecchi; gli altri problemi sono legati ad errori nella configurazione del kernel o del server X, all'uso di schede madri non compatibili con la scheda video, etc. Solo in minima parte si può parlare veramente di bug del driver nVidia.

Io uso gli utlimi driver con una GeForce 7600GS e devo dire che non potrei pretendere di meglio; mai un crash o un freeze e le prestazioni sono nettamente superiori a quelle del driver nVidia sotto Windows (come accade a quanto pare con tutte le nVidia della famiglia 7000).
Il kernel lo ricompilo da me in modo molto accurato e ti consiglio di fare altrettanto; non è assolutamente vero che si debbano studiare ogni volta un sacco di opzioni.
Ciò accade solo la prima volta che si ricompila il kernel; le volte successive basta riciclare il vecchio config e studiare solo le nuove opzioni che vengono aggiunte.

E' vero,lo facevo pure io
make oldconfig ;)
Solo preferivo il precompilato per via di una
maggiore pulizia del sistema,e anche perchè
voglia di ricompilare...:)
Sui drivers nvidia ribadisco che fanno schifo
,mi basta il bug del video corrotto per considerarli..pessimi.

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2412
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.2
Kernel: 4.11.3-smp
Desktop: xfce4
Distribuzione: freeBSD-12.0-Release

Messaggioda slucky » sab ott 20, 2007 0:00

A proposito di questo kernel-2.6.23, io l'ho compilato ed installato, ma provando ad installare il driver nvidia-1.0-9755 ( che uso anche sull'altro kernel 2.6.22) mi ha dato un errore nella procedura di installazione, che voi sappiate è preferibile usare l'ultimo driver con questo kernel?

Questo è comunque l'output del log di nvidia:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Fri Oct 19 18:49:32 2007

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
force tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
9755). As part of installing this driver (version: 1.0-9755), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
che the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
ERROR: Unable to connect to download.nvidia.com (temporary DNS error (try again
later))
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Kernel source path: '/lib/modules/2.6.23.1/source'
-> Kernel output path: '/lib/modules/2.6.23.1/build'
-> Performing rivafb check.
-> Performing nvidiafb check.
-> Performing Xen check.
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv-i2c.o nv.o nv
-vm.o os-agp.o os-interface.o os-registry.o nv-i2c.o nvidia.mod.o
rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
rm -f -f stprof stprof.o symtab.h Modules.symvers
rm -f -rf .tmp_versions
rm -f Makefile
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.23.1/source
SYSOUT=/lib/modules/2.6.23.1/build'...
sh ./conftest.sh "cc" "cc" /lib/modules/2.6.23.1/source /lib/modules/2.6.23.
1/build cc_sanity_check full_output
sh ./conftest.sh "cc" "cc" /lib/modules/2.6.23.1/source /lib/modules/2.6.23.
1/build select_makefile full_output
make --no-print-directory -f Makefile module

NVIDIA: calling KBUILD...
make CC=cc KBUILD_OUTPUT=/lib/modules/2.6.23.1/build KBUILD_VERBOSE=1 -C /li
b/modules/2.6.23.1/source SUBDIRS=/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-
pkg1/usr/src/nv modules
make -C /lib/modules/2.6.23.1/build \
KBUILD_SRC=/usr/src/linux-2.6.23.1 \
KBUILD_EXTMOD="/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv" -
f /usr/src/linux-2.6.23.1/Makefile modules
test -e include/linux/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are mis
sing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to fix it
."; \
echo; \
/bin/false)
mkdir -p /tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/.tmp_vers
ions
rm -f /tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/.tmp_version
s/*
make -f /usr/src/linux-2.6.23.1/scripts/Makefile.build obj=/tmp/selfgz4336/N
VIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > /tmp/selfgz4336/NVI
DIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv_compiler.h
cc -Wp,-MD,/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/.nv.o
.d -nostdinc -isystem /usr/lib/gcc/i486-slackware-linux/4.1.2/include -D__K
ERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.23.1/include -include incl
ude/linux/autoconf.h -I/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/s
rc/nv -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing
-fno-common -Werror-implicit-function-declaration -O2 -pipe -msoft-float -mr
egparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i486 -mtune
=i686 -ffreestanding -maccumulate-outgoing-args -DCONFIG_AS_CFI=1 -DCONFIG_A
S_CFI_SIGNAL_FRAME=1 -I/us
r/src/linux-2.6.23.1/include/asm-i386/mach-default -Iinclude/asm-i386/mach-d
efault -fomit-frame-pointer -fno-stack-protector -Wdeclaration-after-stateme
nt -Wno-pointer-sign -I/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/s
rc/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wp
arentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-common -msoft-floa
t -MD -Wsign-compare -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KER
NEL__ -DMODULE -DNVRM -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLE
VEL=9755 -UDEBUG -U_DEBUG -DNDEBUG -DNV_SIGNAL_STRUCT_RLIM -DNV_MULTIPLE_BRI
DGE_AGPGART_PRESENT -DNV_PCI_GET_CLASS_PRESENT -DNV_SYSCTL_MAX_MAP_COUNT_PRE
SENT -DNV_PM_MESSAGE_T_PRESENT -DNV_PCI_CHOOSE_STATE_PRESENT -DNV_VM_INSERT_
PAGE_PRESENT -DNV_OLD_MM_KGDB_BREAKPOINT_PRESENT -DNV_REMAP_PFN_RANGE_PRESEN
T -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_VMAP_4_PRESENT -DMODULE -D"KBUILD_STR(s
)=#s" -D"KBUILD_BASENAME=KBUILD_STR(nv)" -D"KBUILD_MODNAME=KBUILD_STR(nvidi
a)" -c -o /tmp/selfgz4336/NVIDIA-Lin
ux-x86-1.0-9755-pkg1/usr/src/nv/nv.o /tmp/selfgz4336/NVIDIA-Linux-x86-1.0-97
55-pkg1/usr/src/nv/nv.c
In file included from include/linux/list.h:8,
from include/linux/preempt.h:11,
from include/linux/spinlock.h:49,
from include/linux/seqlock.h:29,
from include/linux/time.h:8,
from include/linux/timex.h:57,
from include/linux/sched.h:53,
from include/linux/utsname.h:35,
from /tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src
/nv/nv-linux.h:19,
from /tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src
/nv/nv.c:14:
include/linux/prefetch.h: In function 'prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type 'void *' used in arith
metic
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c: At top level
:
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:110: error: e
xpected '=', ',', ';', 'asm' or '__attribute__' before '*' token
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c: In function
'nvos_create_alloc':
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:460: error: '
nv_pte_t_cache' undeclared (first use in this function)
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:460: error: (
Each undeclared identifier is reported only once
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:460: error: f
or each function it appears in.)
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c: In function
'nvos_free_alloc':
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:492: error: '
nv_pte_t_cache' undeclared (first use in this function)
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c: In function
'nvidia_init_module':
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:1420: error:
'nv_pte_t_cache' undeclared (first use in this function)
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:1420: error:
too many arguments to function 'kmem_cache_create'
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:1554: error:
void value not ignored as it ought to be
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c: In function
'nvidia_exit_module':
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:1581: error:
void value not ignored as it ought to be
/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.c:1685: error:
'nv_pte_t_cache' undeclared (first use in this function)
make[4]: *** [/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nv.o
] Error 1
make[3]: *** [_module_/tmp/selfgz4336/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src
/nv] Error 2
make[2]: *** [modules] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at http://www.nvidia.com.


Per risolvere l'errore devo dare make oldconfig & make prepare per fixare il problema? ma questo tipo di errore non era tipico dei driver nvidia-legacy? e poi sapevo che era stato risolto con gli installer successivi............... :oops: mahhh.........aspetto qualche suggerimento per sistemare.

Ciao e grazie a tutti!!! :D

Avatar utente
michele.p
Packager
Packager
Messaggi: 1276
Iscritto il: ven nov 24, 2006 16:52
Nome Cognome: Michele Petrecca
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE
Distribuzione: ..Fedora e Mandriva
Località: Pontecorvo(FR)
Contatta:

2.6.23.1 - niente audio

Messaggioda michele.p » sab ott 20, 2007 0:05

...ho scritto la cosa anche quì

http://www.slacky.eu/forum/viewtopic.php?t=21298

visto che è stato aperto quel topic.
Ad ogni modo, a voi l'audio funziona?

Per quanto ne attiene la scheda video, prova a dare i comandi che hai indicato (e che ti ha indicato il file di log....anche se non so se riuscirai a risolvere).

Bye 8)

[Post edit]
Falso allarme :D ...ho aggiunto l'utente al gruppo audio e tutto si sente.

Ora la mia Slack current va alla grande con il kernel 2.6.23.1 ...ottimo 8)

meritil
Master
Master
Messaggi: 1651
Iscritto il: mar ago 24, 2004 0:00
Slackware: bluewhite64
Contatta:

Messaggioda meritil » sab ott 20, 2007 4:09

io posso testimoniare che il 2.6.23 va benone, la serie precedente non mi bootava (sto usando bluewhite64)

anche i driver nvidia mai dato un problema ma sempre e solo soddisfazioni, ogni qual volta ho avuto un problema era solo per causa di errori miei, configurazioni sballate bios ecc...


;)

Avatar utente
conraid
Staff
Staff
Messaggi: 13305
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Messaggioda conraid » sab ott 20, 2007 8:49

slucky ha scritto:Per risolvere l'errore devo dare make oldconfig & make prepare per fixare il problema? ma questo tipo di errore non era tipico dei driver nvidia-legacy? e poi sapevo che era stato risolto con gli installer successivi.


Anche a me dava errori simili. Ho dato male oldconfig && make prepare, ma continuava a darmi un errore.
Ho ricompilato il kernel e tutto ok.
make prepare serve per creare file che gli servono, tipo version.h, ma non ho capito cosa mancava ulteriormente.
Quando ho un po' di voglia di fare prove guardo meglio.

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2412
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.2
Kernel: 4.11.3-smp
Desktop: xfce4
Distribuzione: freeBSD-12.0-Release

Messaggioda slucky » sab ott 20, 2007 11:06

Mah.............sarà comunque, ho provato con l'ultimo driver nvidia, ma mi dà errori già in fase di installazione e non solo a procedura terminata :shock: , comunque ho risolto installando la versione 96.43.01 che vedo funziona bene effettoni compresi :D
Pazienza, aspettiamo tempi migliori per il prossimo driver nvidia.

Ciao a tutti ;)

Avatar utente
conraid
Staff
Staff
Messaggi: 13305
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Messaggioda conraid » sab ott 20, 2007 11:14

slucky ha scritto:Mah.............sarà comunque, ho provato con l'ultimo driver nvidia, ma mi dà errori già in fase di installazione e non solo a procedura terminata :shock:


Anche a me in fase di installazione, precisamente in fase di compilazione.
Facendo solo make prepare arrivava al 100% di compilazione ma poi usciva con un errore. Come ti ho detto non ho indagato, tanto dovevo compilare il kernel con diverse impostazioni e dopo un make anche i driver nvidia sono andati tutto ok.
Non saprei dirti il motivo, se ricapita do un occhiata ai log

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2412
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.2
Kernel: 4.11.3-smp
Desktop: xfce4
Distribuzione: freeBSD-12.0-Release

Messaggioda slucky » lun ott 22, 2007 23:40

Mah..............ho riprovato a reinstallare l'ultimo driver nvidia è stavolta tutto è andato liscio, nessun messaggio di errore in fase di compilazione del driver, e funziona tutto bene :) .................boh è chi ci capisce qualcosa!! direi misteri del kernel :lol: :lol:


Ciao a tutti!!

Meskalamdug
Iper Master
Iper Master
Messaggi: 3914
Iscritto il: ven mag 14, 2004 0:00

Messaggioda Meskalamdug » gio nov 01, 2007 14:23

Dunque..sembra abbia "risolto"

Nov 1 13:55:15 Slack kernel: ------------[ cut here ]------------
Nov 1 13:55:15 Slack kernel: BUG: unable to handle kernel NULL pointer dereference at virtual address 00000001
Nov 1 13:55:15 Slack kernel: printing eip:
Nov 1 13:55:15 Slack kernel: c017e5fd
Nov 1 13:55:15 Slack kernel: *pde = 00000000
Nov 1 13:55:15 Slack kernel: kernel BUG at kernel/workqueue.c:221!
Nov 1 13:55:15 Slack kernel: invalid opcode: 0000 [#1]
Nov 1 13:55:15 Slack kernel: SMP
Nov 1 13:55:15 Slack kernel: Modules linked in: capability commoncap lp joydev usb_storage zd1211rw ieee80211softmac ieee80211 ieee80211_crypt dvb_ttpci lnbp21 l64781 saa7146_vv psmouse video_buf snd_hda_intel serio_raw saa7146 videodev snd_pcm v4l2_common v4l1_compat ves1820 tda8083 sp8870 stv0297 ves1x93 snd_timer ttpci_eeprom ohci1394 stv0299 ieee1394 dvb_core k8temp hwmon snd soundcore ehci_hcd i2c_nforce2 snd_page_alloc ohci_hcd agpgart i2c_core fan evdev ns558 gameport sg rtc_cmos rtc_core rtc_lib button thermal processor pcspkr parport_pc parport reiserfs
Nov 1 13:55:15 Slack kernel: CPU: 1
Nov 1 13:55:15 Slack kernel: EIP: 0060:[<c0138c50>] Not tainted VLI
Nov 1 13:55:15 Slack kernel: EFLAGS: 00010083 (2.6.23.1-smp #1)
Nov 1 13:55:15 Slack kernel: EIP is at queue_delayed_work_on+0x90/0xb0
Nov 1 13:55:15 Slack kernel: eax: f6147418 ebx: f6147414 ecx: f6147414 edx: 00000000
Nov 1 13:55:15 Slack kernel: esi: f6147424 edi: c18de380 ebp: ffffffff esp: c195df30
Nov 1 13:55:15 Slack kernel: ds: 007b es: 007b fs: 00d8 gs: 0000 ss: 0068
Nov 1 13:55:15 Slack kernel: Process events/1 (pid: 8, ti=c195c000 task=c1932550 task.ti=c195c000)
Nov 1 13:55:15 Slack kernel: Stack: f6147414 f7faac00 f6147400 f755ccc4 c0138cb1 00000bb8 f8d7ba9b f7a98f74
Nov 1 13:55:15 Slack kernel: f7a98f74 f8d7ea60 00000000 00000000 00000000 00000000 00000000 c1930000
Nov 1 13:55:15 Slack kernel: f8d7e4e0 f755ccf8 00000286 c18f0380 f6147414 f8d7ba40 c18f0384 c0138394
Nov 1 13:55:15 Slack kernel: Call Trace:
Nov 1 13:55:15 Slack kernel: [<c0138cb1>] queue_delayed_work+0x21/0x30
Nov 1 13:55:15 Slack kernel: [<f8d7ba9b>] ieee80211softmac_auth_queue+0x5b/0x1a0 [ieee80211softmac]
Nov 1 13:55:15 Slack kernel: [<f8d7ea60>] ieee80211softmac_notify_callback+0x0/0x92 [ieee80211softmac]
Nov 1 13:55:15 Slack kernel: [<f8d7e4e0>] ieee80211softmac_assoc_notify_auth+0x0/0x40 [ieee80211softmac]
Nov 1 13:55:15 Slack kernel: [<f8d7ba40>] ieee80211softmac_auth_queue+0x0/0x1a0 [ieee80211softmac]
Nov 1 13:55:15 Slack kernel: [<c0138394>] run_workqueue+0x74/0x100
Nov 1 13:55:15 Slack kernel: [<c013bd40>] autoremove_wake_function+0x0/0x50
Nov 1 13:55:15 Slack kernel: [<c0138e0c>] worker_thread+0x9c/0x100
Nov 1 13:55:15 Slack kernel: [<c013bd40>] autoremove_wake_function+0x0/0x50
Nov 1 13:55:15 Slack kernel: [<c0138d70>] worker_thread+0x0/0x100
Nov 1 13:55:15 Slack kernel: [<c013ba72>] kthread+0x42/0x70
Nov 1 13:55:15 Slack kernel: [<c013ba30>] kthread+0x0/0x70
Nov 1 13:55:15 Slack kernel: [<c0104e43>] kernel_thread_helper+0x7/0x14
Nov 1 13:55:15 Slack kernel: =======================
Nov 1 13:55:15 Slack kernel: Code: 13 c0 01 c2 85 ed 89 56 08 79 28 8b 7b 10 85 ff 75 34 89 f0 e8 c2 8a ff ff ba 01 00 00 00 89 d0 5b 5e 5f 5d c3 0f 0b eb fe 66 90 <0f> 0b eb fe 0f 0b eb fe 89 ea 89 f0 e8 4f 8d ff ff ba 01 00 00
Nov 1 13:55:15 Slack kernel: EIP: [<c0138c50>] queue_delayed_work_on+0x90/0xb0 SS:ESP 0068:c195df30
Nov 1 13:55:15 Slack kernel: Oops: 0000 [#2]
Nov 1 13:55:15 Slack kernel: SMP
Nov 1 13:55:15 Slack kernel: Modules linked in: capability commoncap lp joydev usb_storage zd1211rw ieee80211softmac ieee80211 ieee80211_crypt dvb_ttpci lnbp21 l64781 saa7146_vv psmouse video_buf snd_hda_intel serio_raw saa7146 videodev snd_pcm v4l2_common v4l1_compat ves1820 tda8083 sp8870 stv0297 ves1x93 snd_timer ttpci_eeprom ohci1394 stv0299 ieee1394 dvb_core k8temp hwmon snd soundcore ehci_hcd i2c_nforce2 snd_page_alloc ohci_hcd agpgart i2c_core fan evdev ns558 gameport sg rtc_cmos rtc_core rtc_lib button thermal processor pcspkr parport_pc parport reiserfs

Il bug è del driver della scheda wireless...
un driver fatto maluccio,visto che ogni tanto
tira problemi gravi(non è la prima volta che causa
degli ops)