Settare dpi con driver i810

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
lupix
Linux 1.x
Linux 1.x
Messaggi: 102
Iscritto il: dom nov 07, 2004 0:00
Nome Cognome: Luciano
Località: Los Angeles

Settare dpi con driver i810

Messaggioda lupix » gio mar 13, 2008 0:44

Ho un problema di font enormi che mi vede costretto ad utilizzare l'opzione -dpi per lanciare il server X. Se provo ad inserire le opzioni apposite in Xorg.conf il server
le ignora.
Le stringhe passate in device sono:

Codice: Seleziona tutto

Option "UseEditDpi" "false"
Option "DPI" "96 x 96"

In questo modo sono obbligato ad avviare in "init 3" per poter lanciare

Codice: Seleziona tutto

startx -- -dpi 96
che funge alla perfezione.
Come posso risolvere?
Uso Slackware current con kernel 2.6.23.16

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2416
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.17.2
Desktop: lxde
Località: Pisa
Contatta:

Re: Settare dpi con driver i810

Messaggioda ponce » gio mar 13, 2008 7:07

questa e' sporca: potresti togliere i pacchetti dei font a 75dpi in modo da forzargli l'uso dei 100 (o viceversa)

Avatar utente
conraid
Staff
Staff
Messaggi: 13110
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Settare dpi con driver i810

Messaggioda conraid » gio mar 13, 2008 11:24

Che scheda video hai?
Questo comando cosa ti dice?

Codice: Seleziona tutto

grep -i dpi /var/log/Xorg.0.log

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2416
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.17.2
Desktop: lxde
Località: Pisa
Contatta:

Re: Settare dpi con driver i810

Messaggioda ponce » gio mar 13, 2008 11:39

ho notato ora che l'opzione che hai specificato ha un errore di battitura

Codice: Seleziona tutto

Option "UseEditDpi" "false"

dovrebbe essere

Codice: Seleziona tutto

Option "UseEdidDpi" "false"

Avatar utente
mimmoforlug
Packager
Packager
Messaggi: 143
Iscritto il: lun dic 04, 2006 13:09
Nome Cognome: Domenico Suppa
Slackware: 13.37
Kernel: 3.2.11
Desktop: fluxbox
Località: Caserta
Contatta:

Re: Settare dpi con driver i810

Messaggioda mimmoforlug » ven mar 14, 2008 1:31

nel file /etc/kde/kdm/kdmrc
si può aggiungere l'opzione -dpi
nella sezione [X-:*-Core]
in questo modo

Codice: Seleziona tutto

ServerCmd=/usr/bin/X -br -dpi 96

Avatar utente
lupix
Linux 1.x
Linux 1.x
Messaggi: 102
Iscritto il: dom nov 07, 2004 0:00
Nome Cognome: Luciano
Località: Los Angeles

Re: Settare dpi con driver i810

Messaggioda lupix » mer mag 14, 2008 12:17

ponce ha scritto:ho notato ora che l'opzione che hai specificato ha un errore di battitura

Codice: Seleziona tutto

Option "UseEditDpi" "false"

dovrebbe essere

Codice: Seleziona tutto

Option "UseEdidDpi" "false"


No era solo un errore di battitura di tastiera nel forum.

mimmoforlug ha scritto:nel file /etc/kde/kdm/kdmrc
si può aggiungere l'opzione -dpi
nella sezione [X-:*-Core]
in questo modo

Codice: Seleziona tutto

ServerCmd=/usr/bin/X -br -dpi 96


Ho provato ma non funziona vedo sempre i caratteri giganti anzi enormi.

Comunque ho notato che facendo partire kde con l'opzione -dpi 92 consumo uno notevole quantita' di ram. :x
:-k
grep -i dpi /var/log/Xorg.0.log
(**) VESA(0): DPI set to (78, 92)
:-k
Linux 2.6.23.16-smp kde 3.5.9 su HP Compaq nx7300


Scusate il ritardo.
Sorry.

Avatar utente
urka58
Linux 3.x
Linux 3.x
Messaggi: 542
Iscritto il: mer dic 07, 2005 23:29

Re: Settare dpi con driver i810

Messaggioda urka58 » mer mag 14, 2008 17:11

Ultima modifica di urka58 il mer mag 14, 2008 19:43, modificato 1 volta in totale.

Avatar utente
robbybby
Linux 4.x
Linux 4.x
Messaggi: 1223
Iscritto il: sab dic 16, 2006 10:48
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5
Località: Fra Trantor e Terminus

Re: Settare dpi con driver i810

Messaggioda robbybby » mer mag 14, 2008 17:57

@urka58
Nel link non hai incluso la parentesi finale.

Avatar utente
urka58
Linux 3.x
Linux 3.x
Messaggi: 542
Iscritto il: mer dic 07, 2005 23:29

Re: Settare dpi con driver i810

Messaggioda urka58 » mer mag 14, 2008 19:45

@urka58
Nel link non hai incluso la parentesi finale.

Ho messo i tag URL, adesso dovrebbe funzionare
Ciao