Repository 32bit  Forum
Repository 64bit  Wiki

Problemi di tastiera in Kde..

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problemi di tastiera in Kde..

Messaggioda wacco » mer dic 10, 2003 13:20

Salve a tutti! <BR> Ho un piccolo problema con la tastiera in Kde.Il tastomaggiore/minore non funziona ne in Konsole ne da altre parti. Il layout impostato è IT e tutti gli altri tasti funzionano correttamente, ma se voglio usare il suddetto devo entrare in una console virtuale, il che è un po´ scomodo dato sto cercando di imparare un po´ di scripting con bash e il reindirizzamento mi è utile, anche se per adesso non indispensabile :-) Sono alle prime armi! Grazie per l´aiuto, <BR> Marco.<br>
wacco
Linux 1.0
Linux 1.0
 
Messaggi: 33
Iscritto il: mer dic 10, 2003 0:00

Problemi di tastiera in Kde..

Messaggioda useless » mer dic 10, 2003 14:08

smanetta con l´opzione <BR><!-- BBCode Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Code:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><PRE>Option "XkbModel" "pc102"</PRE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode End --> <BR>del tuo XF86Config<br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Problemi di tastiera in Kde..

Messaggioda Loris » mer dic 10, 2003 19:30

Marco ma che tastiera usi ? passaci la porzione "Core keyboard´s InputDevice section" del tuo XF86Config <BR><br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7583
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

Problemi di tastiera in Kde..

Messaggioda wacco » mer dic 10, 2003 20:47

Ciao! Queste sono le porzioni "attivate" della sezione, intendo senza # davanti: <BR>Section "InputDevice" <BR> <BR> Identifier "Keyboard1" <BR> Driver "Keyboard" <BR> Option "XkbRules" "xfree86" <BR> Option "XkbModel" "pc101" <BR> Option "XkbLayout" "it" <BR> <BR>EndSection <BR> <BR>Ho una tastiera scrausissima da 10 euro ( il PC è assemblato da me :-)) per cui non saprei dirti. Grazie ancora, <BR> Marco. <BR> <BR>ps. Ho notato che la bash mi da problemi sugli accenti.Se do il comando ls mi restituisce ? al posto dei suddetti ma a riga dicomando li posso scrivere e li riconosce perfettamente..<br>
wacco
Linux 1.0
Linux 1.0
 
Messaggi: 33
Iscritto il: mer dic 10, 2003 0:00

Problemi di tastiera in Kde..

Messaggioda Loris » mer dic 10, 2003 21:22

Prova con pc102 o pc105 :-) <br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7583
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

Problemi di tastiera in Kde..

Messaggioda wacco » ven dic 12, 2003 12:04

Ciao Lorys! Ho provato a mettere 102 ed ha funzionato.. Rimane però il problema di visualizzazione degli accenti..Adesso li fa vedere come \350 o \340, hai idea del perchè? Grazie ancora, <BR> Marco.<br>
wacco
Linux 1.0
Linux 1.0
 
Messaggi: 33
Iscritto il: mer dic 10, 2003 0:00

Problemi di tastiera in Kde..

Messaggioda Loris » ven dic 12, 2003 13:38

Anche 105 ti da lo stesso problema ?<br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7583
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

Problemi di tastiera in Kde..

Messaggioda wacco » ven dic 12, 2003 18:50

Con 105 non mi va neanche il tasto <> quindi non ho controllato il resto.. Poi ho scoperto che le /340 etc etc mi si visualizzano con la konsole, non con bash che continua a mettermi i ?. Ho provato a impostare la sessione in console come bash ma mi apre sempre quella sbagliata e devo poi richiamarla. Mah? Ciao, <BR> Marco.<br>
wacco
Linux 1.0
Linux 1.0
 
Messaggi: 33
Iscritto il: mer dic 10, 2003 0:00

Problemi di tastiera in Kde..

Messaggioda pado » ven dic 12, 2003 19:34

prova ad inserire direttamente in console questa riga: <BR>setxkbmap -rules xfree86 -model pc102 -layout "it" <BR> <BR>ciao pado <BR><br>
Avatar utente
pado
Linux 1.0
Linux 1.0
 
Messaggi: 77
Iscritto il: gio ott 09, 2003 23:00
Località: Mantova
Nome Cognome: Moreno P.
Slackware: 14.0 - 64 bit
Kernel: 3.2.28
Desktop: xfce 4.10
Distribuzione: SalixOS 64 14.0

Problemi di tastiera in Kde..

Messaggioda useless » ven dic 12, 2003 21:50

metti <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>export LANG=it_IT.ISO-8859-1</BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>in /etc/profile.d/lang.sh. <BR><br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Problemi di tastiera in Kde..

Messaggioda wacco » sab dic 13, 2003 17:46

OK!! Problema risolto! Grazie mille a tutti! Marco<br>
wacco
Linux 1.0
Linux 1.0
 
Messaggi: 33
Iscritto il: mer dic 10, 2003 0:00


Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti