[miniguida]webcam a righe verdi...

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
blackman85
Linux 2.4
Linux 2.4
Messaggi: 333
Iscritto il: dom giu 22, 2008 14:41
Slackware: 13.1 x86_64
Kernel: 2.6.33.4
Desktop: kde 4.4

[miniguida]webcam a righe verdi...

Messaggioda blackman85 » lun set 21, 2009 11:43

Ciao a tutti scrivo questa miniguida in cui spiego come rimuovere quelle fastidiose righe verdi dalla webcam.
Allora, di default nella slackware 13 viengono installati i driver spca5xx quindi a meno di inconvenienti tecnici la webcam risulta già funzionante (la mia webcam era quella logitech orbicam integrata sul notebook). Per verificare che effettivamente era funzionante sono andato a vedere se era presente il file:

Codice: Seleziona tutto

/dev/video0

Poi ho installato e avviato skype ed ecco che si è presentata l'amara sorpresa...quando sono andato nelle impostazioni la webcam funzionava correttamente ma mi presentava delle righe verdi in verticale, praticamente era impossibile distinguere il volto. Fatte un pò di ricerche ho capito che il problema era legato ad un bug delle librerie v4l e quindi ho risolto in questa maniera:

1) Ho scaricato dal repository di slacky e aggiornato le librerie v4l alla versione 0.6.1 (il pacchetto è libv4l-0.6.1-i686-1as)
2) Con vim ho aperto il file "etc/profile" ed ho aggiunto in fondo la seguente riga:

Codice: Seleziona tutto

export LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so

3) Ho riavviato e ho constatato con grande gioia che le righe verdi sono sparite! (testata con cheese,skype,ams...)

Spero di aver fatta cosa gradita..... :thumbright:

Avatar utente
conraid
Staff
Staff
Messaggi: 12726
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: [miniguida]webcam a righe verdi...

Messaggioda conraid » lun set 21, 2009 12:14

blackman85 ha scritto:Spero di aver fatta cosa gradita..... :thumbright:

viewtopic.php?f=2&t=2846

Avatar utente
blackman85
Linux 2.4
Linux 2.4
Messaggi: 333
Iscritto il: dom giu 22, 2008 14:41
Slackware: 13.1 x86_64
Kernel: 2.6.33.4
Desktop: kde 4.4

Re: [miniguida]webcam a righe verdi...

Messaggioda blackman85 » lun set 21, 2009 12:18

conraid ha scritto:
blackman85 ha scritto:Spero di aver fatta cosa gradita..... :thumbright:

viewtopic.php?f=2&t=2846


non ho capito la relazione con imagemagic... :oops:

Avatar utente
conraid
Staff
Staff
Messaggi: 12726
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: [miniguida]webcam a righe verdi...

Messaggioda conraid » lun set 21, 2009 12:34

viewtopic.php?f=2&t=28469
si era perso un 9

Avatar utente
blackman85
Linux 2.4
Linux 2.4
Messaggi: 333
Iscritto il: dom giu 22, 2008 14:41
Slackware: 13.1 x86_64
Kernel: 2.6.33.4
Desktop: kde 4.4

Re: [miniguida]webcam a righe verdi...

Messaggioda blackman85 » lun set 21, 2009 12:38

Non avevo visto quel post....comunque ben venga! :thumbright:


Torna a “Slackware”

Chi c’è in linea

Visitano il forum: Google [Bot] e 4 ospiti