Repository 32bit  Forum
Repository 64bit  Wiki

avvio automatico di X

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

avvio automatico di X

Messaggioda giacomo » sab gen 10, 2004 12:51

ho slackware 9.1 <BR>come faccio ad impostare l´avvio automatico di X ad accensione computer. Inoltre come posso fare perche´ in un utente ci sia anche il pulsante spegni il computer e riavvia (mentre ho solo "termina la sessione nomeutente")<br>
giacomo
Linux 1.0
Linux 1.0
 
Messaggi: 70
Iscritto il: sab ott 04, 2003 23:00

avvio automatico di X

Messaggioda Loris » sab gen 10, 2004 13:43

<!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>come faccio ad impostare l´avvio automatico di X ad accensione computer.</BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR>Per questo ti basta modificare il file /etc/inittab modificando il runlevel da 3 a 4 <BR># Default runlevel. (Do not set to 0 or 6) <BR>id:3:initdefault: <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>Inoltre come posso fare perche´ in un utente ci sia anche il pulsante spegni il computer e riavvia</BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR>Di default Slack usa GDM puoi usare KDM che dovrebbe avere i pulsanti spegni (mi pare) per avere kdm devi modificare il file /etc/rc.d/rc.4 decommentando tutte le righe riguardanti GDM <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE> # Try to use GNOME´s gdm session manager: <BR>#if [ -x /usr/bin/gdm ]; then <BR># exec /usr/bin/gdm -nodaemon <BR>#fi </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --><br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7578
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

avvio automatico di X

Messaggioda giacomo » sab gen 10, 2004 15:08

tuttavia ora ho questo problema che prima non avevo. Andando in modalita´ root e poi lanciando il comando p.e. "emacs" (o un altro che richiede X) <BR>mi dice: <BR> <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE> <BR>root@localhost:/home/yago# emacs <BR>Xlib: connection to ":0.0" refused by server <BR>Xlib: No protocol specified <BR> <BR>emacs: Cannot connect to X server :0.0. <BR>Check the DISPLAY environment variable or use `-d´. <BR>Also use the `xhost´ program to verify that it is set to <BR>connections from your machine. <BR></BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>Sai come posso correggere? <BR> <BR><br>
giacomo
Linux 1.0
Linux 1.0
 
Messaggi: 70
Iscritto il: sab ott 04, 2003 23:00

avvio automatico di X

Messaggioda johnnystuff » sab gen 10, 2004 16:04

le cose sono due: o ti logghi come root (e non "diventi" root con su nè su -) oppure se la shell di login è di "utente_normale" devi specificare su quale display avviare il serverX. Quindi in questo caso: <BR>$xhost +localhost /*se vuoi anche sapere che vuol dire....man xhost! */ <BR>$su - <BR>password:xxxx <BR>#export DISPLAY=:0.0 /*specifichi su quale screen lanci X */ <BR>#emacs || kate || quel_che_ti_pare <BR> <BR>questo è un comportamento assolutamente rigoroso dell´uso del server X, che viene non si sa perchè trascurato in molte altre distro che noi tutti disprezziamo e aborriamo! <BR>Ciao jente! <BR><br>
johnnystuff
Linux 1.0
Linux 1.0
 
Messaggi: 1
Iscritto il: lun dic 01, 2003 0:00

avvio automatico di X

Messaggioda useless » dom gen 11, 2004 4:05

prima di diventare root devi fare, ancora dal tuo utente: <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>xhost +</BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>altrimenti la connessione al server grafico da parte delle applicazioni che non appartengono allo stesso utente a cui appartiene il server verrà rifiutata. <BR>purtroppo lo devi fare ogni volta che lanci X. ci si dovrebbe poter ovviare modificando /etc/X0.hosts ma da me questa cosa non funziona :-(.<br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name


Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 3 ospiti