Changelog Jan 4 21:43:02 2010: aggiorna il kernel? [RISOLTO]

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Bart
Staff
Staff
Messaggi: 4249
Iscritto il: lun ago 09, 2004 0:00
Località: Rimini

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda Bart » mar gen 05, 2010 19:03

Io per non avere problemi con i driver nvidia li disinstallo prima di passare al nuovo kernel ricompilato. Poi faccio il reboot con il nuovo kernel e li reinstallo.

@Toni: Grazie, adesso controllo quelle opzioni.

Avatar utente
daniele50
Linux 3.x
Linux 3.x
Messaggi: 964
Iscritto il: mar apr 10, 2007 13:58
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.1
Kernel: 3.10.17
Desktop: Xfce 4.10
Località: San Zenone al Lambro (MI)
Contatta:

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda daniele50 » mar gen 05, 2010 19:13

E' successo ancora quello che mi era successo l'altra volta:
avviando virtualbox mi dice di lanciare rc.vboxdrv setup, lo lancio e:

Codice: Seleziona tutto

# ./rc.vboxdrv setup
Stopping VirtualBox kernel module ...done.
Recompiling VirtualBox kernel module ...failed!
  (Look at /var/log/vbox-install.log to find out what went wrong)


Anche se seguo la guida il kernel non si aggiorna correttamente, non so perché e non so neanche cosa guardare, ecco alcuni dettagli:

Codice: Seleziona tutto

uname -a
Linux slacky 2.6.32.2-smp #2 SMP Thu Dec 31 15:22:43 CST 2009 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 5000+ AuthenticAMD GNU/Linux


Codice: Seleziona tutto

/boot# ls -l
total 20376
lrwxrwxrwx 1 root root      37 2010-01-04 17:12 README.initrd -> /usr/doc/mkinitrd-1.3.4/README.initrd
lrwxrwxrwx 1 root root      32 2010-01-05 17:17 System.map -> System.map-huge-smp-2.6.32.2-smp
-rw-r--r-- 1 root root 1134129 2009-12-31 22:51 System.map-generic-2.6.32.2
-rw-r--r-- 1 root root 1187122 2009-12-31 21:58 System.map-generic-smp-2.6.32.2-smp
-rw-r--r-- 1 root root 1795843 2009-12-31 23:10 System.map-huge-2.6.32.2
-rw-r--r-- 1 root root 1860364 2009-12-31 22:23 System.map-huge-smp-2.6.32.2-smp
-rw-r--r-- 1 root root     512 2009-09-02 13:46 boot.0800
-rw-r--r-- 1 root root     512 2009-09-29 19:23 boot.0830
-rw-r--r-- 1 root root     168 2009-09-02 13:46 boot_message.txt
lrwxrwxrwx 1 root root      28 2010-01-05 17:17 config -> config-huge-smp-2.6.32.2-smp
-rw-r--r-- 1 root root  102993 2009-12-31 22:51 config-generic-2.6.32.2
-rw-r--r-- 1 root root  103375 2009-12-31 21:58 config-generic-smp-2.6.32.2-smp
-rw-r--r-- 1 root root  103011 2009-12-31 23:10 config-huge-2.6.32.2
-rw-r--r-- 1 root root   66965 2010-01-05 18:12 config-huge-smp-2.6.32.2-smp
-rw-r--r-- 1 root root    5040 2008-11-29 19:43 diag1.img
-rw------- 1 root root  130048 2010-01-05 17:42 map
-rw-r--r-- 1 root root   15754 2008-02-22 01:08 slack.bmp
lrwxrwxrwx 1 root root      29 2010-01-05 17:17 vmlinuz -> vmlinuz-huge-smp-2.6.32.2-smp
-rw-r--r-- 1 root root 2239168 2009-12-31 22:51 vmlinuz-generic-2.6.32.2
-rw-r--r-- 1 root root 2363056 2009-12-31 21:58 vmlinuz-generic-smp-2.6.32.2-smp
-rw-r--r-- 1 root root 4731936 2009-12-31 23:10 vmlinuz-huge-2.6.32.2
-rw-r--r-- 1 root root 4914224 2009-12-31 22:23 vmlinuz-huge-smp-2.6.32.2-smp


Codice: Seleziona tutto

/usr/src# ls -l
total 8
lrwxrwxrwx  1 root root   14 2010-01-05 17:38 linux -> linux-2.6.32.2
drwxr-xr-x 24 root root 4096 2010-01-05 19:05 linux-2.6.32.2
drwxr-xr-x  3 root root 4096 2009-09-01 15:51 openoffice-autobuilder-multilang


Ma è così complicato? E' la quarta volta che provo a ricompilare/aggiornare il kernel, ma non arrivo mai in fondo e alla fine non si riesce a capire perché... l'unica cosa positiva è che questa volta l'ho fatto su una root di test (vedendo come sono finite le altre volte...). Io vorrei imparare a ricompilarlo, ci sbatto la testa ma non ne esco...

EDIT

forse ho trovato qualcosa di utile:

Codice: Seleziona tutto

/usr/src# more /var/log/vbox-install.log
Makefile:163: *** Error: /usr/src/linux (version 2.6.32.2) does not match the current kernel (version 2.6.32.2-smp).  Stop.


Prima avevo la 2.6.29.6-smp, perché ora ho il kernel 2.6.32.2-smp e i sorgenti della 2.6.32.2???

Avatar utente
corrado
Linux 2.x
Linux 2.x
Messaggi: 218
Iscritto il: dom feb 13, 2005 0:00
Nome Cognome: corrado
Slackware: current
Kernel: 2.6.29.6-smp
Desktop: kde-4
Località: isola del liri
Contatta:

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda corrado » mar gen 05, 2010 19:29

Ciao a tutti,
ho fatto anche io l'aggiornamento ma sto avendo molti problemi:
1) non va più la scheda wireless;
2) se do il comando lsmod non mi da alcun modulo :(
3) driver video nvidia che non riesco ad installare.

Sono in alto mare...


Saluti
corrado

Avatar utente
daniele50
Linux 3.x
Linux 3.x
Messaggi: 964
Iscritto il: mar apr 10, 2007 13:58
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.1
Kernel: 3.10.17
Desktop: Xfce 4.10
Località: San Zenone al Lambro (MI)
Contatta:

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda daniele50 » mar gen 05, 2010 20:39

Se ti può consolare io sto rifacendo tutto, ma questa volta seguo la sezione Compilazione Nuovo Kernel Serie 2.6.xx della guida http://www.slacky.eu/wikislack/index.ph ... _Slackware

Sto seguendo passo-passo, compreso il download del nuovo kernel... ti dirò poi come sarà andata...

Avatar utente
corrado
Linux 2.x
Linux 2.x
Messaggi: 218
Iscritto il: dom feb 13, 2005 0:00
Nome Cognome: corrado
Slackware: current
Kernel: 2.6.29.6-smp
Desktop: kde-4
Località: isola del liri
Contatta:

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda corrado » mar gen 05, 2010 21:26

corrado ha scritto:Ciao a tutti,
ho fatto anche io l'aggiornamento ma sto avendo molti problemi:
1) non va più la scheda wireless;
2) se do il comando lsmod non mi da alcun modulo :(
3) driver video nvidia che non riesco ad installare.

Sono in alto mare...


Saluti
corrado


Ho rifatto un upgradepkg --reinstall dei pacchetti dell'aggiornamento del 4 gennaio (sempre in init 1) ed ora i punti 2) e 3) sembrano risolti.
Ho ancora un problema con il wireless: in pratica ho messo alcuni comandi in rc.local che mi "avviano" la scheda, le danno l'indirizzo IP e l'indirizzo del gateway. Ora pingo l'interfaccia del mio pc ma non pingo il router a meno di non ridare da root il comando:
/etc/rc.d/rc.local restart

Idee?

Saluti
corrado

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3513
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda Trotto@81 » mar gen 05, 2010 21:59

Anche io aggiornando i pacchetti del kernel ho sempre avuto grossi problemi, non sono mai riuscito a capite il perchè!!
Mi lascia file del vecchio kernel, tipo modules.conf linkato al kernel precedente e altre cosucce.

Avatar utente
slux
Linux 3.x
Linux 3.x
Messaggi: 789
Iscritto il: dom mar 20, 2005 0:00
Nome Cognome: Andrea Amerini
Slackware: 14.1 x86
Kernel: 3.12.0-smp
Desktop: xfce 4.10
Località: Prato
Contatta:

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda slux » mar gen 05, 2010 23:19

Per chi usa il kernel smp generic di Pat e poi aggiorna con quello nuovo, si deve ricordare che è tassativo:
1)Rigenerare il file initrd
2)Assicurarsi che il link /usr/src/linux punti alla directory dei sorgenti giusti(controllare con uname -a)
3)Ricompilare i driver nvidia /ati , virtualbox,vmware ed eventuali driver esterni al kernel(webcam,schede wireless etc...)
4)Lanciate lilo!!!!

Io per semplificarmi la vita,non ho mai usato il kernel di Pat sulle mie macchine personali,non uso initrd e tolgo lilo in favore di grub. :badgrin:

Bart
Staff
Staff
Messaggi: 4249
Iscritto il: lun ago 09, 2004 0:00
Località: Rimini

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda Bart » mar gen 05, 2010 23:26

slux ha scritto:Io per semplificarmi la vita,non ho mai usato il kernel di Pat sulle mie macchine personali,non uso initrd...
Ti appoggio in tutto ma spesso l'uso di initrd non è una scelta...voluta. :)

Avatar utente
slux
Linux 3.x
Linux 3.x
Messaggi: 789
Iscritto il: dom mar 20, 2005 0:00
Nome Cognome: Andrea Amerini
Slackware: 14.1 x86
Kernel: 3.12.0-smp
Desktop: xfce 4.10
Località: Prato
Contatta:

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda slux » mar gen 05, 2010 23:39

Initrd è necessario per le partizioni criptate immagino,ma poi?Ammetto la mia ignoranza qui...

Avatar utente
ermes
Linux 2.x
Linux 2.x
Messaggi: 372
Iscritto il: dom feb 20, 2005 0:00
Slackware: current 64
Desktop: kde
Località: Rho (Mi)

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda ermes » mer gen 06, 2010 9:35

nessuno ha provato con "slackpkg upgrade-all" ?

risultati ?

Avatar utente
daniele50
Linux 3.x
Linux 3.x
Messaggi: 964
Iscritto il: mar apr 10, 2007 13:58
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.1
Kernel: 3.10.17
Desktop: Xfce 4.10
Località: San Zenone al Lambro (MI)
Contatta:

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda daniele50 » mer gen 06, 2010 10:17

Se non ho capito male bart l'ha fatto (guarda il post nella pagina precedente) e ha avuto qualche problema.
Anch'io ho provato, ho dovuto però disinstallare i driver nvidia altrimenti non partiva kde, poi però non sono riuscito più ad installarli. Anche virtualbox mi dava problemi dicendomi che usavo il kernel 2.6.32.2-smp ma avevo i sorgenti del 2.6.32.2. Io sto provando su una distro di test e quindi sono tornato alla 2.6.29.6... adesso vorrei provare ad installare il nuovo kernel senza eliminare quello vecchio (mettendo due avvii in lilo) ma sinceramente ho le idee un po' confuse... #-o

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3513
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda Trotto@81 » mer gen 06, 2010 10:37

daniele50 ha scritto:Se non ho capito male bart l'ha fatto (guarda il post nella pagina precedente) e ha avuto qualche problema.
Anch'io ho provato, ho dovuto però disinstallare i driver nvidia altrimenti non partiva kde, poi però non sono riuscito più ad installarli. Anche virtualbox mi dava problemi dicendomi che usavo il kernel 2.6.32.2-smp ma avevo i sorgenti del 2.6.32.2. Io sto provando su una distro di test e quindi sono tornato alla 2.6.29.6... adesso vorrei provare ad installare il nuovo kernel senza eliminare quello vecchio (mettendo due avvii in lilo) ma sinceramente ho le idee un po' confuse... #-o

L'smp nella 13 non c'è più, c'è il generic che richiede initrd e l'huge.
Se usi huge bisgona fare l'upgrade di questi:
http://www.slackware.at/data/slackware6 ... arch-1.txz
http://www.slackware.at/data/slackware6 ... 6_64-1.txz
http://www.slackware.at/data/slackware6 ... 6_64-1.txz
Non vedo l'utilità di usare slackpkg che crea solo confusione.
Ovvio che i driver nvidia vanno disinstallati prima, e ancor prima controllare che siano compatibili con il nuovo kernel.
Poi ti controlli il link modules.conf e quello ai sorgenti e aggiorni il lilo.
Il mio discorso non fa una piega, peccato che in pratica non ha mai funzionato.

Avatar utente
daniele50
Linux 3.x
Linux 3.x
Messaggi: 964
Iscritto il: mar apr 10, 2007 13:58
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.1
Kernel: 3.10.17
Desktop: Xfce 4.10
Località: San Zenone al Lambro (MI)
Contatta:

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda daniele50 » mer gen 06, 2010 10:54

L'smp nella 13 non c'è più

io ho installato la 13 dal dvd ufficiale che è uscito ad agosto e il kernel che di default è huge-smp-2.6.29.6-smp, e poi nel changelog c'è a/kernel-huge-smp-2.6.32.2_smp-i686-1.txz: Upgraded.

Il mio discorso non fa una piega, peccato che in pratica non ha mai funzionato.

rassicurante...

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3513
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda Trotto@81 » mer gen 06, 2010 11:26

daniele50 ha scritto:
L'smp nella 13 non c'è più

io ho installato la 13 dal dvd ufficiale che è uscito ad agosto e il kernel che di default è huge-smp-2.6.29.6-smp, e poi nel changelog c'è a/kernel-huge-smp-2.6.32.2_smp-i686-1.txz: Upgraded.

Perdonami, mi riferivo alla slackware64, dò per scontato che tutti usino questa oramai.
In ogni caso anche sulla 32bit non ha mai funzionato a dovere.

erio
Linux 4.x
Linux 4.x
Messaggi: 1193
Iscritto il: ven ott 09, 2009 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Changelog Mon Jan 4 21:43:02 UTC 2010: aggiorna il kernel?

Messaggioda erio » mer gen 06, 2010 12:06

ciao, i driver nvidia quando li installi lo creano loro il modulo per il kernel che hai installato,non vanno se, il compilatore è diverso come versione tra la vecchia e la nuova installazione