Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
play593
Linux 0.x
Linux 0.x
Messaggi: 11
Iscritto il: ven ott 08, 2010 3:28
Nome Cognome: Giuseppe Sanna
Slackware: 13.1
Desktop: KDE

Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda play593 » mar nov 02, 2010 16:31

Salve a tutti!

Inizio premettendo che sono nuovo del mondo Slackware, ho avuto delle fantastiche esperienze con Linux: infatti nei miei portatili è rigorosamente installato Ubuntu, però per il PC Desktop di casa volevo azzardare qualcosa di nuovo, quindi dopo vari sondaggi ho scelto di installare Slackware, anche perchè è l'unica ce funge sul mio Desktop: Ubuntu, Mandriva, Fedora, Debian, OpenSuSe...per un motivo o per l'altro non funzionano!

Comunque, tornando al problema...io praticamente ho appena installato l'S.O. nel mio computer e ho riscontrato il problema che non è assolutamente connesso ad internet! Ho provato sia attaccando il Modem a mezzo USB che ad Ethernet e in nessuno dei due casi ho avuto risposta o segno di vita da parte del computer, e lo stesso con una penna Wireless! Neanche quella è stata riconosciuta...:( Probabilmente la mia è una richiesta stupida, banale e imprecisa....ma confido nella vostra pazienza e vi ringrazio qualora decidiate di dare una mano, a una povera anima che non sà che pesci pigliare! :roll:

Grazie a tutti quanti amici!! :thumbright:

P.S. Ho la Slackware 13.1!

sircello
Linux 1.x
Linux 1.x
Messaggi: 108
Iscritto il: dom gen 02, 2005 0:00
Nome Cognome: Natale Sircello
Slackware: Slackware 64 current
Kernel: Kernel 4.4.9
Desktop: KDE 4.14.14
Località: Campobello di Mazara

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda sircello » mar nov 02, 2010 17:09

cosa hai modem su scheda router , se hai un router già configurarato ed un collegamento ethenet , prova ad usare il comando netconfig , comuque leggiti Slackware for dummies , lo trovi su questo sito è una ottima guida ,alla pagina 224
ciao.

Avatar utente
navajo
Staff
Staff
Messaggi: 3884
Iscritto il: gio gen 08, 2004 0:00
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)
Località: Roma

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda navajo » mar nov 02, 2010 19:02

Come dice Paoletta, non avresti aver problemi a connetterti attraverso un router adsl. In teoria basta configurare la tua slackware in modalità DHCP-
Però ho un dubbio: come mai tante distro, con riconoscimento hardware, anche più avanzato di slackware non funziona ? è un pc anzianotto ??? vedi, per prima cosa, se slackware ti riconosce la tua scheda ethernet. dai questo comando da root:

Codice: Seleziona tutto

#lspci | grep -i eth

se l output che leggerai, sarà il modello della tua scheda, procedi con la configurazione.

play593
Linux 0.x
Linux 0.x
Messaggi: 11
Iscritto il: ven ott 08, 2010 3:28
Nome Cognome: Giuseppe Sanna
Slackware: 13.1
Desktop: KDE

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda play593 » mer nov 03, 2010 18:20

navajo ha scritto:Come dice Paoletta, non avresti aver problemi a connetterti attraverso un router adsl. In teoria basta configurare la tua slackware in modalità DHCP- [...]


Uhm...Ovvero?? :?


[...] Però ho un dubbio: come mai tante distro, con riconoscimento hardware, anche più avanzato di slackware non funziona ? è un pc anzianotto ??? [...]


Affatto! Il PC è nuovo...6GB di RAM, Scheda video da 512, HarDisk da 600GB...ed è proprio questo il problema! Adesso probabilmente faccio una cosa per cui mi linceranno! :lol: Leggi questo post: è relativo al mio PC Desktop, l'ho scritto apposta io! E per questo motivo non funge Ubuntu, poi per altri non funziona in altre distro: su Debian mi dà "Input not supported".
Il link: http://forum.ubuntu-it.org/index.php/topic,411460.msg3217611.html#msg3217611


[...] vedi, per prima cosa, se slackware ti riconosce la tua scheda ethernet. dai questo comando da root:

Codice: Seleziona tutto

#lspci | grep -i eth

se l output che leggerai, sarà il modello della tua scheda, procedi con la configurazione.


Allora, francamente non riesco a scrivere questo comando! La tastiera deve essere configurata in qualche stramba combinazione che mi dà tutto sballato! Durante l'installazione ho rigorosamente selezionato la mappatura italiana, eppure non sò perchè non è italiana l'attuale mappatura! Sapresti dirmi come cambiarla nuovamente? Utilizzo KDE! :D

A proposito! Grazie mille!!! :D

play593
Linux 0.x
Linux 0.x
Messaggi: 11
Iscritto il: ven ott 08, 2010 3:28
Nome Cognome: Giuseppe Sanna
Slackware: 13.1
Desktop: KDE

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda play593 » mer nov 03, 2010 18:26

sircello ha scritto:cosa hai modem su scheda router , se hai un router già configurarato ed un collegamento ethenet , prova ad usare il comando netconfig , comuque leggiti Slackware for dummies , lo trovi su questo sito è una ottima guida ,alla pagina 224
ciao.


Allora, io ho un router, al quale ho tentato di accedere tramite una penna wireless che purtroppo non mi ha riconosciuto Slacky! Se questa pennina, con Ubuntu viene riconosciuta appena inserita, lui non ci è riuscito! Comunque, questo non è un problema! Io sono interessato a collegare il mio modem Digicom con il mio computer a mezzo USB.
Comunque, ho provato a dare

Codice: Seleziona tutto

netconfig

Però l'esito non è tanto carino!

Codice: Seleziona tutto

bash: netconfig: command not found

Da quanto ricordo, in un manuale su linux, qualche giorno fa' ho letto che ci sono tanti modi di terminale(perdonatemi ma non mi viene il termine giusto...azzarderei linguaggi di terminale? :roll: ) come bash e altri! Non è che magari questo comando non è in bash? Anche perchè non capisco quale altra soluzione possa essere perchè non viene letto un comando così banale! :(

Comunque, grazie mille anche a te! Ora dò un'occhiata al PDF da te segnalatomi! :thumbright:

play593
Linux 0.x
Linux 0.x
Messaggi: 11
Iscritto il: ven ott 08, 2010 3:28
Nome Cognome: Giuseppe Sanna
Slackware: 13.1
Desktop: KDE

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda play593 » mer nov 03, 2010 18:31

Comunque, ho provato a dare

Codice: Seleziona tutto

netconfig

Però l'esito non è tanto carino!

Codice: Seleziona tutto

bash: netconfig: command not found

Da quanto ricordo, in un manuale su linux, qualche giorno fa' ho letto che ci sono tanti modi di terminale(perdonatemi ma non mi viene il termine giusto...azzarderei linguaggi di terminale? :roll: ) come bash e altri! Non è che magari questo comando non è in bash? Anche perchè non capisco quale altra soluzione possa essere perchè non viene letto un comando così banale! :(


Pardon! :oops:
Mea culpa est! Non ero loggato da root!

play593
Linux 0.x
Linux 0.x
Messaggi: 11
Iscritto il: ven ott 08, 2010 3:28
Nome Cognome: Giuseppe Sanna
Slackware: 13.1
Desktop: KDE

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda play593 » mer nov 03, 2010 19:04

Allora...ho seguito i vostri consigli e ora vi faccio un piccolo resoconto, sperando nella benevolenza di qualcuno di voi che mi sappia risolvere questo problemone! Perché tutt'ora sto rimanendo con un PC piantato che è pressoché un soprammobile senza internet! :(

Allora, innanzitutto ho provato a dare da terminale, da root( :D ):

Codice: Seleziona tutto

lspci | grep -i eth

L'esito è il seguente:
Immagine

Quindi, credo proprio sia una cosa positiva! Posso quindi stare tranquillo che la mia rete è riconosciuta!
Resta però il fato che io in internet non ci entro! :(
Quindi ho tentato poi con il comando, da root,:

Codice: Seleziona tutto

netconfig

A questo punto ho avuto una finestra semi-grafica dove mi chiedeva di configurare hostname e dominio e poi cosa scegliere come metodo: io ho, in ordine scelto: "localhost,localdominio.org,DHCP". Fatto questo ho ritentato a dare il comando ma mi appariva la medesima finestra di configurazione; a quel punto ho detto: Beh....evidentemente non salva i parametri? Eppure i parametri li salva alla grande: mi è bastato andare su "/etc/HOSTNAME" e il nome da me scelto: "localhost" era correttamente salvato.
Comunque, ho fatto anche uno screen di questa finestra, eccola:
Immagine

Mentre di seguito, degli screen al mio desktop per farvi capire in che condizioni è la mia configurazione internet:
Immagine
Immagine
Immagine

Spero che qualcuno ci capisca qualcosina in più di me!! [-o<
Comunque, grazie anticipatamente a tutti!! :D

Avatar utente
manny
Linux 2.x
Linux 2.x
Messaggi: 278
Iscritto il: mer ott 29, 2003 0:00
Slackware: 13.1 (fisso)
Kernel: 2.6.33.4
Desktop: kde
Distribuzione: Debian 5 (notebook)

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda manny » mer nov 03, 2010 19:51

mah, ripartiamo da zero.

Collega il pc con slack al router con il cavo ethernet.

Lancia il comando netconfig, e attribuisci un ip fisso al tuo pc (lascia momentaneamente perdere il dhcp) della stessa classe del tuo router (192.168.ecc ecc per esempio, e con la stessa sottorete 255.ecc.ecc.)

Lancia ping sull'indirizzo ip che hai assegnato sopra. Se risponde la scheda di rete è ok, procedi quindi a pingare il router.

Se anche il router risponde ti rimane solo da modificare il file resolv.conf in caso non riuscissi a navigare, inserendo un dns valido (208.67.222.222 per esempio).

Se non funzia, ci risentiamo.

Ciao.
Manny

play593
Linux 0.x
Linux 0.x
Messaggi: 11
Iscritto il: ven ott 08, 2010 3:28
Nome Cognome: Giuseppe Sanna
Slackware: 13.1
Desktop: KDE

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda play593 » mer nov 03, 2010 20:58

manny ha scritto:mah, ripartiamo da zero.

Collega il pc con slack al router con il cavo ethernet.
[...]
Ciao.
Manny


Ma io voglio collegare il Modem con il PC tramite USB.
Il router con Slacky non deve comunicare! ANche perchè il fisso non ha WiFi.
Io avendo il modem e il router separati(due apparecchi distinti) collegati tra loro con Ethernet, a me interessa che il mode USB si colleghi al PC con il cavo USB.

Cosa devo fare quindi? :)

Avatar utente
manny
Linux 2.x
Linux 2.x
Messaggi: 278
Iscritto il: mer ott 29, 2003 0:00
Slackware: 13.1 (fisso)
Kernel: 2.6.33.4
Desktop: kde
Distribuzione: Debian 5 (notebook)

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda manny » mer nov 03, 2010 21:12

Non capisco: vuoi usare il modem per navigare e non vuoi collegamento del pc con il router...ma: con che cosa navighi??? con il router o con il modem?

E quindi, il router a cosa ti serve? Il router, è anche modem (se è un router...)

Più info please!

play593
Linux 0.x
Linux 0.x
Messaggi: 11
Iscritto il: ven ott 08, 2010 3:28
Nome Cognome: Giuseppe Sanna
Slackware: 13.1
Desktop: KDE

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda play593 » mer nov 03, 2010 21:34

Aaaallora...Mi spiego meglio! Sono un pochetto confuso, lo sò! #-o
Allora... Io ho collegato alla presa del telefono un MODEM Digicom che funge solo come Modem; esso è collegato alla corrente elttrica, al computer(protagonista di questa discussione con installato Slacky) tramite un cavo USB ed inoltre il modem è collegato a un semplice router SparkLan tramite cavo ethernet. Ciò che voglio fare io è navigare in rete tramite la connessione USB tra PC fisso e Modem; mentre il router non c'entra nulla; lo uso per collegare i portatili con WiFi, quindi non c'entra niente.
Quello che voglio fare io quindi, è collegare il modem al PC con un cavo USB. Io sia con Windows(ai tempi in cui ero scemo... :roll:) che con Ubuntu collego i PC al modem con USB; Windows necessitava di driver, mentre Ubuntu riconosceva tutto automaticamente.
Comunque, ora sono stato chiaro?? :oops:

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda phobos3576 » mer nov 03, 2010 21:56

Prova a staccare il cavetto USB del modem, poi apri un terminale, digita:

Codice: Seleziona tutto

tail -f /var/log/messages

ricollega il modem alla porta USB e guarda che messaggi compaiono.

Avatar utente
manny
Linux 2.x
Linux 2.x
Messaggi: 278
Iscritto il: mer ott 29, 2003 0:00
Slackware: 13.1 (fisso)
Kernel: 2.6.33.4
Desktop: kde
Distribuzione: Debian 5 (notebook)

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda manny » mer nov 03, 2010 22:17

play593 ha scritto:Aaaallora...Mi spiego meglio! Sono un pochetto confuso, lo sò! #-o
Allora... Io ho collegato alla presa del telefono un MODEM Digicom che funge solo come Modem; esso è collegato alla corrente elttrica, al computer(protagonista di questa discussione con installato Slacky) tramite un cavo USB ed inoltre il modem è collegato a un semplice router SparkLan tramite cavo ethernet. Ciò che voglio fare io è navigare in rete tramite la connessione USB tra PC fisso e Modem; mentre il router non c'entra nulla; lo uso per collegare i portatili con WiFi, quindi non c'entra niente.
Quello che voglio fare io quindi, è collegare il modem al PC con un cavo USB. Io sia con Windows(ai tempi in cui ero scemo... :roll:) che con Ubuntu collego i PC al modem con USB; Windows necessitava di driver, mentre Ubuntu riconosceva tutto automaticamente.
Comunque, ora sono stato chiaro?? :oops:


Scusa se insisto ma: il router, fa anche da modem? se si lascia perdere il digicom e utilizza direttamente il router...tanto, cosa cambia?

In caso contrario, segui il consiglio di Phobos.

ciao

Avatar utente
voulaz
Linux 0.x
Linux 0.x
Messaggi: 39
Iscritto il: lun ott 09, 2006 14:53
Slackware: 12.0
Desktop: KDE
Località: Milano

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda voulaz » mer nov 03, 2010 23:37

Provo a ricapitolare per vedere se ho capito bene come è configurata la tua rete:

1. Modem Digicom collegato alla linea ADSL della presa telefonica.
2. Router SparkLan collegato tramite cavo di rete al modem.
3. Portatili collegati via WiFi al Router.
4. PC Fisso collegato tramite cavo USB al Modem.

Se è questa la tua configurazione possiamo fare alcune considerazioni ed ulteriori domande:
1. Immagino che il modem non sia WiFi ed abbia una sola porta ethernet (Che modello è?)
2. Il router invece (solo router vero? non modem-router. Modello?) immagino proprio che abbia più porte ethernet. Perchè non ti colleghi a una di queste porte del router con un cavo ethernet?
3. I portatili collegati WiFi con il router riescono a navigare in Internet? Se si, un motivo in più per collegarsi al router. (Se no, va configurato opportunamente.)
4. Se proprio devi collegarti al modem con un cavo USB, forse manca (o non è caricato) il driver adatto che a quanto pare su Ubuntu c'è. Segui il consiglio di Phobos per vedere come il modem viene riconosciuto dal sistema.

PS. Scusa se ti facciamo tutte queste domande, ma di solito si usa il collegamento USB solo quando non è possibile connettersi in altri modi.

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Non funziona internet: ne con ethernet, ne USB, ne WiFi!

Messaggioda phobos3576 » mer nov 03, 2010 23:43

voulaz ha scritto:PS. Scusa se ti facciamo tutte queste domande, ma di solito si usa il collegamento USB solo quando non è possibile connettersi in altri modi.

La stessa Telecom, quando fornisce modem/router dotati di porta USB/Ethernet, consiglia di usare la Ethernet per non occupare inutilmente una porta USB del computer; inoltre, aggiungo io, l'uso soprattutto di una USB2 per il collegamento al modem provoca un superlavoro aggiuntivo per la CPU a causa dell'enorme numero di Interrupt Request inviate dal controller USB.