[current] attenzione a libgpod

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
conraid
Staff
Staff
Messaggi: 13329
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

[current] attenzione a libgpod

Messaggioda conraid » dom gen 16, 2011 10:46

Con l'ultimo aggiornamento della -current libgpod cambia i permessi di /tmp, quindi appena installato il pacchetto riprisinateli con "chmod 1777 /tmp". Ho già avvisato Pat sia scritto su LQ

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2643
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.4.2
Desktop: lxde
Località: Pisa
Contatta:

Re: [current] attenzione a libgpod

Messaggioda ponce » dom gen 16, 2011 11:41

gliel'abbiamo segnalato entrambi :D

comunque ne avevo parlato con robby e concordavamo che debba aggiornare il configure di libgpod aggiungendoci --with-temp-mount-dir=/media

Avatar utente
conraid
Staff
Staff
Messaggi: 13329
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: [current] attenzione a libgpod

Messaggioda conraid » dom gen 16, 2011 11:44

ti ho scritto di la, io il pacchetto su slackers lo avevo lasciato stare, togliendo semplicemente /tmp visto che mi sembra corretta come directory temporanea. Anche /media va bene comunque. Avevo visto che anche altre distribuzioni fanno così. Però è stata una svista, diciamolo dai :-)

Jan69
Linux 0.x
Linux 0.x
Messaggi: 39
Iscritto il: dom nov 28, 2010 1:55
Slackware: 64 -current
Kernel: 2.6.37.4
Desktop: KDE 4.5.5

Re: [current] attenzione a libgpod

Messaggioda Jan69 » dom gen 16, 2011 11:47

Scusate ragazzi, intendete la current del 14/01 o 15/01?
Perche' proprio ieri sera mi sono scaricato la iso di Hameleers e oggi, dopo aver letto il vostro post, sono andato a vedere e ce n'e' una nuova.
A questo punto vado di ftp se quella con questo problema e' quella di cui sono gia' in possesso...

Avatar utente
conraid
Staff
Staff
Messaggi: 13329
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: [current] attenzione a libgpod

Messaggioda conraid » dom gen 16, 2011 11:50

non esiste -current del 14 o del 15, ce ne è una sola :-)
solitamente si intende per -current l'ultimo aggiornamento del ramo di sviluppo. Le iso sono di utilità, ma non ti confondere con esse, ufficialmente non esistono neppure. Se vuoi seguire la -current segui il ramo di sviluppo.
L'aggiornamento di libgpod è uscito Sat Jan 15 20:43:54 UTC 2011

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2643
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.4.2
Desktop: lxde
Località: Pisa
Contatta:

Re: [current] attenzione a libgpod

Messaggioda ponce » dom gen 16, 2011 11:51

si, penso che gli sia sfuggito, anche se la directory per montare l'iPod la cita sia tra le opzioni del configure --help sia quando lo hai eseguito, nel riepilogo delle opzioni ;)
Ultima modifica di ponce il dom gen 16, 2011 11:59, modificato 1 volta in totale.

Jan69
Linux 0.x
Linux 0.x
Messaggi: 39
Iscritto il: dom nov 28, 2010 1:55
Slackware: 64 -current
Kernel: 2.6.37.4
Desktop: KDE 4.5.5

Re: [current] attenzione a libgpod

Messaggioda Jan69 » dom gen 16, 2011 11:56

conraid ha scritto:non esiste -current del 14 o del 15, ce ne è una sola :-)
solitamente si intende per -current l'ultimo aggiornamento del ramo di sviluppo. Le iso sono di utilità, ma non ti confondere con esse, ufficialmente non esistono neppure. Se vuoi seguire la -current segui il ramo di sviluppo.
L'aggiornamento di libgpod è uscito Sat Jan 15 20:43:54 UTC 2011

Chiaramente hai ragione, scusa ma ho appena iniziato e faccio ancora un po' di confusione :lol:

Grazie

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: [current] attenzione a libgpod

Messaggioda gohanz » dom gen 16, 2011 19:35

Il problema riguarda anche il pacchetto libgpod aggiornato presente su Slacky?
http://www.slacky.eu/aadm/pkgs/index.ph ... 4&pkg=3378

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2643
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.4.2
Desktop: lxde
Località: Pisa
Contatta:

Re: [current] attenzione a libgpod

Messaggioda ponce » dom gen 16, 2011 20:27

sembra che lo slackbuild abbia dentro queste linee, quindi non dovrebbe

Codice: Seleziona tutto

# Removing tmp directory inside package
rm -r $PKG/tmp

Bart
Staff
Staff
Messaggi: 4249
Iscritto il: lun ago 09, 2004 0:00
Località: Rimini

Re: [current] attenzione a libgpod

Messaggioda Bart » dom gen 16, 2011 22:18

Dovrebbe aver corretto il baco:

Codice: Seleziona tutto

Sun Jan 16 17:58:55 UTC 2011
kde/k3b-2.0.2-x86_64-1.txz: Upgraded.
l/libgpod-0.8.0-x86_64-2.txz: Rebuilt.
    Fix bad /tmp permissions caused by a DESTDIR bug.
    Disable HAL and use udev instead.

Avatar utente
conraid
Staff
Staff
Messaggi: 13329
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: [current] attenzione a libgpod

Messaggioda conraid » lun gen 17, 2011 8:18

Ha messo anche il ripristino dei permessi di /tmp nel doinst.sh :)

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: [current] attenzione a libgpod

Messaggioda gohanz » lun gen 17, 2011 14:02

ponce ha scritto:sembra che lo slackbuild abbia dentro queste linee, quindi non dovrebbe

Codice: Seleziona tutto

# Removing tmp directory inside package
rm -r $PKG/tmp


Va bene comunque visto il problema dei permessi in /tmp forse è meglio lasciare questa linea nello SlackBuild.
Poi non vedo a cosa possa servire crare un directory /tmp vuota nel pacchetto.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2643
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.4.2
Desktop: lxde
Località: Pisa
Contatta:

Re: [current] attenzione a libgpod

Messaggioda ponce » lun gen 17, 2011 14:09

la directory la fa se non si passa al configure l'opzione --with-temp-mount-dir: se la specifichi (Pat nel suo mi sembra che abbia poi scelto /var/run/libgpod) non la crea.

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: [current] attenzione a libgpod

Messaggioda gohanz » lun gen 17, 2011 20:13

ponce ha scritto:la directory la fa se non si passa al configure l'opzione --with-temp-mount-dir: se la specifichi (Pat nel suo mi sembra che abbia poi scelto /var/run/libgpod) non la crea.


Ok grazie! Quindi devo modificare lo SlackBuild, aggiungendo questa riga?

Codice: Seleziona tutto

--with-temp-mount-dir=/var/run/libgpod

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2643
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.4.2
Desktop: lxde
Località: Pisa
Contatta:

Re: [current] attenzione a libgpod

Messaggioda ponce » lun gen 17, 2011 20:21

si, Pat, gia' che c'era, ce ne ha aggiunte anche altre due

Codice: Seleziona tutto

  --without-hal \
  --enable-udev \
  --with-temp-mount-dir=/var/run/libgpod/ \

ma magari quelle stanno meglio su -current ;)