Repository 32bit  Forum
Repository 64bit  Wiki

sound driver Risolto

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: sound driver

Messaggioda 414N » gio feb 10, 2011 20:21

Oltre ad impostare il driver audio per arts, credo tu possa specificare anche come trattare i singoli dispositivi...
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: sound driver

Messaggioda targzeta » gio feb 10, 2011 20:58

La mia idea è semplice, impostare udev in modo che crei un link simbolico per la scheda audio e quindi far si che 'sound server' utilizzi il link creato invece di /dev/dsp. Dato che l'errore compare in KDE potresti fare una prova per vedere se ho ragione. Avvia il PC con la webcam attiva e, prima di avviare KDE prova a spostare il file /dev/dsp1 in /dev/dsp e il file /dev/dsp in /dev/dsp1 in questo modo:
Codice: Seleziona tutto
cd /dev
mv dsp dsp.old
mv dsp1 dsp
mv dsp.old dsp1

Dicci se così funziona,
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: sound driver

Messaggioda pino » ven feb 11, 2011 16:41

Ripeto secondo me non è un errore di kde visto che se avvio xfce è la stessa cosa
Avevo già provato a copiare, come mi avevi detto "cp -a /dev/dsp /lib/udev/devices", ho poi copiato anche dev/dsp1 è lincato su dev/sdp ma non è servito.
Sembra un problema di ordine di caricamento dei drivers con la webcam inserita carica prima il microfono e poi la scheda audio
Non esistono un modo per assegnare l'ordine di caricamento?
pino
Linux 2.4
Linux 2.4
 
Messaggi: 485
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde

Re: sound driver

Messaggioda targzeta » ven feb 11, 2011 18:49

No, quelle copie servivano per una prova iniziale, ora puoi anche cancellare quei file (quelli in /lib/udev/devices). Anche sul mio PC il rilevamento delle periferiche usb avviene prima di quello della scheda audio. C'è un modo "brutto" ma "brutto veramente" per forzare il caricamento del modulo per la scheda audio prima di quello delle porte usb, ma secondo me devi intervenire a livello di sound server, devi potergli dire che la scheda audio non è /dev/dsp ma, ad esempio /dev/audio_device, poi, sfruttando udev possiamo creare il link simbolico /dev/audio_device che punta sempre alla scheda audio, che sia dsp o dsp1.

Ma non ho capito se hai fatto la prova che ho scritto nel post precedente, ovvero rinominare i device prima di far partire KDE o chi per lui.

Emanuele

:edit: questa è la soluzione bruttissima, che però non ti garantisco al 100% che funziona.
Codice: Seleziona tutto
echo 'install usbcore /sbin/modprobe snd_hda_codec ; /sbin/modprobe -i usbcore' >> /etc/modprobe.d/usb.conf
quindi riavvii e facci sapere.
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: sound driver

Messaggioda pino » sab feb 12, 2011 18:59

spina ha scritto:Ma non ho capito se hai fatto la prova che ho scritto nel post precedente, ovvero rinominare i device prima di far partire KDE o chi per lui.Emanuele

No
Ho provato a creare un link tra dsp e dsp1, ma pare siano device creati di volta in volta quindi non funziona.
Il server sonoro di kde permette solo di scegliere tra autorilevamento,alsa,oss, non so come dirgli altro.
pino
Linux 2.4
Linux 2.4
 
Messaggi: 485
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde

Re: sound driver

Messaggioda targzeta » sab feb 12, 2011 19:04

Fai una prova con la soluzione bruttissima e vediamo se va. Così dovresti "obbligare" il driver della scheda audio a caricarsi prima di quello usb, facendo in questo modo far associare "sempre" /dev/dsp alla scheda audio.
Basta che fai:
Codice: Seleziona tutto
echo 'install usbcore /sbin/modprobe snd_hda_codec ; /sbin/modprobe -i usbcore' >> /etc/modprobe.d/usb.conf
e poi riavvii.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: sound driver

Messaggioda pino » dom feb 13, 2011 9:39

spina ha scritto:Fai una prova con la soluzione bruttissima

la soluzione, per quel poco che capisco, mi sembra rischiosa e il problema non cosi grave da valere in rischio.
Non c'è il pericolo di incasinare il sistema sonoro con quel metodo? Piuttosto tengo le cose come stanno e come esce la prossima versione di slackware mi decido ad abbandonare questa gloriosa e rocciosa 12.1
Grazie pino
pino
Linux 2.4
Linux 2.4
 
Messaggi: 485
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde

Re: sound driver

Messaggioda targzeta » dom feb 13, 2011 11:26

pino ha scritto:
spina ha scritto:Fai una prova con la soluzione bruttissima

la soluzione, per quel poco che capisco, mi sembra rischiosa e il problema non cosi grave da valere in rischio.
Non c'è il pericolo di incasinare il sistema sonoro con quel metodo?
Assolutamente no, il comando crea solo un file di configurazione per il comando 'modprobe' che forza il caricamento del modulo della scheda audio prima di quello usb. Poi se non funziona (o non ti piace) basta fare:
Codice: Seleziona tutto
rm /etc/modprobe.d/usb.conf
e cancelli il file creato.

E' solo brutta da vedere :)
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: sound driver

Messaggioda pino » dom feb 13, 2011 18:31

spina ha scritto:Assolutamente no, il comando crea solo un file di configurazione per il comando 'modprobe' che forza il caricamento del modulo della scheda audio prima di quello usb

non va, solito messaggio di errore
Codice: Seleziona tutto
Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (No such file or directory)
The sound server will continue, using the null output device.


Pero con webcam inserita è camdiato il risultato di:
Codice: Seleziona tutto
root@pino:/home/pino# udevadm info --name=/dev/dsp1 --attribute-walk

Udevinfo starts with the device specified by the devpath and then
walks up the chain of parent devices. It prints for every device
found, all possible attributes in the udev rules key format.
A rule to match, can be composed by the attributes of the device
and the attributes from one single parent device.

  looking at device '/class/sound/dsp1':
    KERNEL=="dsp1"
    SUBSYSTEM=="sound"
    DRIVER==""
    ATTR{dev}=="14:19"

  looking at parent device '/devices/pci0000:00/0000:00:05.0':
    KERNELS=="0000:00:05.0"
    SUBSYSTEMS=="pci"
    DRIVERS=="HDA Intel"
    ATTRS{vendor}=="0x10de"
    ATTRS{device}=="0x03f0"
    ATTRS{subsystem_vendor}=="0x1849"
    ATTRS{subsystem_device}=="0x0662"
    ATTRS{class}=="0x040300"
    ATTRS{irq}=="22"
    ATTRS{local_cpus}=="ffffffff"
    ATTRS{local_cpulist}=="0-31"
    ATTRS{modalias}=="pci:v000010DEd000003F0sv00001849sd00000662bc04sc03i00"
    ATTRS{enable}=="1"
    ATTRS{broken_parity_status}=="0"
    ATTRS{msi_bus}==""

  looking at parent device '/devices/pci0000:00':
    KERNELS=="pci0000:00"
    SUBSYSTEMS==""
    DRIVERS==""

non si capisce perche attribuisce la sceda a dsp1 e non a dsp
pino
Linux 2.4
Linux 2.4
 
Messaggi: 485
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde

Re: sound driver

Messaggioda targzeta » dom feb 13, 2011 19:06

Te lo detto perchè l'attribuisce, perché i moduli usb sono caricati prima di quello della scheda audio (anche sul mio PC è così). Quindi succede che il modulo usb crea il device /dev/dsp e poi, quello della scheda audio crea il modulo /dev/dsp1. Quando invece avvii il PC senza la webcam, allora il modulo della scheda usb non crea nessun device e quindi quello della scheda audio crea /dev/dsp. Sembra che qualcosa non abbia funzionato nella mia idea. Puoi postare l'output del comando 'lsmod'? Probabilmente avremmo dovuto forzare il caricamento di qualche altro modulo.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: sound driver

Messaggioda pino » lun feb 14, 2011 17:50

Ti ringrazio molto per la pazienza
Per adesso sospendiamo i tentativi, non ho più tempo e voglia di continuare a fare prove.
Ciao Pino
pino
Linux 2.4
Linux 2.4
 
Messaggi: 485
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde

Re: sound driver

Messaggioda pino » mer ago 17, 2011 19:34

Per chi avesse lo stesso problema . La soluzione è creare un file che contiene l'ordine di caricamento delle schede sonore nel mio caso ho creato il file /etc/modprobe.d/alsabase.conf e vi ho inserito
Codice: Seleziona tutto
options snd_hda_intel index=0

options snd_usb_audio index=1


La soluzione la ho trovata nel link sotto
Ciao Pino

https://wiki.archlinux.org/index.php/Ad ... chitecture

Dopo aver selezionato la lingua si va su:
impostare_la_scheda_audio_predefinita
pino
Linux 2.4
Linux 2.4
 
Messaggi: 485
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde

Precedente

Torna a Slackware

Chi c’è in linea

Visitano il forum: Bing [Bot], fenics, Google [Bot] e 2 ospiti