Repository 32bit  Forum
Repository 64bit  Wiki

installazione stampante

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

installazione stampante

Messaggioda james2221 » ven mar 11, 2011 19:13

ciao
innanzitutto una critica affettuosa: gli indici degli argomenti sono troppo generici, spesso non si sa dove postare, comunque voglio bene a tutti quindi non subbissatemi di improperi.
premetto: avevo Slackware 13.1 64bit fino a una settimana fa, ma a causa della mia incapacità di gestire lib a 32-64bit ho raso tutto al suolo e reinstallato Slack 13.1 32bit. Ho riscontrato alcuni piccoli problemi postati in un' altra sezione.
Il problema piu grosso nasce dalla stampante: una Lexmark X2600 multifunzione che non riesco a installare, ovvero ho installato cups e le dipendenze (trovate su Zenwalk, va bene ???).
Apro
http://localhost:631
ma prima devo installare la stampante: nessun problema: scarico, scompatto, ottengo un file tar.gx.sh e lo faccio partire, si apre la finestra e dopo la pass di root e un po di scroll si ferma e mi dice di installare cups.
Mi chiedo: ho reinstallato cups e dipendenze un paio di violte, si apre la pagina http://localhost:631 come è possibile che il programma di installazione mi dia cups non installato? come posso fare una controprova ??

grazie

james
Ultima modifica di james2221 il ven mar 11, 2011 21:49, modificato 1 volta in totale.
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: installazione stampante

Messaggioda navajo » ven mar 11, 2011 20:47

ho cercato sul sito della Lexmarc ed ho trovato questo:
http://support.lexmark.com:80/lexmark/index?page=content&locale=IT&userlocale=IT_IT&id=OS4

i driver non li ho cercati, ma dovrebbero stare nella sezione download
Avatar utente
navajo
Staff
Staff
 
Messaggi: 3778
Iscritto il: gio gen 08, 2004 0:00
Località: Roma
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)

Re: installazione stampante

Messaggioda james2221 » ven mar 11, 2011 21:11

ciao
dunque: il problema non sono i drivers nè il metodo di installazione, avrò installato questa stamp decine di volte (ubuntu32-64 debian 32-64 Arch 32-64, fedora, ecc ecc ecc) pertanto la prassi la conosco ed è comunque quella del tuo link, ed è semplice e intuitiva:

installo cups
scarico e scompatto i drivers
faccio partire il file .sh e mi compare la finestra di installazione, installo e si chiude la finestra
apro localhost:631 e dico a cups che ho la stampante
finito

. Il .problema è che quando faccio partire il file eseguibile , dopo la pass e qualche secondo di scroll mi dice che devo installare cups almeno alla versione 1.2, io installato 1.4.
come faccio a sapere se cups è a posto? ovviamente dando
slapt-get --installed
mi da cups e tutte le dipendenze, cercate una a una e reinstallate un paio di volte.
Sono certo di aver commesso qualche errore ma mi servirebbe una strada da percorrere per trovare questo errore

grazie
james
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: installazione stampante

Messaggioda navajo » ven mar 11, 2011 21:17

ok scusami non avevo capito bene la domanda
il demone di cups è attivo ?? riesci ad entrare nella pagina web di configurazione ?
Avatar utente
navajo
Staff
Staff
 
Messaggi: 3778
Iscritto il: gio gen 08, 2004 0:00
Località: Roma
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)

Re: installazione stampante

Messaggioda james2221 » ven mar 11, 2011 21:29

si, se do localhost:631 mi compare la pagina di cups, clicco su "aggiungi stampanti" si apre la pagina per l'accesso da root con passwd ecc, si apre una ulteriore pagina dove trovo la scelta tra due stampanti locali: cups-pdf e HP-fax, ma ovviamenbte la mia lexmark non c'è, perche la installazione si è fermata a meta chiedendomi di installare cups, che però, come abbiamo visto, è installato.

è come quando si va in un ufficio: non ti danno un documento se non c'è un modulo, non puoi ritirare il modulo se non hai il documento
sto a scherzà...
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: installazione stampante

Messaggioda 414N » sab mar 12, 2011 14:04

Scusa, ma non riesco a capire come hai installato cups. Non l'hai installato dal disco di installazione di Slackware al momento, appunto, dell'installazione?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: installazione stampante

Messaggioda james2221 » sab mar 12, 2011 14:28

ciao
(ma ci siamo solo noi qui?)
francamente nun maarricordo se ho installato da disco di installazione (che comunque ho qui nel cassetto), per tagliare la testa al toro l'ho installato da repository di zenwalk, e magari, anzi certamente l'errore è lì.
Che faccio per rimediare?

grazie
Ultima modifica di james2221 il sab mar 12, 2011 14:39, modificato 1 volta in totale.
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: installazione stampante

Messaggioda 414N » sab mar 12, 2011 14:37

Prova con un
Codice: Seleziona tutto
slackpkg upgrade-all
dopo aver scelto un mirror in /etc/slackpg/mirrors
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: installazione stampante

Messaggioda james2221 » sab mar 12, 2011 15:27

ho fatto l'upgrade ed effettivamente mi ha detto qualcosa in merito a cups, per cui credo che avessi 2 cups, mi dà ancora lo stesso errore

Codice: Seleziona tutto
The installer has detected the operating system does not meet CUPS minimum version requirements. Please install CUPS version 1.2 or higher and run the installer again.


pertanto dovro fare una bella roba: rimuovo tutti i cups e relative dipendenze e lo reinstallo daccapo, salvo diversi suggerimenti. Una domanda a cui non ho mai avuto risposta: i repository di zenwalk sono ASSOLUTAMENTE compatibili? così dicono tutti, piu che altro perchè sono meglio dettagliati (almeno per uno al mio livello) che non quelli di Slack, e con cio spero di non innescare nessun flame..
grazie, lo farò nelle prossime puntate, mi ci vuole tempo...
james
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: installazione stampante

Messaggioda navajo » sab mar 12, 2011 18:44

perchè usi quelli di zenwalk ??? il problema potrebbe essere proprio quello, a questo punto.
Capisco che magari potrebbe essere utile usare alternative per pacchetti che non si trovano, ma per i pacchetti di sistema ufficiali dovresti usare quelli.
Avatar utente
navajo
Staff
Staff
 
Messaggi: 3778
Iscritto il: gio gen 08, 2004 0:00
Località: Roma
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)

Re: installazione stampante

Messaggioda james2221 » sab mar 12, 2011 18:50

ok ok, d'ora in poi userò quelli ufficiali, solo che non tutti li ho trovati per cui mi sono spostato su Zenwalk, effettivamente è il grosso dubbio che ho avuto. Domani mi alzo all'alba, pulisco Cups e affiliati sperando di non creare caXsini, mi riscrivo l'elenco delle dipendenze di cups, ed eventuali sottodipendenze, e vediamo come va...
speriamo in bene

comunque posterò, credo proprio che ci pianteremo subito ai primi pacchetti che trovo su Zen e non su Slack.

ahhh, quanto era piu comodo XP...
NON é VERO, solo una boutade
grazie
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: installazione stampante

Messaggioda james2221 » gio mar 17, 2011 11:07

Ciao
torno alla carica per la stampante lexmarkx2600, datosi che ho disinstallato e reinstallato cups (sembrava fosse la causa del problema) e mi da lo stesso risultato.
riepilogo brevemente: l'ho installata piu volte su altre distro, sia 32 che 64bit, con questa procedura, che peraltro è quella dei vari wiki:

1 installo cups
2 scarico driver, scompatto e faccio partire file .sh
3 seguo le istruzioni a schermo
4 apro http://localhost:631 (praticamente cups)
5 seguo la procedura"installa nuova stampante"
6 finito

al punto 2 mi fermo, ovvero dopo che la finestra della lexmark mi chiede la pass di root, fa qualche riga di scrolling poi si pianta dicendo di installare cups almeno 1.2 ma io ho gia installato cups-1.4.4, la prova che cups esiste è che al punto 4 apro http://localhost:631 si apre la pagina e arrivo fino a quando mi chiede che stampante ho, ovviamente NON VEDE non avendo potuto installarla.
sono certo che il problema sta nelle installazione di cups, ma ho cercato le dipendenze e sistemate, come posso sapere che eventuale dipendenza manca oppure è obsoleta???
grazzzzzie
james
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: installazione stampante

Messaggioda 414N » gio mar 17, 2011 13:44

james2221 ha scritto:sono certo che il problema sta nelle installazione di cups, ma ho cercato le dipendenze e sistemate, come posso sapere che eventuale dipendenza manca oppure è obsoleta???
grazzzzzie
james

Sbagliato. Il problema è nell'installer che, piuttosto stupidamente, cerca cups tramite i sistemi di package management rpm o dpkg, non utilizzati da Slackware. Il bello è che c'è qualche file lua per l'installer che gestisce la creazione del pacchetto per Slackware ma, a quanto pare, non hanno considerato che il controllo dell'esistenza di CUPS tramite i soli rpm o dpkg non permette di proseguire la procedura sulla nostra distro...
Puoi risolvere la faccenda in vari modi, dato che il problema sta tutto nell'estrarre dallo script i file necessari a crearti un pacchetto Slackware oppure i soli PPD che servono a CUPS per far andare la stampante. Ho fatto qualche prova con il file per OpenSuse (che contiene un RPM) e procederei come segue (da terminale):
  1. Estrai i contenuti dello zip scaricato dal sito Lexmark in una directory a piacere
  2. Lancia il file di setup specificando l'opzione --keep, ovvero
    Codice: Seleziona tutto
    ./lexmark-inkjet-08-driver-1.0-1.i386.rpm.sh --keep
  3. Procedi come solito fino a quando non ti dice che CUPS non è stato trovato ed annulla l'installazione
  4. Ora dovresti avere una subdirectory tmp/. Entraci ed estrai il RPM che contiene i driver della stampante per creare un bel pacchettino Slackware in questo modo:
    Codice: Seleziona tutto
    cd tmp
    mkdir package
    cd package
    rpm2cpio ../pkg/files/lexmark-inkjet-08-driver-1.0-1.i386.rpm  | cpio -vid
  5. Ora non ci resta che creare qualche link simbolico per rendere il pacchetto più usabile su Slackware:
    Codice: Seleziona tutto
    cd usr
    mkdir bin
    cd bin
    ln -sf /usr/local/lexmark/lxk08/bin/lxkusb
    ln -sf /usr/local/lexmark/lxk08/bin/printdriver
    ln -sf /usr/local/lexmark/lxk08/bin/prnutility
    cd ..
    cd ..
  6. Crea il pacchetto Slackware:
    Codice: Seleziona tutto
    makepkg -l y -c y lexmark_inkjet-1.0.1-i386.txz
  7. Installa il pacchetto con installpkg (da root, ovviamente):
    Codice: Seleziona tutto
    installpkg lexmark_inkjet-1.0.1-i386.txz
  8. Dall'interfaccia web di CUPS, devi andare a cercare il PPD per la tua stampante in /usr/local/lexmark/lxk08/etc/
A questo punto, una volta indicato il giusto PPD (che, esagerando, presumo sia lx2600.ppd) a CUPS, la stampante dovrebbe venire riconosciuta.
Ultima modifica di 414N il gio mar 17, 2011 15:48, modificato 1 volta in totale.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: installazione stampante

Messaggioda james2221 » gio mar 17, 2011 15:32

@414N
urcavè quanta robba.
Credo di aver capito (quasi) tutto in linea teorica. Datosi che una cosa così equivale all'incirca, per me, alla prima operazione a cuore aperto di Barnard devo prendermi i miei tempi, per cui rinvio tra un paio di giorni, quando avrò per lo meno un paio di ore per affrontare una procedura così complessa. Per ora ti ringrazio e apprezzo molto il tuo interessamento, avrai impiegato parecchi minuti anche tu per scrivere tutta 'sta roba.
Posto piu avanti, probabilmente sabato o domenica mattina.
per ora ti ringrazio

james
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: installazione stampante

Messaggioda 414N » mar ago 30, 2011 17:06

Ti ho creato un pacchetto Slackware comodo comodo che dovrebbe farti andare la stampante con CUPS:
pacchetto (MD5).
Come già detto sopra, una volta installato devi andare ad indicare a cups dove trovare il PPD (nello stesso posto sopraindicato).
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti