RISOLTO: Wireless Broadcom 4311

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
neretux
Linux 0.x
Linux 0.x
Messaggi: 11
Iscritto il: dom mag 29, 2011 10:57

RISOLTO: Wireless Broadcom 4311

Messaggioda neretux » mar giu 07, 2011 19:51

Ho installato Slackware 13.1 sul mio laptop ma non riesco a far andare il wireless premesso che la ethernet non funziona perchè si è fregata la porta.

La mia scheda è:

Codice: Seleziona tutto

# lspci | grep -i wlan
05:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
e per farla funzionare

Codice: Seleziona tutto

 # modprobe b43


Vi posto il risultato di diversi comandi:

Codice: Seleziona tutto

# iwlist scan
lo        Interface doesn't support scanning.

irda0     Interface doesn't support scanning.

wlan0     Interface doesn't support scanning : Network is down

poi

Codice: Seleziona tutto

# ifconfig -a
irda0     Link encap:IrLAP  HWaddr 00:00:00:00 
          NOARP  MTU:2048  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:8
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1000 (1000.0 B)  TX bytes:1000 (1000.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:1c:26:63:a2:9c 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


poi

Codice: Seleziona tutto

# ifconfig wlan0 up
SIOCSIFFLAGS: No such file or directory


Ho configurato i file in quesgto modo:
- /etc/wpa_supplicant.conf

Codice: Seleziona tutto

# See /usr/doc/wpa_supplicant-0.6.10/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
#country=US

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="TISCALI"
  proto=WPA RSN
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk=*******************************
  priority=10
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
network={
  key_mgmt=NONE
  priority=0
}
al posto della chiave ho messo degli asterischi ma nel file c'è il valore della wpa

- /etc/rc.d/rc.inet1.conf

Codice: Seleziona tutto

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your data.  (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]=TISCALI
WLAN_MODE[4]=Managed
#WLAN_RATE[4]="54M auto"
#WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="D5A31F54ACF0487C2D0B1C10D2"
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK="
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPACONF[4]="/etc/wpa_supplicant.conf"
#WLAN_WPADRIVER[4]="wext"
#WLAN_WPAWAIT[4]=30

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0"              # Use a different interface name instead of
                                # the default 'eth4'
#IFNAME[4]="eth0:1"             # Set up an IP alias.
#HWADDR[4]="00:01:23:45:67:89"  # Overrule the card's hardware MAC address
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
#DHCP_TIMEOUT[4]=15             # The default timeout for the DHCP client to
                                # wait for server resonse is 10 seconds, but
                                # you might want a shorter or longer wait.
#DHCP_KEEPRESOLV[4]="yes"       # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes"          # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes"           # If you don't want the DHCP server to change
                                # your default gateway
#DHCP_IPADDR[4]=""              # Request a specific IP address from the DHCP
                                # server
#DHCP_DEBUG[4]="yes"            # Make dhcpcd show verbose diagnostics
#DHCP_NOIPV4LL[4]="yes"         # Do not assign an ipv4ll address when a DHCP
                                # server is not found (ipv4ll link-local
                                # adresses in the IP range 169.254.0.0/16 are
                                # also known as "zeroconf" addresses)
#WLAN_ESSID[4]=DARKSTAR         # An example of how you can override _any_
                                # parameter defined in rc.wireless.conf, by
                                # prepending 'WLAN_' to the parameter's name.
                                # Useful with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
                                # Some drivers require a private ioctl to be
                                # set through the iwpriv command. If more than
                                # one is required, you can place them in the
                                # IWPRIV parameter (separated with the pipe (|)
                                # character, see the example).
#WLAN_WPA[4]="wpa_supplicant"   # Run wpa_supplicant for WPA support
#WLAN_WPADRIVER[4]="ndiswrapper"# Tell wpa_supplicant to specifically use the
                                # ndiswrapper driver (if you leave this empty
                                # the 'wext' driver is used by default)
#WLAN_WPAWAIT[4]=30             # In case it takes long for the WPA association
                                # to finish, you can increase the wait time
                                # (defaults to 10 seconds)


ma quando lancio:

Codice: Seleziona tutto

# wpa_supplicant -d -c /etc/wpa_supplicant.conf -i wlan0
Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
Initializing interface (2) 'wlan0'
SIOCSIFFLAGS: No such file or directory
Could not set interface 'wlan0' UP
SIOCGIWRANGE: WE(compiled)=22 WE(source)=21 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf flags 0x0
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:1c:26:63:a2:9c
wpa_driver_wext_set_wpa
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_countermeasures
wpa_driver_wext_set_drop_unencrypted
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
WPS: UUID based on MAC address - hexdump(len=16): 71 ad 73 04 fd 55 52 43 8b 1e 9e 7a e1 e3 b4 46
WPS: Build Beacon and Probe Response IEs
WPS:  * Version
WPS:  * Wi-Fi Protected Setup State (0)
WPS:  * Version
WPS:  * Wi-Fi Protected Setup State (0)
WPS:  * Response Type (2)
WPS:  * UUID-E
WPS:  * Manufacturer
WPS:  * Model Name
WPS:  * Model Number
WPS:  * Serial Number
WPS:  * Primary Device Type
WPS:  * Device Name
WPS:  * Config Methods (0)
WPS:  * RF Bands (3)
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
Added interface wlan0
RTM_NEWLINK: operstate=0 ifi_flags=0x1002 ()
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
RTM_NEWLINK: operstate=0 ifi_flags=0x1002 ()
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK: operstate=0 ifi_flags=0x1002 ()
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b1a len=40
l2_packet_receive - recvfrom: Network is down
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Trying to get current scan results first without requesting a new scan to speed up initial association
ioctl[SIOCGIWSCAN]: Network is down
Failed to get scan results
Failed to get scan results - try scanning again
Setting scan request: 0 sec 0 usec
Starting AP scan (broadcast SSID)
ioctl[SIOCSIWSCAN]: Network is down
Scan requested (ret=-1) - scan timeout 5 seconds
Failed to initiate AP scan.
Setting scan request: 10 sec 0 usec
EAPOL: disable timer tick
Scan timeout - try to get results
ioctl[SIOCGIWSCAN]: Network is down
Failed to get scan results
Failed to get scan results - try scanning again
State: SCANNING -> INACTIVE
No enabled networks - do not scan
State: INACTIVE -> INACTIVE
si blocca e lo devo fermare con ctrl+z.

E poi

Codice: Seleziona tutto

# /etc/rc.d/rc.inet1 restart
SIOCSIFFLAGS: No such file or directory
/etc/rc.d/rc.inet1:  wlan0 information: 'Any ESSID'
Error for wireless request "Set Nickname" (8B1C) :
    SET failed on device wlan0 ; Operation not supported.
SIOCSIFFLAGS: No such file or directory
Could not set interface 'wlan0' UP
SIOCSIFFLAGS: No such file or directory
Polling for DHCP server on interface wlan0:
dhcpcd: version 5.2.2 starting
dhcpcd: wlan0: up_interface: No such file or directory
dhcpcd: wlan0: waiting for carrier
dhcpcd: timed out
dhcpcd: allowing 8 seconds for IPv4LL timeout
dhcpcd: timed out


Nonostante queste impostazioni e tentativi non riesco a navigare col wireless.
Cosa sbaglio? Suggerimenti?
Ultima modifica di neretux il mer giu 08, 2011 12:02, modificato 1 volta in totale.

Avatar utente
proffi
Linux 1.x
Linux 1.x
Messaggi: 135
Iscritto il: ven ago 13, 2004 0:00
Slackware: 13.37
Località: Lunano

Re: Wireless Broadcom 4311

Messaggioda proffi » mar giu 07, 2011 20:22

Devi prima installare il firmware della tua scheda wireless. Dai un'occhiata qua:

http://linuxwireless.org/en/users/Drivers/b43

Dato che hai la ethernet rotta, ti basta scaricare il firmware su un altro pc, poi segui le istruzioni. Se una volta fatta funzionare la scheda hai problemi con la configurazione della connessione, ti consiglio di usare wicd.

Ciao

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Wireless Broadcom 4311

Messaggioda phobos3576 » mar giu 07, 2011 23:13

Se si fa una ricerca si trovano molte discussioni qui su Slacky relativamente ai driver per schede wireless Broadcom, compresa la BCM4311.
Fortunatamente, quelle schede sono ottimamente supportate dal driver rilasciato dalla stessa Broadcom e scaricabile (per 32 e 64 bit) da:

http://www.broadcom.com/support/802.11/linux_sta.php

Vorrei ricordare che prima della compilazione con kernel >= 2.6.37, è necessario apportare una modifica ai sorgenti (a tale proposito, c'è anche una patch sullo stesso sito della Broadcom); alla riga 487 del file src/wl/sys/wl_linux.c bisogna sostituire:

Codice: Seleziona tutto

init_MUTEX(&wl->sem);

con:

Codice: Seleziona tutto

sema_init(&wl->sem, 1);

La compilazione richiede il package kernel_headers ed avviene con:

Codice: Seleziona tutto

make clean
make

Se tutto è andato bene, viene creato il driver wl.ko.
A questo punto, da root:

Codice: Seleziona tutto

cp wl.ko /lib/modules/`uname -r`/kernel/drivers/net/wireless
depmod -a
modprobe wl

E' importante blacklistare tutti gli altri driver che potrebbero creare conflitti; quindi, in /etc/modprobe.d/blacklist.conf bisogna aggiungere:

Codice: Seleziona tutto

blacklist ssb
blacklist b43
blacklist brcm80211

P.S. Il driver della Broadcom non richiede il firmware in quanto lo incorpora al suo interno.

Avatar utente
proffi
Linux 1.x
Linux 1.x
Messaggi: 135
Iscritto il: ven ago 13, 2004 0:00
Slackware: 13.37
Località: Lunano

Re: Wireless Broadcom 4311

Messaggioda proffi » mer giu 08, 2011 0:23

phobos3576 ha scritto:P.S. Il driver della Broadcom non richiede il firmware in quanto lo incorpora al suo interno.


Beh a dire la verità nel sito di linux wireless fa scaricare un file che contiene il firmware e il software per estrarlo, il kernel ha il supporto alle schede ma manca il firmware, che mi sembra di aver capito non può essere distribuito. Anch'io ho una Broadcom e ho sempre seguito le istruzioni nel sito che ho linkato, poi non so se coi driver ufficiali sia meglio...

Edit: scusa sarà l'ora ma mi era sfuggito che per il firmware ti riferivi al driver ufficiale rilasciato dalla Broadcom... sorry & buonanotte!

Avatar utente
neretux
Linux 0.x
Linux 0.x
Messaggi: 11
Iscritto il: dom mag 29, 2011 10:57

Re: Wireless Broadcom 4311

Messaggioda neretux » mer giu 08, 2011 1:05

Grazie per le risposte.
Allora tramite una distro live con il wireless attivo ho chrootato slackware ed ho correttamente installato tramite gli slackbuilds sia b43-fwcutter sia wicd.
Per il firmware poi ho fatto:

Codice: Seleziona tutto

wget http://downloads.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2
tar xjf broadcom-wl-4.150.10.5.tar.bz2
cd broadcom-wl-4.150.10.5/driver
b43-fwcutter -w /lib/firmware/ wl_apsta_mimo.o
ho riavviato e mi sembra che la scheda la riconosca infatti quando faccio

Codice: Seleziona tutto

ifconfig wlan0 up
non escono i messaggi di errore e quando do

Codice: Seleziona tutto

 iwlist wlan0 scan
mi vede la rete wireless (essid, channel ecc.).
Il problema è che quando do startx e si avvia kde, wicd non me la vede, anche se tra le preferenze>wireless interface imposto wlan0 continua a non vederla.
Come posso risolvere?

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Wireless Broadcom 4311

Messaggioda phobos3576 » mer giu 08, 2011 2:49

Wicd usa propri script per gestire la connessione; tali script vanno in conflitto con quelli messi da Pat in /etc/rc.d.

Devi quindi togliere i permessi di esecuzione a /etc/rc.d/rc.wireless e devi commentare tutto ciò che riguarda il wireless in /etc/rc.d/rc.inet1.conf (soprattutto, le righe che fanno riferimento a DHCP).
Ci potrebbero essere poi conflitti tra i driver b43 e brcm80211; ti conviene quindi mettere quest'ultimo nella blacklist.
Poi riavvia il computer.

Ma perché non usi il driver della Broadcom?

Avatar utente
neretux
Linux 0.x
Linux 0.x
Messaggi: 11
Iscritto il: dom mag 29, 2011 10:57

Re: Wireless Broadcom 4311

Messaggioda neretux » mer giu 08, 2011 11:59

Fiuuu... è stato peggio di un parto ma alla fine ce l'ho fatta: ho risolto! :thumbright: Infatti vi sto scrivendo da slackware... \:D/
Non uso i driver della broadcom perchè il modulo wl mi ha sempre dato casini... :evil: Infatti ho eseguito anche la tua procedura ma non ha funzionato, forse perchè magari posso anche aver sbagliato io qualcosa...
Riassumo la procedura risolutiva:

1. Tramite una distro live con il wireless attivo ho chrootato slackware ed ho correttamente installato tramite gli slackbuilds sia b43-fwcutter sia wicd.

2. Per il firmware ho fatto:

Codice: Seleziona tutto

wget http://downloads.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2
tar xjf broadcom-wl-4.150.10.5.tar.bz2
cd broadcom-wl-4.150.10.5/driver
b43-fwcutter -w /lib/firmware/ wl_apsta_mimo.o


3. in /etc/rc.d/rc.modules ho aggiunto la riga

Codice: Seleziona tutto

 /sbin/modprobe b43
ed in /etc/modprobe.d/blacklist.conf ho aggiunto le righe

Codice: Seleziona tutto

blacklist ssb
blacklist brcm80211


4. ho modificato /etc/wpa_supplicant.conf in questo modo

Codice: Seleziona tutto

# See /usr/doc/wpa_supplicant-0.6.10/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
#country=US

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="TISCALI"
  proto=WPA RSN
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk=fe2114f
  priority=10
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
network={
  key_mgmt=NONE
  priority=0
}


5. ho modificato il file /etc/rc.d/rc.inet1.conf in questo modo:

Codice: Seleziona tutto

# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your data.  (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=DARKSTAR
#WLAN_MODE[4]=Managed
#WLAN_RATE[4]="54M auto"
#WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="D5A31F54ACF0487C2D0B1C10D2"
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="wext"
#WLAN_WPAWAIT[4]=30

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0"              # Use a different interface name instead of
                                # the default 'eth4'
#IFNAME[4]="eth0:1"             # Set up an IP alias.
#HWADDR[4]="00:01:23:45:67:89"  # Overrule the card's hardware MAC address
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
#DHCP_TIMEOUT[4]=15             # The default timeout for the DHCP client to
                                # wait for server resonse is 10 seconds, but
                                # you might want a shorter or longer wait.
#DHCP_KEEPRESOLV[4]="yes"       # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes"          # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes"           # If you don't want the DHCP server to change
                                # your default gateway
#DHCP_IPADDR[4]=""              # Request a specific IP address from the DHCP
                                # server
#DHCP_DEBUG[4]="yes"            # Make dhcpcd show verbose diagnostics
#DHCP_NOIPV4LL[4]="yes"         # Do not assign an ipv4ll address when a DHCP
                                # server is not found (ipv4ll link-local
                                # adresses in the IP range 169.254.0.0/16 are
                                # also known as "zeroconf" addresses)
#WLAN_ESSID[4]=DARKSTAR         # An example of how you can override _any_
                                # parameter defined in rc.wireless.conf, by
                                # prepending 'WLAN_' to the parameter's name.
                                # Useful with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
                                # Some drivers require a private ioctl to be
                                # set through the iwpriv command. If more than
                                # one is required, you can place them in the
                                # IWPRIV parameter (separated with the pipe (|)
                                # character, see the example).
#WLAN_WPA[4]="wpa_supplicant"   # Run wpa_supplicant for WPA support
#WLAN_WPADRIVER[4]="ndiswrapper"# Tell wpa_supplicant to specifically use the
                                # ndiswrapper driver (if you leave this empty
                                # the 'wext' driver is used by default)
#WLAN_WPAWAIT[4]=30             # In case it takes long for the WPA association
                                # to finish, you can increase the wait time
                                # (defaults to 10 seconds)


6. da terminale

Codice: Seleziona tutto

 nano -w /etc/resolv.conf.head
ed ho aggiunto la riga

Codice: Seleziona tutto

 nameserver 212.216.112.112


7. al reboot ho ritrovato la scheda direttamente connessa ad internet ed ho verificato la connessione con

Codice: Seleziona tutto

ping www.google.it


Tutto a posto senza wicd e simili! =D>
Al rebbot vi trovate la scheda direttamente connessa con Internet e lo potete verificare magari con ping

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: RISOLTO: Wireless Broadcom 4311

Messaggioda phobos3576 » mer giu 08, 2011 15:18

Come ho scritto prima, se cerchi sul forum trovi una discussione relativa proprio alla BCM 4311; è bastato installare il driver wl e il programma wicd e tutto si è risolto senza la necessità di dover fare tutto quel gigantesco lavoro.

Il driver wl lo fa la Broadcom ed è enormemente meglio di quelli alternativi; supporta anche il suspend/hybernate e il led del wireless.

Avatar utente
neretux
Linux 0.x
Linux 0.x
Messaggi: 11
Iscritto il: dom mag 29, 2011 10:57

Re: RISOLTO: Wireless Broadcom 4311

Messaggioda neretux » mer giu 08, 2011 17:13

phobos3576 ha scritto:Come ho scritto prima, se cerchi sul forum trovi una discussione relativa proprio alla BCM 4311; è bastato installare il driver wl e il programma wicd e tutto si è risolto senza la necessità di dover fare tutto quel gigantesco lavoro.

Il driver wl lo fa la Broadcom ed è enormemente meglio di quelli alternativi; supporta anche il suspend/hybernate e il led del wireless.

Ma io ho provato ad installare wl, l'ho fatto due volte ed in entrambi i casi ho fallito, vuoi per la mia inesperienza, vuoi per altri motivi che non comprendo e nonostante ciò wicd non riusciva a vedere wlan0, allora ho ripiegato su b43, che è l'unico modulo che, sul mio laptop con tutte le distro che uso ed che ho usato, riesce a far funzionare la scheda. Comunque alla fine ho risolto e questo è l'importante ;)