Repository 32bit  Forum
Repository 64bit  Wiki

Aggiornare XFCE

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Aggiornare XFCE

Messaggioda Procopio » sab dic 10, 2011 1:59

Continuo da qua: che a voi risulti nel mirror current di alien (http://taper.alienbase.nl/mirrors/slack ... e-current/) c'è la versione 4.6 di xfce? perchè io ho installato la versione di rworkman che dovrebbe essere la 4.8, ma se vado su "about xfce" nel menu xfce mi da la versione 4.6, e allora mi chiedevo se fossero gli aggiornamenti della current a darmi questa versione.....può essere questo?
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Aggiornare XFCE

Messaggioda brainvision » sab dic 10, 2011 8:28

Procopio ha scritto:Continuo da qua: che a voi risulti nel mirror current di alien (http://taper.alienbase.nl/mirrors/slack ... e-current/) c'è la versione 4.6 di xfce? perchè io ho installato la versione di rworkman che dovrebbe essere la 4.8, ma se vado su "about xfce" nel menu xfce mi da la versione 4.6, e allora mi chiedevo se fossero gli aggiornamenti della current a darmi questa versione.....può essere questo?

certo sì..
ammesso che hai seguito la procedure a dovere ed hai disinstallato tutti i vecchi pacchetti prima di mettere i nuovi (alcuni non sono segnati sulla mini guida di rworkman, spero te ne sarai accorto), se poi hai aggiornato con un tool automatizzato ovvio che ha fatto il downgrade di quei pacchetti.. io, anche se uso davvero pochissimo slapt-get, preferisco sempre fare a mano, è più sicuro, non c'è che dire, ho risolto comunque settando le voci xfce* e le altre come non aggiornabili, esattamente come per le voci del kernel e delle glibc (sempre parlando si slapt-get).
Comunque non ti dovrebbe essere complicato controllare con un
Codice: Seleziona tutto
cat /var/log/packages/xfce-XXXXX


Inoltre, quello non è il mirror di alien.. è il mirror della current (ospitato da alien), quindi è uguale identico spiccicato a qualsiasi altro mirror della current quindi sì, certo, Slackware current usa Xfce 4.6 (potremmo dire ancora, ma non lo diciamo) e quindi ovviamente quello troverai.. :)

In ultimissima istanza, ieri notte - oddio, notte.. ieri sera tardi ;) - avevo letto un tup post che non trovo più: volevo risponderti ma poi la connessione mi faceva gli scherzetti e non ho avuto la pazienza per insistere.. comunque volevo solo dire che Xfce, KDE, Gnome o Fluxbox o qello che ti pare: un browser con 30 schede aperte, gimp con 3 / 4 grossi file immagini, che altro dicevi?.. fidati, puoi metterci quello che ti 0pare, ma a meno che non abbia un i7, 16 GB RAM ed un ottima scheda video - non dedicata!! - accuserai sempre lentezza o per meglio dire meno reattività!! Stai tranquillo sui questo!
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Aggiornare XFCE

Messaggioda Procopio » sab dic 10, 2011 14:34

brainvision ha scritto:certo sì..
ammesso che hai seguito la procedure a dovere ed hai disinstallato tutti i vecchi pacchetti prima di mettere i nuovi (alcuni non sono segnati sulla mini guida di rworkman, spero te ne sarai accorto), se poi hai aggiornato con un tool automatizzato ovvio che ha fatto il downgrade di quei pacchetti..
io ho fatto l'upgrade alla current dopo aver installato i pacchetti di rworkman, ma non ho disinstallato prima la 4.8 (non credevo che mi facesse il downgrade se la versione che avevo io era più vecchia) ad ogni modo ho installato con slackpkg, ora mi devo ancora preoccupare di rimuovere i pacchetti ri rworkman? il mio file /var/log/packages/ ho questi files:
Codice: Seleziona tutto
...
xfce-4.6.2-i486-5
xfce4-mixer-4.8.0-i486-1_rlw
xfce4-notifyd-0.1.1-i486-1
xfce4-power-manager-0.8.5-i486-1
...
i cat mi danno questo:
Codice: Seleziona tutto
bash-4.1$ cat /var/log/packages/xfce4-mixer-4.8.0-i486-1_rlw
PACKAGE NAME:     xfce4-mixer-4.8.0-i486-1_rlw
COMPRESSED PACKAGE SIZE:     184K
UNCOMPRESSED PACKAGE SIZE:     980K
PACKAGE LOCATION: xfce4-mixer-4.8.0-i486-1_rlw.txz
PACKAGE DESCRIPTION:
xfce4-mixer: xfce4-mixer (Sound mixer applet for Xfce)
xfce4-mixer:
xfce4-mixer: The xfce4-mixer package contains a volume control application based
xfce4-mixer: on GStreamer 0.10 written to conceptually fit into the Xfce desktop
xfce4-mixer: environment. It also contains a plugin for the Xfce panel which is
xfce4-mixer: especially designed for use with the mouse wheel.
xfce4-mixer:
xfce4-mixer:
xfce4-mixer:
xfce4-mixer:
xfce4-mixer:
FILE LIST:
./
usr/
usr/doc/
usr/doc/xfce4-mixer-4.8.0/
usr/doc/xfce4-mixer-4.8.0/README
usr/doc/xfce4-mixer-4.8.0/TODO
usr/doc/xfce4-mixer-4.8.0/NEWS
usr/doc/xfce4-mixer-4.8.0/HACKING
usr/doc/xfce4-mixer-4.8.0/THANKS
usr/doc/xfce4-mixer-4.8.0/INSTALL
usr/doc/xfce4-mixer-4.8.0/ChangeLog
usr/doc/xfce4-mixer-4.8.0/COPYING
usr/doc/xfce4-mixer-4.8.0/AUTHORS
usr/libexec/
usr/libexec/xfce4/
usr/libexec/xfce4/panel-plugins/
usr/libexec/xfce4/panel-plugins/xfce4-mixer-plugin
usr/bin/
usr/bin/xfce4-mixer
usr/share/
usr/share/pixmaps/
usr/share/pixmaps/xfce4-mixer/
usr/share/pixmaps/xfce4-mixer/chain-broken.png
usr/share/pixmaps/xfce4-mixer/chain.png
usr/share/applications/
usr/share/applications/xfce4-mixer.desktop
usr/share/xfce4/
usr/share/xfce4/panel-plugins/
usr/share/xfce4/panel-plugins/xfce4-mixer-plugin.desktop
usr/share/xfce4-mixer/
usr/share/xfce4-mixer/icons/
usr/share/xfce4-mixer/icons/hicolor/
usr/share/xfce4-mixer/icons/hicolor/24x24/
usr/share/xfce4-mixer/icons/hicolor/24x24/status/
usr/share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-medium.png
usr/share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-low.png
usr/share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-ultra-low.png
usr/share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-high.png
usr/share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-low-medium.png
usr/share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-no-record.png
usr/share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-very-high.png
usr/share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-muted.png
usr/share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-no-muted.png
usr/share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-muted.png
usr/share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-record.png
usr/share/xfce4-mixer/icons/hicolor/48x48/
usr/share/xfce4-mixer/icons/hicolor/48x48/status/
usr/share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-medium.png
usr/share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-low.png
usr/share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-ultra-low.png
usr/share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-high.png
usr/share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-low-medium.png
usr/share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-no-record.png
usr/share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-very-high.png
usr/share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-muted.png
usr/share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-no-muted.png
usr/share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-muted.png
usr/share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-record.png
usr/share/xfce4-mixer/icons/hicolor/16x16/
usr/share/xfce4-mixer/icons/hicolor/16x16/status/
usr/share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-medium.png
usr/share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-low.png
usr/share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-ultra-low.png
usr/share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-high.png
usr/share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-low-medium.png
usr/share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-no-record.png
usr/share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-very-high.png
usr/share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-muted.png
usr/share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-no-muted.png
usr/share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-muted.png
usr/share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-record.png
usr/share/xfce4-mixer/icons/hicolor/scalable/
usr/share/xfce4-mixer/icons/hicolor/scalable/status/
usr/share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-low-medium.svg
usr/share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-muted.svg
usr/share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-very-high.svg
usr/share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-ultra-low.svg
usr/share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-no-muted.svg
usr/share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-low.svg
usr/share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-high.svg
usr/share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-record.svg
usr/share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-medium.svg
usr/share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-no-record.svg
usr/share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-muted.svg
usr/share/locale/
usr/share/locale/sv/
usr/share/locale/sv/LC_MESSAGES/
usr/share/locale/sv/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/uk/
usr/share/locale/uk/LC_MESSAGES/
usr/share/locale/uk/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/pl/
usr/share/locale/pl/LC_MESSAGES/
usr/share/locale/pl/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/fi/
usr/share/locale/fi/LC_MESSAGES/
usr/share/locale/fi/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/fr/
usr/share/locale/fr/LC_MESSAGES/
usr/share/locale/fr/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/sk/
usr/share/locale/sk/LC_MESSAGES/
usr/share/locale/sk/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/tr/
usr/share/locale/tr/LC_MESSAGES/
usr/share/locale/tr/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/lv/
usr/share/locale/lv/LC_MESSAGES/
usr/share/locale/lv/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/id/
usr/share/locale/id/LC_MESSAGES/
usr/share/locale/id/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/ur/
usr/share/locale/ur/LC_MESSAGES/
usr/share/locale/ur/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/ast/
usr/share/locale/ast/LC_MESSAGES/
usr/share/locale/ast/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/zh_CN/
usr/share/locale/zh_CN/LC_MESSAGES/
usr/share/locale/zh_CN/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/pt_BR/
usr/share/locale/pt_BR/LC_MESSAGES/
usr/share/locale/pt_BR/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/eu/
usr/share/locale/eu/LC_MESSAGES/
usr/share/locale/eu/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/hu/
usr/share/locale/hu/LC_MESSAGES/
usr/share/locale/hu/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/am/
usr/share/locale/am/LC_MESSAGES/
usr/share/locale/am/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/ar/
usr/share/locale/ar/LC_MESSAGES/
usr/share/locale/ar/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/ro/
usr/share/locale/ro/LC_MESSAGES/
usr/share/locale/ro/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/cs/
usr/share/locale/cs/LC_MESSAGES/
usr/share/locale/cs/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/ur_PK/
usr/share/locale/ur_PK/LC_MESSAGES/
usr/share/locale/ur_PK/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/nb/
usr/share/locale/nb/LC_MESSAGES/
usr/share/locale/nb/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/ja/
usr/share/locale/ja/LC_MESSAGES/
usr/share/locale/ja/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/si/
usr/share/locale/si/LC_MESSAGES/
usr/share/locale/si/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/ca/
usr/share/locale/ca/LC_MESSAGES/
usr/share/locale/ca/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/nl/
usr/share/locale/nl/LC_MESSAGES/
usr/share/locale/nl/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/pt/
usr/share/locale/pt/LC_MESSAGES/
usr/share/locale/pt/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/it/
usr/share/locale/it/LC_MESSAGES/
usr/share/locale/it/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/ru/
usr/share/locale/ru/LC_MESSAGES/
usr/share/locale/ru/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/es/
usr/share/locale/es/LC_MESSAGES/
usr/share/locale/es/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/gl/
usr/share/locale/gl/LC_MESSAGES/
usr/share/locale/gl/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/de/
usr/share/locale/de/LC_MESSAGES/
usr/share/locale/de/LC_MESSAGES/xfce4-mixer.mo
usr/share/locale/da/
usr/share/locale/da/LC_MESSAGES/
usr/share/locale/da/LC_MESSAGES/xfce4-mixer.mo
install/
install/slack-desc
install/doinst.sh
bash-4.1$


brainvision ha scritto:io, anche se uso davvero pochissimo slapt-get, preferisco sempre fare a mano, è più sicuro, non c'è che dire, ho risolto comunque settando le voci xfce* e le altre come non aggiornabili, esattamente come per le voci del kernel e delle glibc (sempre parlando si slapt-get).
ah! questo mi interessa molto, io ho tre kernel: quello della current, quelo di Con Kolivas e uno realtime, gli aggiornamenti della current queindi li devo fare sempre dal kernel della current se no mi abbassa la versione anche del kernel? così facendo non è che comunque mi tocca anche gli altri due o si?....il kernel realtime lo uso per fare musica e ho diversi programmi, anche quelli me li aggiorna alla current giusto?
ieri sera ho effettuato un aggiornamento della current dal kernel current, ma non mi pare che abbia modificato gli altri due kernel...


brainvision ha scritto:In ultimissima istanza, ieri notte - oddio, notte.. ieri sera tardi ;) - avevo letto un tup post che non trovo più: volevo risponderti ma poi la connessione mi faceva gli scherzetti e non ho avuto la pazienza per insistere.. comunque volevo solo dire che Xfce, KDE, Gnome o Fluxbox o qello che ti pare: un browser con 30 schede aperte, gimp con 3 / 4 grossi file immagini, che altro dicevi?.. fidati, puoi metterci quello che ti 0pare, ma a meno che non abbia un i7, 16 GB RAM ed un ottima scheda video - non dedicata!! - accuserai sempre lentezza o per meglio dire meno reattività!! Stai tranquillo sui questo!
eheheh questo è un fatto curioso: quello che ho scritto ieri sera si riferiva alla versione 4.8 che avevo installato io e che avevo notato che funzionasse molto peggio di kde 4.5.5, ieri sera mi sono deciso di scriverlo sul forum e dopo per scrupolo ho aperto xfce, con mia sorpresa ero alla versione 4.6 (non l'avevo più usato dopo l'upgrade alla current), e questa versione funziona bene, almeno quanto kde, il problema quindi era risolto e allora ho pensato di rimuoverlo prima che rispondesse qualcuno! ;) grazie mille comunque per la risposta!
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Aggiornare XFCE

Messaggioda brainvision » sab dic 10, 2011 16:47

mmm.. allora, ricapitoliamo partendo dalla fine, per semplicità..
Codice: Seleziona tutto
allora ho pensato di rimuoverlo prima che rispondesse qualcuno! ;)
come vedi qui non sfugge nulla a nessuno, quindi pensaci bene, la prossima volta!!
:D :D :D :D :D sto scherzando ovviamente, era per fare una battuta.. ;)

riguardo ai timori per i tuoi kernel, non devi assolutamente preoccuparti.. infatti, quando usi slapt-get e aggiorni o fai downgrade o chissà cosa, gli unici pacchetti che vengono toccati sono quelli presenti anche sul repositry.. e comunque solo i pacchetti! Io per upgrade manuale intendevo scaricare i pacchetti ed usare upgradepkg, non installazioni manuali del kernel, che tu hai fatto per installarti quello di Con kolivas e l'altro (o almeno credo, dimmi se sbaglio). Quindi se esce un aggiornamento del kernel della slackware, usando slapt-get sarà quello che verrà aggiornato, gli altri no.. ma non è detto proprio, anzi di default neanche lo fa, perché come ti ho detto alcuni pacchetti sono messi in black-list! Questo o perché, come i kernel, richiedono modifiche manuali al file /etc/lilo.conf (non vioene fatto in automatico perché uno, come te, ad esempio, potrebbe avere installati i propri kernel e quindi con l'aggiornamento perderebbe queste impostazioni!); altri paccchetti come le glibc, invece, non vengono aggiornati perché s tratta di pacchetti molto molto importanti per il sistema, quindi è consigliabile farlo a manina..

Infine, passando a Xfce.. come vedi hai fatto un bel casotto, in quanto hai pacchetti di Xfce 4.6 e pacchetti di Xfce 4.8!! Io ti cosiglio di tagliare la testa al toro e disinstallare completamente tutti i pacchetti di Xfce, scegliere quale versione vuoi e reinstallarli! Ti spiego il motivo: non credo che tu abbia seguito la storia di Xfce o le sue ultime vicissitudini, quindi ti dico solo brevemente che le due versioni vengono compilate e pacchettizate diversamente l'una dall'altra: Xfce 4.6 pacchettizzato in Slackware 13.37 e current comprende:
- xfce-4.6-******
- xfce4-power-manager-******
- xfce4-notifyd-*******
- thunar-volman
Come vedi non ci sono thunar, orage, Terminal, mousepad.. Sono tutti infatti compresi nella pacchetti principali di Xfce!
Attualmente invece le cose funzionano diversamente: come puoi facilmente vedere dal repository di rworkman, ora ci sono appositi pacchetti per ognuno di questi programmi (tranne Mousepad che è stato abbandonato a causa del suo bug nel caso di ricerca teso - se usata dopo una prima volta non va più - e perché ormai non più sviluppato): quindi nel caso decidi di seguire il mio consiglio ed eliminare tutto prima di reinstallarti Xfce ricordati ovviamente di questi pacchetti (ripeto, basta che vai al repo di rworkman e li trovi tutti); secondo me non c'è bisogno di togliere anche tutte le dipendenze, quelli puoi lasciarle. Solo controlla di avere l'ultima versione: stavo leggendo su LinuxQuestions che ha rilasciato un nuovo build per via di alcuni problemimi minori, oltre ad aggiungere alcuni plugin per il pannello..

Spero di essermi spiegato bene, in caso contrario chiedi ancora, non temere..
bau bau!
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Aggiornare XFCE

Messaggioda Procopio » dom dic 11, 2011 17:43

brainvision ha scritto:mmm.. allora, ricapitoliamo partendo dalla fine, per semplicità..
Codice: Seleziona tutto
allora ho pensato di rimuoverlo prima che rispondesse qualcuno! ;)
come vedi qui non sfugge nulla a nessuno, quindi pensaci bene, la prossima volta!!
:D :D :D :D :D sto scherzando ovviamente, era per fare una battuta.. ;)
hehehe ma ci avevo pensato, lo capivo che non fosse proprio correto, infatti all prox occasione lo lascio;)

brainvision ha scritto:riguardo ai timori per i tuoi kernel, non devi assolutamente preoccuparti.. infatti, quando usi slapt-get e aggiorni o fai downgrade o chissà cosa, gli unici pacchetti che vengono toccati sono quelli presenti anche sul repositry.. e comunque solo i pacchetti! Io per upgrade manuale intendevo scaricare i pacchetti ed usare upgradepkg, non installazioni manuali del kernel, che tu hai fatto per installarti quello di Con kolivas e l'altro (o almeno credo, dimmi se sbaglio). Quindi se esce un aggiornamento del kernel della slackware, usando slapt-get sarà quello che verrà aggiornato, gli altri no.. ma non è detto proprio, anzi di default neanche lo fa, perché come ti ho detto alcuni pacchetti sono messi in black-list! Questo o perché, come i kernel, richiedono modifiche manuali al file /etc/lilo.conf (non vioene fatto in automatico perché uno, come te, ad esempio, potrebbe avere installati i propri kernel e quindi con l'aggiornamento perderebbe queste impostazioni!); altri paccchetti come le glibc, invece, non vengono aggiornati perché s tratta di pacchetti molto molto importanti per il sistema, quindi è consigliabile farlo a manina..
bene, perfetto:) sei stato molto chiaro, solo una cosa, io non uso slapt-get, ma slackpkg e questo dovrebbe preoccuparsi, ogni volta che fa un aggiornamento della current, di controllare prima le glibc ed installare quelle per prima, giusto? per ora sto facendo così ed infatti le glibc non sono blacklistate, e neanche il kernel:
Codice: Seleziona tutto
root@darkstar:/etc/slackpkg# cat blacklist
# This is a blacklist file. Any packages listed here won't be
# upgraded, removed, or installed by slackpkg.
#
# The correct syntax is:
#
# To blacklist the package xorg-server-1.6.3-x86_64-1 the line will be:
# xorg-server
#
# DON'T put any space(s) before or after the package name or regexp.
# If you do this, the blacklist will NOT work.

#
# Automated upgrade of kernel packages aren't a good idea (and you need to
# run "lilo" after upgrade). If you think the same, uncomment the lines
# below
#
#kernel-firmware
#kernel-generic
#kernel-generic-smp
#kernel-headers
#kernel-huge
#kernel-huge-smp
#kernel-modules
#kernel-modules-smp
#kernel-source

#
# aaa_elflibs can't be updated.
#
aaa_elflibs

# You can blacklist using regular expressions.
#
# Don't use *full* regex here, because all of the following
# will be checked for the regex: series, name, version, arch,
# build and fullname.
#
# This one will blacklist all SBo packages:
#[0-9]+_SBo
jack-audio-connection-kit
root@darkstar:/etc/slackpkg#
quindi io non le installo mai a mano, ma è comunque corretto no?


brainvision ha scritto:Infine, passando a Xfce.. come vedi hai fatto un bel casotto, in quanto hai pacchetti di Xfce 4.6 e pacchetti di Xfce 4.8!! Io ti cosiglio di tagliare la testa al toro e disinstallare completamente tutti i pacchetti di Xfce, scegliere quale versione vuoi e reinstallarli!
ok, farò proprio così, ed installo la versione della current, per il momento mi basta quella, poi se intenderò passare all 4.8 disinstallo la 4.6 e installo da capo, corretto?
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Precedente

Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 3 ospiti