Repository 32bit  Forum
Repository 64bit  Wiki

problema configurazione

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

problema configurazione

Messaggioda LELLO_X » dom lug 17, 2011 13:19

ciao a tutti, sono un ragazzo che ha messo da poco piede nel linux, è la mia prima esperienza... uso windows xp professional con 4 gb di ram... ho scaricato e istallato virtualbox per creare una macchina virtuale e poi ho istallato il linus slackware 13.37.... ho eseguito l'stallazione seguendo una guida passo passo e arrivo alla fine, riavvio il pc e al riavvio mi carica la prima schermata di settings però nel caricare le icone riappare la schermata nera dicendomi che non trova il monitor... durante l'istallazione ho selezionato KDE... dov'é l'errore??
in attesa di risporta, grazie mille...
LELLO_X
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: dom lug 17, 2011 13:04
Nome Cognome: Antonello Romano

Re: problema configurazione

Messaggioda hashbang » dom lug 17, 2011 14:20

che scheda video usi?

Se non lo sai dai, dalla console (come utente root) un:
Codice: Seleziona tutto
# lscpi -v | grep VGA
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1834
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: problema configurazione

Messaggioda 414N » dom lug 17, 2011 15:11

LELLO_X ha scritto:ciao a tutti, sono un ragazzo che ha messo da poco piede nel linux, è la mia prima esperienza... uso windows xp professional con 4 gb di ram... ho scaricato e istallato virtualbox per creare una macchina virtuale e poi ho istallato il linus slackware 13.37.... ho eseguito l'stallazione seguendo una guida passo passo e arrivo alla fine, riavvio il pc e al riavvio mi carica la prima schermata di settings però nel caricare le icone riappare la schermata nera dicendomi che non trova il monitor... durante l'istallazione ho selezionato KDE... dov'é l'errore??
in attesa di risporta, grazie mille...

Probabilmente c'è qualche problema con la scheda video emulata da virtualbox. Forse non hai abilitato l'accelerazione 2D (la 3D non so quanto sia affidabile). Prova ad abilitarla e vediamo.
Se ancora non funziona, esegui il comando suggerito da atomix600, così possiamo capire che scheda viene emulata da virtualbox.
Il log dell'errore lo puoi comunque leggere con
Codice: Seleziona tutto
less /var/log/Xorg.0.log
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: problema configurazione

Messaggioda LELLO_X » lun lug 18, 2011 14:46

allora la mia scheda video è una nvidia 9800 GT però non ho ben capito come devo eseguire i comandi da voi indicati (sono ancora alle prime armi) quindi se potreste darmi dei passaggi più dettagliati per vedere dov'é l'accelerazione 2D e per capire cosa emula virtualbox vi sarei grato...
LELLO_X
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: dom lug 17, 2011 13:04
Nome Cognome: Antonello Romano

Re: problema configurazione

Messaggioda 414N » lun lug 18, 2011 14:54

Il fatto di abilitare o meno l'accelerazione video lo devi fare dalla GUI di VirtualBox.
Non avendolo mai usato, non saprei dirti dove cercare di preciso. Da alcuni screenshot che ho visto in giro, però, mi pare che basti cliccare su una macchina virtuale per vederne le caratteristiche principali, ed una di queste mi pare riguardasse proprio l'accelerazione video.
Per quanto riguarda i comandi, dato che non ti parte la sessione grafica (o, se non ho capito male, ti parte ma va in crash poco dopo), devi eseguirli nella modalità testuale. Se quando avvi la macchina virtuale, questa ti arriva direttamente alla schermata di login grafico, premi CTRL+ALT+1 per andare in una schermata testuale; esegui login come root e prova quanto ti abbiamo indicato io e atomix600.
Se, invece, la macchina parte ma rimane in modalità testuale e tu ogni volta devi dare startx per far partire la modalità grafica, allora li puoi eseguire prima di startx quei comandi.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: problema configurazione

Messaggioda hashbang » lun lug 18, 2011 15:10

Posta il log come richiesto da 414N, anche perchè come dice il file CHANGES_AND_HINTS.TXT presente nel DVD
Changes_and_Hints.txt ha scritto:Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection


Infatti ci sono altri topic di utenti nvidia che hanno avuto il tuo stesso problema con KDE, ma che hanno risolto con l'installazione dei driver proprietari.
Fai una cosa, oltre al log che ti è stato chiesto, prova a partire con un altro DE come XFCE e vedi se questo problema si verifica.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1834
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: problema configurazione

Messaggioda LELLO_X » mar lug 19, 2011 1:09

messo l'acceleratore 2D ma non cambia niente...
il problema è che si avvia la schermata video però dopo va in crash quando mi deve caricare l'ultima icona per mettere la lingua in italiano....
ho scritto ciò che mi avete detto torna alla schermata video però dopo va nuovamente in crash....
dove trovo questi driver proprietari?? nel CD??
e poi dove trovo XFCE??
LELLO_X
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: dom lug 17, 2011 13:04
Nome Cognome: Antonello Romano

Re: problema configurazione

Messaggioda 414N » mar lug 19, 2011 8:33

LELLO_X ha scritto:messo l'acceleratore 2D ma non cambia niente...
il problema è che si avvia la schermata video però dopo va in crash quando mi deve caricare l'ultima icona per mettere la lingua in italiano....

Di quale icona stai parlando? Di quella con la K? Oppure dell'applet della lingua nel vassoio del sistema a KDE avviato?
LELLO_X ha scritto:ho scritto ciò che mi avete detto torna alla schermata video però dopo va nuovamente in crash....

Evidentemente non ci siamo capiti. I comandi che ti abbiamo elencato servono per ottenere l'elenco delle schede video nel sistema (lspci) e leggere il log di X (less /var/log/Xorg.0.log). Non sono "comandi magici" che ti risolvono il problema. Dovresti eseguire per prima cosa il comando suggerito da atomix600 per capire quale scheda video ti simula VirtualBox, e poi riportare il contenuto del log di X per capire cosa lo fa andare in crash ogni volta.
Dovresti essere in grado di copiare del testo dalla macchina virtuale alla macchina reale se hai abilitato la clipboard bidirezionale.
LELLO_X ha scritto:dove trovo questi driver proprietari?? nel CD??

Lascia stare i driver proprietari, per il momento. Non sappiamo neanche che scheda video venga emulata...
Ma hai installato il sistema da CD o DVD? Se da CD, quali CD hai installato? Tutti?
LELLO_X ha scritto:e poi dove trovo XFCE??

Se hai fatto un'installazione full, è già installato. Se parti in modalità grafica (non ce l'hai ancora detto), ti basta selezionare come sessione XFCE invece di KDE.
Se parti in modalità testo e avvi la modalità grafica con startx, prima di dare startx usa xwmconfig per scegliere l'ambiente desktop che startx lancerà.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: problema configurazione

Messaggioda Kronos » mar lug 19, 2011 8:42

I driver proprietari devi andare sul sito nVidia e scaricarteli da lì; nel wiki di slacky trovi le indicazioni su come installarli: dai un'occhiata alla sezione dedicata alla configurazione di X e leggiti anche l'articolo dedicato ai problemi noti della 13.37.

Invece per quanto riguarda XFCE basta che usi il comando xwmconfig e potrai scegliere di utilizzare XFCE al posto di KDE.
Ciao
Kronos
Linux 2.0
Linux 2.0
 
Messaggi: 126
Iscritto il: gio mar 09, 2006 21:50
Località: In Calabria

Re: problema configurazione

Messaggioda hashbang » mar lug 19, 2011 9:42

LELLO_X ha scritto:ho scritto ciò che mi avete detto torna alla schermata video però dopo va nuovamente in crash....

Quello che hai scritto dovresti postarlo.
Non caricare la sessione grafica, perchè:
a) Il problema non è risolto, in quanto non abbiamo un idea precisa del tuo problema, almeno finchè non porti quello che ti è stato chiesto
b) Per quei comandi non serve a nulla. Basta la console.

LELLO_X ha scritto:dove trovo questi driver proprietari?? nel CD??

Lascia perdere per ora i driver proprietari...

LELLO_X ha scritto:e poi dove trovo XFCE??
Da una shell:
Codice: Seleziona tutto
xwmconfig


oppure se usi il KDM, selezioni XFCE dalla lista della sessione.
Questo se lo hai installato (con una installazione full non dovresti avere problemi).

Per sapere se è installato dai un:
Codice: Seleziona tutto
ls /var/log/packages/xfce*

E controlla che il pacchetto di xfce sia presente.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1834
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: problema configurazione

Messaggioda 414N » mar lug 19, 2011 10:15

Kronos ha scritto:I driver proprietari devi andare sul sito nVidia e scaricarteli da lì; nel wiki di slacky trovi le indicazioni su come installarli: dai un'occhiata alla sezione dedicata alla configurazione di X e leggiti anche l'articolo dedicato ai problemi noti della 13.37.

Ti faccio presente che LELLO_X sta cercando di usare Slackware in ambito di VirtualBox, percui non dovrebbe servirgli nessun driver proprietario per far andare la grafica.
@LELLO_X: se riporti output di comandi/listati lunghi nel forum, usa i tag code, mi raccomando...
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: problema configurazione

Messaggioda LELLO_X » mar lug 19, 2011 11:20

@414N quando mi carica l'icona con la K va in crash....
comunque io entro come root, inserisco la pass e dopo ho scritto "lscpi -v | grep VGA" il cursore va a capo però non mi compare niente... come faccio a capire che scheda video mi emula??
ho utilizzato un DVD non un CD... un iso montato con alcool....
LELLO_X
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: dom lug 17, 2011 13:04
Nome Cognome: Antonello Romano

Re: problema configurazione

Messaggioda LELLO_X » mar lug 19, 2011 11:26

mettendo xface è risolto il problema... però vorrei capire perchè con KDE non va...
LELLO_X
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: dom lug 17, 2011 13:04
Nome Cognome: Antonello Romano

Re: problema configurazione

Messaggioda 414N » mar lug 19, 2011 11:49

Dato che XFCE parte, probabilmente si tratta di un problema con la composizione desktop di KDE.
Hai fondamentalmente due modi per disabilitarla in modo da evitare che KDE crashi all'avvio: disabilitarla a livello di kwin (il gestore delle finestre di KDE) oppure disabilitarla a livello di X (incide su tutti i desktop environment che puoi usare).
Per disabilitarla a livello di kwin, apri un terminale in XFCE (tipo xterm) ed inserisci il comando
Codice: Seleziona tutto
kwriteconfig --file kwinrc --group Compositing --key Enabled false

Prova a vedere se ha funzionato eseguendo un logout e riprovando a far partire KDE.
Se invece kwin "non sta capito", usa il primo consiglio di atomix600, ovvero crea un file /etc/X11/xorg.conf (devi essere root per farlo) con questo contenuto:
Codice: Seleziona tutto
Section "Extensions"
Option "Composite" "Disable"
EndSection

Se hai bisogno di altre indicazioni (soprattutto riguardo il secondo metodo), non esitare a chiedere.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: problema configurazione

Messaggioda LELLO_X » mer lug 20, 2011 2:50

per il secondo modo non sapreste darmi un video tutorial da seguire magari?? oppure una guida con delle immagini??
LELLO_X
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: dom lug 17, 2011 13:04
Nome Cognome: Antonello Romano

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 3 ospiti