Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Installazione 13.37: tastiera morta.

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Installazione 13.37: tastiera morta.

Messaggioda makbell » lun lug 18, 2011 17:51

Ciao a tutti, ho un problema simile a quello di Y4ri: devo installare la slack 13.37 su un notebook che ha installato Kubuntu, cancellando tutto. Avvio il pc, premo "Esc" (quindi la tastiera funziona subito), seleziono l'avvio da dvd e si avvia, ma alla prima schermata non posso neanche premere "invio" perchè la tastiera è morta: Come posso aggirare il problema? :cry:
Ultima modifica di makbell il ven lug 22, 2011 22:41, modificato 1 volta in totale.
Avatar utente
makbell
Linux 2.4
Linux 2.4
 
Messaggi: 202
Iscritto il: lun dic 20, 2004 0:00
Località: brescia

Re: Installazione 13.37: tastiera morta.

Messaggioda slux » lun lug 18, 2011 18:04

Ci puoi dire che portatile usi?
Non è che la tastiera è connessa internamente al bus usb?Se fosse così,magari devi controllare se nel bios puoi attivare il supporto "usb legacy".
Se non risolvi ,prova ad aggiornare il bios.
Altrimenti non saprei.
Avatar utente
slux
Linux 2.6
Linux 2.6
 
Messaggi: 782
Iscritto il: dom mar 20, 2005 0:00
Località: Prato
Nome Cognome: Andrea Amerini
Slackware: 14.1 x86
Kernel: 3.12.0-smp
Desktop: xfce 4.10

Re: Installazione 13.37: tastiera morta.

Messaggioda 414N » lun lug 18, 2011 18:07

Anch'io ho avuto un problema del genere al momento di installare la 13.1 sul portatile.
Ti rimando a questo mio post.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Installazione 13.37: tastiera morta.

Messaggioda makbell » lun lug 18, 2011 18:27

Allora: il pc è un vecchio Fujitsu amilo di cui non sono riuscito a capire che processore monta. Non so se la tastiera è usb interna, ma non capisco perchè si disattivi alla partenza del dvd. Boh?! Grazie intanto per l'aiuto. Ciao: Mak!
Avatar utente
makbell
Linux 2.4
Linux 2.4
 
Messaggi: 202
Iscritto il: lun dic 20, 2004 0:00
Località: brescia

Re: Installazione 13.37: tastiera morta.

Messaggioda yAri » lun lug 18, 2011 19:06

Credo che il problema sia quello di 414N, vi farò sapere qui. Grazie mille per l'aiuto.
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Installazione 13.37: tastiera morta.

Messaggioda makbell » mar lug 19, 2011 18:37

Adesso sono proprio messo bene: all'avvio mi si presenta Grub (prima si avviava direttamente Ubuntu) e, avendo la tastiera morta, non posso avviare niente. Bel casino. Penso che non potrei neanche aggiornare il Bios, visto che non posso usare la tastiera. Che faccio: lo sbatto all'isola ecologica? :evil:
Avatar utente
makbell
Linux 2.4
Linux 2.4
 
Messaggi: 202
Iscritto il: lun dic 20, 2004 0:00
Località: brescia

Re: Installazione 13.37: tastiera morta.

Messaggioda targzeta » mar lug 19, 2011 18:49

makbell ha scritto:Adesso sono proprio messo bene: all'avvio mi si presenta Grub (prima si avviava direttamente Ubuntu) e, avendo la tastiera morta, non posso avviare niente. Bel casino. Penso che non potrei neanche aggiornare il Bios, visto che non posso usare la tastiera. Che faccio: lo sbatto all'isola ecologica? :evil:

Basta che avvii una live e sistemi Grub o lilo. Altrimenti lo puoi "sbattere" a casa mia, c'è tanto spazio qui :lol:

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Installazione 13.37: tastiera morta.

Messaggioda zoros » mar lug 19, 2011 20:00

mi chiedevo se era possibile collegare temporaneamente una seconda tastiera usb ... il notebook avrà delle porte usb, immagino :-k ...

un'altra cosa (forse serve): nel config del kernel huge troviamo:
CONFIG_HID=m
...
CONFIG_USB_HID=m
e, a quanto pare, il solo kernel non è in grado di gestire le tastiere usb, deve poter caricare i moduli aggiuntivi ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Installazione 13.37: tastiera morta.

Messaggioda makbell » mar lug 19, 2011 21:15

Per spina: già provato con la tastiera usb ma all'inizio non carica nessun driver e poi finchè non avvii il sistema il kernel non viene caricato.
Per zoros: l'ultima chance è proprio una Live. Domani provo e riferisco.
Intanto grazie a tutti. Ciao.
Avatar utente
makbell
Linux 2.4
Linux 2.4
 
Messaggi: 202
Iscritto il: lun dic 20, 2004 0:00
Località: brescia

Re: Installazione 13.37: tastiera morta.

Messaggioda targzeta » mar lug 19, 2011 21:36

makbell ha scritto:Per spina: già provato con la tastiera usb ma all'inizio non carica nessun driver e poi finchè non avvii il sistema il kernel non viene caricato.
Per zoros: l'ultima chance è proprio una Live. Domani provo e riferisco.
Intanto grazie a tutti. Ciao.

Mi sa che hai invertito i nomi :lol:

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Installazione 13.37: tastiera morta.

Messaggioda makbell » mer lug 20, 2011 18:32

Hai ragione, chiedo venia. :oops:
Secondo voi è possibile modificare il file "isolinux.cfg" della ISO e, dopo aver rimasterizzato, fare in modo che si avvii direttamente l'installazione senza alcun prompt?
Avatar utente
makbell
Linux 2.4
Linux 2.4
 
Messaggi: 202
Iscritto il: lun dic 20, 2004 0:00
Località: brescia

Re: Installazione 13.37: tastiera morta.

Messaggioda 414N » mer lug 20, 2011 19:01

Sicuro di non aver cambiato qualche altra impostazione nel BIOS, oltre a quella riguardante il boot order?
Controlla che non ci sia una voce del tipo "Plug and Play OS", e prova a cambiarla.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Installazione 13.37: tastiera morta.

Messaggioda zoros » mer lug 20, 2011 20:26

makbell ha scritto:Hai ragione, chiedo venia. :oops:
Secondo voi è possibile modificare il file "isolinux.cfg" della ISO e, dopo aver rimasterizzato, fare in modo che si avvii direttamente l'installazione senza alcun prompt?

ciò che scrivi è abbastanza incomprensibile: anche senza input da tastiera il CD/DVD di avvio di Slackware parte da solo dopo circa 2 minuti ... a sistema avviato la tastiera deve funzionare, altrimenti non funzionerà neanche dopo aver installato il tutto su hard disk ...

e poi, come suggerisce
414N ha scritto:Sicuro di non aver cambiato qualche altra impostazione nel BIOS, oltre a quella riguardante il boot order?
Controlla che non ci sia una voce del tipo "Plug and Play OS", e prova a cambiarla.
si deve poter risolvere da bios ... a meno che la tastiera non sia irrimediabilmente guasta ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Installazione 13.37: tastiera morta.

Messaggioda makbell » gio lug 21, 2011 19:33

Allora, come ho detto all'inizio: appena avviato il pc premo Esc e mi appare la sequenza dei dispositivi che posso avviare e in questo momento la tastiera funziona. Selezionando il cd e dando invio si avvia il dvd di Slackware, arriva subito al prompt in cui potrei dare solo invio o passare dei parametri particolari ma la tastiera rimane morta. Nel Bios non esiste alcuna voce riguardo PnP. Sto pensando di provare a mettere una ISO minimale su una chiavetta usb e vedere che succede.
P.s.: il dvd di installazione a me non parte nemmeno dopo 10 minuti.
Avatar utente
makbell
Linux 2.4
Linux 2.4
 
Messaggi: 202
Iscritto il: lun dic 20, 2004 0:00
Località: brescia

Re: Installazione 13.37: tastiera morta.

Messaggioda 414N » gio lug 21, 2011 20:01

Non è che la tastiera abbia un qualche tasto incastrato che rimane costantemente premuto?
Se non è nemmeno questo, io proverei a ripristinare i valori di default del BIOS.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti