Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto] KDE mezzo in italiano e mezzo in inglese...

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto] KDE mezzo in italiano e mezzo in inglese...

Messaggioda federfigo5 » sab lug 30, 2011 21:11

Ciao a tutti!
Ho installato slack 13.37 e ho installato il pacchetto di traduzione kde it dal dvd dopo... Vedendo che i programmi e alcune scritte erano rimasti in inglese, installato pure il pacchetto trovato qui sul forum... Ma continua ad essere mezzo in italiano e mezzo in inglese! :evil:
Come posso fare?

Grazie in anticipo.
Ultima modifica di federfigo5 il lun ago 01, 2011 8:33, modificato 1 volta in totale.
federfigo5
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: sab lug 30, 2011 19:33
Slackware: Slack 13.37
Kernel: 2.6.37.6

Re: KDE mezzo in italiano e mezzo in inglese...

Messaggioda navajo » sab lug 30, 2011 21:31

Quale pacchetto di slacky.eu hai installato ??
hai letto slackware for dummies ??? è una specie di bibbia per chi usa slackware. Anche se è riferito a una vecchia versione di slackware, è sempre una fonte di notizie.
comunque, hai modificato i file
Codice: Seleziona tutto
/etc/profile.d/lang.sh
e
Codice: Seleziona tutto
/etc/profile.d/lang.csh
?
Avatar utente
navajo
Staff
Staff
 
Messaggi: 3782
Iscritto il: gio gen 08, 2004 0:00
Località: Roma
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)

Re: KDE mezzo in italiano e mezzo in inglese...

Messaggioda federfigo5 » sab lug 30, 2011 21:37

Si l'ho letto slack for dummies (ottima guida). Li ho modificati proprio come diceva...
federfigo5
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: sab lug 30, 2011 19:33
Slackware: Slack 13.37
Kernel: 2.6.37.6

Re: KDE mezzo in italiano e mezzo in inglese...

Messaggioda federfigo5 » sab lug 30, 2011 21:42

Ho installato con installpkg kde-l10n-it-4.5.5-noarch-3.txz...
federfigo5
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: sab lug 30, 2011 19:33
Slackware: Slack 13.37
Kernel: 2.6.37.6

Re: KDE mezzo in italiano e mezzo in inglese...

Messaggioda 414N » dom lug 31, 2011 9:23

Ma hai cambiato le impostazioni regionali nelle impostazioni di sistema di KDE?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: KDE mezzo in italiano e mezzo in inglese...

Messaggioda federfigo5 » dom lug 31, 2011 17:23

Si si le ho cambiate...
federfigo5
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: sab lug 30, 2011 19:33
Slackware: Slack 13.37
Kernel: 2.6.37.6

Re: KDE mezzo in italiano e mezzo in inglese...

Messaggioda 414N » dom lug 31, 2011 17:32

Allora non capisco cosa possa essere rimasto di KDE ancora in inglese.
Se parli di Firefox, sappi che non fa parte di KDE (usa le GTK, tra l'altro), e hai un paio di strade per italianizzarlo.
Ti rimando a questo mio post passato per alcuni suggerimenti.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: KDE mezzo in italiano e mezzo in inglese...

Messaggioda federfigo5 » dom lug 31, 2011 18:40

Ad esempio Konqueror è in inglese, k3b pure etc... Ma cosa ho fatto di sbagliato? :(
Potreste gentilmente linkarmi il .txz giusto?
federfigo5
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: sab lug 30, 2011 19:33
Slackware: Slack 13.37
Kernel: 2.6.37.6

Re: KDE mezzo in italiano e mezzo in inglese...

Messaggioda navajo » dom lug 31, 2011 19:15

federfigo5 ha scritto:Ad esempio Konqueror è in inglese, k3b pure etc... Ma cosa ho fatto di sbagliato? :(
Potreste gentilmente linkarmi il .txz giusto?

Forse hai sbagliato qualcosa nei file lang.sh e .csh

ecco i miei :
Codice: Seleziona tutto
/etc/profile.d/lang.sh

Codice: Seleziona tutto
#!/bin/sh
# Set the system locale.  (no, we don't have a menu for this ;-)
# For a list of locales which are supported by this machine, type:
#   locale -a

# en_US is the Slackware default locale:
export LANG=it_IT.UTF-8

# 'C' is the old Slackware (and UNIX) default, which is 127-bit
# ASCII with a charmap setting of ANSI_X3.4-1968.  These days,
# it's better to use en_US or another modern $LANG setting to
# support extended character sets.
#export LANG=C

# There is also support for UTF-8 locales, but be aware that
# some programs are not yet able to handle UTF-8 and will fail to
# run properly.  In those cases, you can set LANG=C before
# starting them.  Still, I'd avoid UTF unless you actually need it.
#export LANG=en_US.UTF-8

# Another option for en_US:
#export LANG=en_US.ISO8859-1

# One side effect of the newer locales is that the sort order
# is no longer according to ASCII values, so the sort order will
# change in many places.  Since this isn't usually expected and
# can break scripts, we'll stick with traditional ASCII sorting.
# If you'd prefer the sort algorithm that goes with your $LANG
# setting, comment this out.
export LC_COLLATE=C

# End of /etc/profile.d/lang.sh

E il mio
Codice: Seleziona tutto
 /etc/profile.d/lang.csh

Codice: Seleziona tutto
# Set the system locale.  (no, we don't have a menu for this ;-)
# For a list of locales which are supported by this machine, type:
#   locale -a

# en_US is the Slackware default locale:
setenv LANG it_ IT

# 'C' is the old Slackware (and UNIX) default, which is 127-bit
# ASCII with a charmap setting of ANSI_X3.4-1968.  These days,
# it's better to use en_US or another modern $LANG setting to
# support extended character sets.
#setenv LANG C

# There is also support for UTF-8 locales, but be aware that
# some programs are not yet able to handle UTF-8 and will fail to
# run properly.  In those cases, you can set LANG=C before
# starting them.  Still, I'd avoid UTF unless you actually need it.
#setenv LANG en_US.UTF-8

# Another option for en_US:
#setenv LANG en_US.ISO8859-1

# One side effect of the newer locales is that the sort order
# is no longer according to ASCII values, so the sort order will
# change in many places.  Since this isn't usually expected and
# can break scripts, we'll stick with traditional ASCII sorting.
# If you'd prefer the sort algorithm that goes with your $LANG
# setting, comment this out.
setenv LC_COLLATE C

# End of /etc/profile.d/lang.csh
Avatar utente
navajo
Staff
Staff
 
Messaggi: 3782
Iscritto il: gio gen 08, 2004 0:00
Località: Roma
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)

Re: KDE mezzo in italiano e mezzo in inglese...

Messaggioda 414N » dom lug 31, 2011 19:32

federfigo5 ha scritto:Ad esempio Konqueror è in inglese, k3b pure etc... Ma cosa ho fatto di sbagliato? :(
Potreste gentilmente linkarmi il .txz giusto?

Sembrano proprio sintomi della mancanza del pacchetto kde-l10n-it-4.5.5-noarch-3.txz. Per curiosità, quale sarebbe il pacchetto pescato da slacky che hai installato per risolvere il problema?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: KDE mezzo in italiano e mezzo in inglese...

Messaggioda federfigo5 » lun ago 01, 2011 8:32

Boh, era un pacchetto trovato come suggerimento in una discussione sul forum, ma non aveva niente di sbagliato.... Ero semplicemente io che avevo fatto "errori di copiatura" nel lang.sh...
Grazie ho risolto!!
federfigo5
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: sab lug 30, 2011 19:33
Slackware: Slack 13.37
Kernel: 2.6.37.6


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite