Repository 32bit  Forum
Repository 64bit  Wiki

Impressioni su KDE 4.7

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Impressioni su KDE 4.7

Messaggioda sya54M » dom dic 04, 2011 17:44

EmaDaCuz ha scritto:E il 30% di carico per core e' perche' ho un Phenom...

io ho un phenom2 x6 e una nvidia e il carico della cpu è alto pure che ho la geforce... anche a me arriva al 30% di carico su ogni core senza niente aperto
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

Re: Impressioni su KDE 4.7

Messaggioda Trotto@81 » dom dic 04, 2011 18:02

Cambiate CPU, perchè con un i7 920 non ho nessun problema di carico.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3029
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: Impressioni su KDE 4.7

Messaggioda sya54M » dom dic 04, 2011 18:54

Trotto@81 ha scritto:Cambiate CPU, perchè con un i7 920 non ho nessun problema di carico.

e certo... devo dire che è una soluzione intelligente, giustamente se kde è difettoso butto il pc comprato qualche mese fa e ne compro un altro... perchè non ci ho pensato prima?
Ultima modifica di sya54M il dom dic 04, 2011 19:39, modificato 1 volta in totale.
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

Re: Impressioni su KDE 4.7

Messaggioda submax82 » dom dic 04, 2011 19:11

[OT] povero kde è bello e usa le meravigliose QT, ma il miglior DE è xfce, ormai è l'unico stabile e veloce su ogni tipo di hardware. [/OT]
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Re: Impressioni su KDE 4.7

Messaggioda sya54M » dom dic 04, 2011 19:30

appena provato con gli stessi programmi aperti (kaffeine in uso con la dvb, firefox e pidgin)... ho notato una cosa particolare... l'uso della cpu su entrambi di DE aumenta complessivamente del 10% visualizzando la textarea di questo forum per rispondere ai topic...
in pratica ho ottenuto questi risultati coi programmi su detti:
kde 4.7.3 sulla textarea: ~25%
kde 4.7.3 fuori dalla textarea: ~15%
xfce 4.6.2 sulla textarea: ~15%
xfce 4.6.2 fuori dalla textarea: ~5%

in definitiva kde mi carica la cpu il 10% in più

da notare però che tutte le prove sono con kaffeine che riproduce la tv dalla dvb... per esempio senza niente aperto su xfce stava a 0%
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

Re: Impressioni su KDE 4.7

Messaggioda Trotto@81 » dom dic 04, 2011 19:55

E' un bug noto di Firefox con le gif animate, ci hanno provato anche a ridurlo, ma meno di così pare non andare.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3029
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: Impressioni su KDE 4.7

Messaggioda sya54M » dom dic 04, 2011 20:08

Trotto@81 ha scritto:E' un bug noto di Firefox con le gif animate, ci hanno provato anche a ridurlo, ma meno di così pare non andare.

ho capito, non lo sapevo.
comunque come si vede nel mio ultimo post, nei primi post ho esagerato... consuma di più ma non esageratamente... il problema è che quando xfce caricherebbe 0 senza niente aperto, kde carica 10

su entrambi ho attivato il composite anche se kde ha più effetti
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

Re: Impressioni su KDE 4.7

Messaggioda Trotto@81 » dom dic 04, 2011 20:18

Ma qual'è il processo di KDE incriminato?
Come stabilisci che KDE consuma il 25% delle risorse della tua cpu?
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3029
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: Impressioni su KDE 4.7

Messaggioda sya54M » dom dic 04, 2011 20:29

un po' ciascuno... plasma-desktop, kwin e quando questi sono aperti anche X consuma di più

poi del 25% il 10% era firefox con le gif e il 5% kaffeine con la tv, quindi rimane 10% di carico solo per kde
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

Re: Impressioni su KDE 4.7

Messaggioda rik70 » lun dic 05, 2011 8:58

Che scheda video hai? Driver?

Lo fa solo con kde 4.7 o anche col 4.5.5?
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1255
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Impressioni su KDE 4.7

Messaggioda sya54M » lun dic 05, 2011 11:46

geforce gt440 montata dalla gainward e uso gli ultimi driver proprietari nvidia (290.10)
col 4.5.5 non lo so perchè ho sempre usato la current e se disponibile la versione più nuova dei pacchetti di alien di kde e quando ho assemblato questo pc era già passata quella versione
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

Re: Impressioni su KDE 4.7

Messaggioda rik70 » lun dic 05, 2011 13:15

E rimuovere i pacchetti di alien e installare quelli di Pat.... o è troppo "oneroso"? Almeno vedi se è un prob della versione specifica di kde. Su xfce Xorg quanta cpu usa? Se disattivi tutti gli effetti grafici com'è la situazione?

Coi driver nvidia, Xorg da me ha sempre "consumato" più di quanto non faccia ad es. con i radeon open, senza distinzione tra i vari DE/WM. Altra cosa che ho notato: quando riproduco un video con qualsiasi player su kde, Xorg schizza verso l'alto in modo evidente rispetto ad altri ambienti grafici. Ma io non faccio testo: ho un pc vecchio e al massimo ho usato gli nvidia lecacy 173.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1255
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Impressioni su KDE 4.7

Messaggioda sya54M » lun dic 05, 2011 13:32

su xfce ho già scritto che senza altri programmi aperti sta a 0% di conseguenza anche xorg carica 0...
il composite era attivo anche su xfce quando stava a 0% anche se xfce supporta solo trasparenza e ombre come effetti del composite e se li disattivo su kde non cambia niente... il problema non sono i driver video e la riproduzione di mpeg2 come ho già scritto, consuma poco su tutti DE, il 5% con kaffeine e credo anche meno con vlc usando l'accelerazione della gpu.
mi ricordo che era uguale anche col 4.6, non mi va di installare il 4.5 che sono sicuro che non cambia niente... la questione è semplice, kde carica il 10% della cpu (phenom2) solo lui, la scheda video e gli effetti grafici non centrano
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

Re: Impressioni su KDE 4.7

Messaggioda rik70 » lun dic 05, 2011 15:22

Uhm.... a rigor di logica, a giudicare dai processi che impegnano la cpu, dovrebbe trattarsi di un problema grafico. E' da vedere se la colpa è del solo kde o dei driver+scheda video+kde

Un modo per verificarlo è far partire Xorg coi driver vesa sempre che kde si avvii con questa configurazione. Se la cpu scende a livelli prossimi allo zero è un problema di driver nvidia. Se non va coi vesa, prova i nouveau o i vecchi nv e vedi se cambia qualcosa.

Altrimenti come non detto.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1255
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Impressioni su KDE 4.7

Messaggioda sya54M » lun dic 05, 2011 15:53

coi nv e nouveau non parte proprio xorg, rimane il cursore lampeggiante, credo perchè la scheda non sia ancora supportata (dovrei leggere il log di xorg per esserne sicuro), penso così perchè ho la stessa installazione di slackware di quando avevo la geforce fx5700 che funzionava sia coi nouveau che coi nv.
coi vesa parte, il carico sulla cpu effettivamente si riduce parecchio, arriva anche a 0 quando sta tutto fermo, ma la risoluzione dello schermo è così bassa che il cursore lo vedo grosso quanto un dito, quindi magari l'allegerimento è dovuto solo alla bassa risoluzione
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

PrecedenteProssimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti