Repository 32bit  Forum
Repository 64bit  Wiki

RISOLTO-Assenza di suono.

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

RISOLTO-Assenza di suono.

Messaggioda nonnogs » dom ago 28, 2011 20:47

In altro topic dissi che ero riuscito ad avere il suono e la stampa,dopo ggiornai e forse questo ha provocato la sparizione del suono.Ho configurato alsaconf -tutto regolare - ma alsamixer mi da questa risposta :
Codice: Seleziona tutto
root@myhost:~# alsamixer
ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so
cannot open mixer: No such device or address


Ho cercato nella letteratura più diversa,nel forum anche ma non ho trovato niente.Potrei avere un chiarimento?Grazie.
Ultima modifica di nonnogs il mer ago 31, 2011 16:35, modificato 1 volta in totale.
nonnogs
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: gio giu 30, 2011 20:09
Nome Cognome: giorgio scubla
Slackware: 13.37 DVD
Kernel: 2.6.37-r?

Re: Assenza di suono.

Messaggioda targzeta » dom ago 28, 2011 20:59

Posta l'output di questi due comandi:
Codice: Seleziona tutto
ldd /usr/bin/alsamixer
grep 'bin/alsamixer' /var/log/packages/*
sembra che alsamixer dipenda da una libreria che però non esiste su Slackware.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6176
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Assenza di suono.

Messaggioda gohanz » lun ago 29, 2011 11:03

Ma che stai usando Pulseaudio? Quella libreria che ti manca fa parte del pacchetto alsa-plugins ed è usato proprio da Pulseaudio. Nel caso hai due soluzioni: Primo rimuovere Pulseaudio e riavviare Alsa. Secondo installare il pacchetto alsa-plugins.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Assenza di suono.

Messaggioda nonnogs » lun ago 29, 2011 16:20

@ Spina -- questi sono gli output :
Codice: Seleziona tutto
root@myhost:~# ldd /usr/bin/alsamixer
        linux-gate.so.1 =>  (0xffffe000)
        libformw.so.5 => /usr/lib/libformw.so.5 (0xb784a000)
        libmenuw.so.5 => /usr/lib/libmenuw.so.5 (0xb7843000)
        libpanelw.so.5 => /usr/lib/libpanelw.so.5 (0xb7840000)
        libncursesw.so.5 => /lib/libncursesw.so.5 (0xb77f2000)
        libasound.so.2 => /usr/lib/libasound.so.2 (0xb7724000)
        libm.so.6 => /lib/libm.so.6 (0xb76fe000)
        libdl.so.2 => /lib/libdl.so.2 (0xb76fa000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb76e1000)
        libc.so.6 => /lib/libc.so.6 (0xb757e000)
        librt.so.1 => /lib/librt.so.1 (0xb7574000)
        /lib/ld-linux.so.2 (0xb7880000)
root@myhost:~# grep 'bin/alsamixer' /var/log/packages/*
/var/log/packages/alsa-utils-1.0.24.2-i486-1:usr/bin/alsamixer


@ gohanz - sembra che pulseaudio,anche se ce l'ho tra i download (per la verità) non sia installato.Ho cercato di rimuoverlo con questo risultato :
Codice: Seleziona tutto
root@myhost:~# slackpkg remove pulseaudio-0.9.23-i486-5sl.txz
Looking for pulseaudio-0.9.23-i486-5sl.txz in package list. Please wait... DONE
The file(s) pulseaudio-0.9.23-i486-5sl.txz can't be removed - package not installed.

Per quanto riguarda alsa-plugins :
Codice: Seleziona tutto
Executing install script for alsa-plugins-1.0.24-i486-1sl.txz.
Package alsa-plugins-1.0.24-i486-1sl.txz installed.


Grazie.
nonnogs
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: gio giu 30, 2011 20:09
Nome Cognome: giorgio scubla
Slackware: 13.37 DVD
Kernel: 2.6.37-r?

Re: Assenza di suono.

Messaggioda gohanz » lun ago 29, 2011 20:02

Controlla il contenuto di /etc/asound.conf non vorrei che fosse rimasta l'impostazione che obbliga alsa ad usare pulseaudio.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Assenza di suono.

Messaggioda nonnogs » lun ago 29, 2011 20:16

Per quanto posso capirci mi sembra che ci siano pochi dubbi :
Codice: Seleziona tutto
ppcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}
nonnogs
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: gio giu 30, 2011 20:09
Nome Cognome: giorgio scubla
Slackware: 13.37 DVD
Kernel: 2.6.37-r?

Re: Assenza di suono.

Messaggioda targzeta » lun ago 29, 2011 20:19

Prova a spostare quel file (ad esempio, rinominalo come .old) e poi prova.

Offtopic: Quando posti l'output di comandi o pezzi di codice, usa i tag code. I tuoi messaggi precedenti li ho corretti io. Se non sai come fare, chiedi pure.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6176
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Assenza di suono.

Messaggioda nonnogs » lun ago 29, 2011 20:37

1) Come si fa?

2) Come si fa a rinominare il file?
nonnogs
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: gio giu 30, 2011 20:09
Nome Cognome: giorgio scubla
Slackware: 13.37 DVD
Kernel: 2.6.37-r?

Re: Assenza di suono.

Messaggioda targzeta » lun ago 29, 2011 20:48

nonnogs ha scritto:1) Come si fa?
Quando vai all'editor dei messaggi, giusto sopra alla textbox in cui scrivi noti che ci sono dei pulsanti, il primo è 'B', poi 'i', etc... Devi usare quello che si chiama 'Code'.

nonnogs ha scritto:2) Come si fa a rinominare il file?
Da root:
Codice: Seleziona tutto
mv /etc/asound.conf /etc/asound.conf.old
poi, se vuoi ripristinarlo fai il contrario.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6176
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Assenza di suono.

Messaggioda nonnogs » mar ago 30, 2011 16:20

Adesso /etc/asound.conf è completamente vuoto e alsamixer funziona.

Grazie.
nonnogs
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: gio giu 30, 2011 20:09
Nome Cognome: giorgio scubla
Slackware: 13.37 DVD
Kernel: 2.6.37-r?

RISOLTO-Re: Assenza di suono.

Messaggioda sgonnon » mer ago 31, 2011 15:14

Penso che abbiate letto il post nel topic " slackware non aggiornata) e quindi presumo che sappiate già che ho dato startx come utente normale e mi sono trovato la slackware da sistemare ma con il sound attivo.Se ho fatto confusione me ne scuso e vi ringrazio per l'assistenza datami per la risoluzione del problema.Vi saluto giorgio scubla.
sgonnon
Linux 1.0
Linux 1.0
 
Messaggi: 25
Iscritto il: mar ago 30, 2011 20:28
Nome Cognome: scubla giorgio
Slackware: 13.37
Kernel: 2.6.37-6
Desktop: Samsung


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti