Repository 32bit  Forum
Repository 64bit  Wiki

Slackware non aggiornata (credo).

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Slackware non aggiornata (credo).

Messaggioda nonnogs » dom ago 28, 2011 20:52

Eseguo gli aggiornamenti diciamo con regolarità,tuttavia mi sono sorti dei dubbi : possibile che slackware 13.37 monti ancora Firefox 3.6.20 e KDE 4.5.5? Questi sono i miei dubbi ed avrei piacere che mi venissero chiariti.Grazie.
nonnogs
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: gio giu 30, 2011 20:09
Nome Cognome: giorgio scubla
Slackware: 13.37 DVD
Kernel: 2.6.37-r?

Re: Slackware non aggiornata (credo).

Messaggioda darkstaring » lun ago 29, 2011 4:56

Umh, dipende dal mirror..
Per esempio quì ftp://ftp.slackware.no/pub/linux/slackw ... LELIST.TXT
Come puoi vedere lì in testing si trova anche mozilla-firefox-7.0b1-i486-1.txt...
Per quanto riguarda Kde l'ultima versione rilasciata da Pat è quella 4.5.5, puoi sostituirla con la 4.7.0
se usi i pacchetti di AlienBob..

Comunque prova a sostituire il mirror in /etc/slackpkg/mirrors con
ftp://ftp.slackware.no/pub/linux/slackw ... e-current/
e dai slackpkg update
è aggiornato molto frequentemente !
darkstaring
Linux 2.4
Linux 2.4
 
Messaggi: 364
Iscritto il: mer ott 13, 2010 12:55
Slackware: Current
Desktop: xfce

Re: Slackware non aggiornata (credo).

Messaggioda 414N » lun ago 29, 2011 8:05

nonnogs ha scritto:possibile che slackware 13.37 monti ancora Firefox 3.6.20 e KDE 4.5.5? Questi sono i miei dubbi ed avrei piacere che mi venissero chiariti.Grazie.

KDE non verrà aggiornato fino alla prossima release di Slackware, a meno che non spuntino fuori gravi falle di sicurezza.
Firefox è stato aggiornato alla 5.0.1, percui è strano che tu abbia ancora il 3.6.20 installato.
Prova ad usare il mirror austriaco, che uso anch'io:
Codice: Seleziona tutto
ftp://ftp.slackware.at/slackware64-13.37/

Quello che ti ho indicato è per slackware64: se usi slackware a 32 bit, ti basta togliere il 64 dall'URL.
Non usare un mirror per slackware current se vuoi rimanere con la 13.37.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Slackware non aggiornata (credo).

Messaggioda nonnogs » lun ago 29, 2011 20:33

Ho cambiato mirror come mi avete suggerito,ho attivato quello che mi ha suggerito 414N ed ho subito dato un update ma la velocità di scarico è talmente alta che non ho potuto capire se firefox era negli aggiornamenti.Però,dopo aver riavviato il sistema ho visto che sono sempre al 3.6.20.Negli slacky repository c'è firefox 4.0.1 e l'ho installato :

bash-4.1# installpkg mozilla-firefox-l10n-it-4.0.1-i686-2sl.txz
Verifying package mozilla-firefox-l10n-it-4.0.1-i686-2sl.txz.
Installing package mozilla-firefox-l10n-it-4.0.1-i686-2sl.txz:
PACKAGE DESCRIPTION:
# Mozilla Firefox (Italian Localization)
#
# Italian language pack for Mozilla Firefox.
# Use this package if you want to run Mozilla Firefox localized
# in your own language.
#
Package mozilla-firefox-l10n-it-4.0.1-i686-2sl.txz installed.

Ho riavviato ma senza risultati : è sempre il 3.6.20. Ora,poichè il 3.6.20 è venuto con aggiornamenti e poichè funziona regolarmente aspetterò che si modifichi con i successivi aggiornamenti.Ho sollevato la questione perchè è anomala.Su Arch e Chakra c'è addirittura firefox 6.0 e anche 6.0.2,su Sabayon il 5.0.quindi quando sarà tempo verrà.Vi ringrazio comunque.

OT. 414N io sono fiorentino ma da 54 anni abito a Frara e Bulagna la conosco abbastanza.
nonnogs
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: gio giu 30, 2011 20:09
Nome Cognome: giorgio scubla
Slackware: 13.37 DVD
Kernel: 2.6.37-r?

Re: Slackware non aggiornata (credo).

Messaggioda 414N » mar ago 30, 2011 8:41

nonnogs ha scritto:Ho cambiato mirror come mi avete suggerito,ho attivato quello che mi ha suggerito 414N ed ho subito dato un update ma la velocità di scarico è talmente alta che non ho potuto capire se firefox era negli aggiornamenti.

Indipendentemente dalla velocità di download durante la fase di update di slackpkg, quando poi passi alla fase di aggiornamento (upgrade-all) hai modo di scegliere i singoli pacchetti da aggiornare, percui mi viene il sospetto che tu finora abbia solo scaricato gli aggiornamenti ma non li abbia mai installati.
nonnogs ha scritto:Però,dopo aver riavviato il sistema ho visto che sono sempre al 3.6.20.Negli slacky repository c'è firefox 4.0.1 e l'ho installato :
Codice: Seleziona tutto
bash-4.1# installpkg mozilla-firefox-l10n-it-4.0.1-i686-2sl.txz
Verifying package mozilla-firefox-l10n-it-4.0.1-i686-2sl.txz.
Installing package mozilla-firefox-l10n-it-4.0.1-i686-2sl.txz:
PACKAGE DESCRIPTION:
# Mozilla Firefox (Italian Localization)
#
# Italian language pack for Mozilla Firefox.
# Use this package if you want to run Mozilla Firefox  localized
# in your own language.
#
Package mozilla-firefox-l10n-it-4.0.1-i686-2sl.txz installed.

Quel pacchetto serve solo ad aggiungere la lingua italiana al pacchetto standard di firefox, percui non te lo aggiornerà. Come altri pacchetti di internazionalizzazione, presenta la sigla l10n (oppure anche i18n) per indicarlo.
Ricordati, inoltre, di installare aggiornamenti di pacchetti già presenti sul sistema tramite upgradepkg, non installpkg. Usando installpkg rischi di creare sovrapposizioni tra due pacchetti (non controlla se un pacchetto esiste già o meno), percui se disinstalli uno vai a disinstallare anche file dell'altro.
nonnogs ha scritto:Ho riavviato ma senza risultati : è sempre il 3.6.20. Ora,poichè il 3.6.20 è venuto con aggiornamenti e poichè funziona regolarmente aspetterò che si modifichi con i successivi aggiornamenti.Ho sollevato la questione perchè è anomala.Su Arch e Chakra c'è addirittura firefox 6.0 e anche 6.0.2,su Sabayon il 5.0.quindi quando sarà tempo verrà.Vi ringrazio comunque.

Riprova con
Codice: Seleziona tutto
slackpkg upgrade-all

come già suggerito.
nonnogs ha scritto:Offtopic: 414N io sono fiorentino ma da 54 anni abito a Frara e Bulagna la conosco abbastanza.

Offtopic: Maial (nel senso del tipico intercalare ferrarese)! Un vicino di bassa :D
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Slackware non aggiornata (credo).

Messaggioda nonnogs » mar ago 30, 2011 15:43

Per dire la verità ho sempre usato upgrade-all.Oggi ho dato un update e mi scaricato un buon numero di aggiornamenti e dopo slackpkg upgrade-all e la risposta è stata la seguente :

root@myhost:~# slackpkg upgrade-all
Checking local integrity... DONE
Looking for packages to upgrade. Please wait... DONE
No packages match the pattern for upgrade. Try:
/usr/sbin/slackpkg install|reinstall

Ciò non mi convince perchè su "slackers.it" dopo avere suggerito l'upgrade-all,precisano

.......che aggiornerà tutti i pacchetti di Slackware, state quindi attenti a deselezionare quei pacchetti che non volete vengano aggiornati.
Al termine di questa procedura slackpkg vi chiederà come trattare i file .new, state attenti ai file che avete modificato e tramite l'opzione diff decidete se potete tranquillamente tenere i vostri (spesso le differenze si limitano a modifiche delle intestazioni dei file). Slackpkg provvederà ad aggiornare i link nella directory /boot.....

C'è qualcosa che mi sfugge e che evidentemente non metto in atto.Ma cosa?!
nonnogs
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: gio giu 30, 2011 20:09
Nome Cognome: giorgio scubla
Slackware: 13.37 DVD
Kernel: 2.6.37-r?

Re: Slackware non aggiornata (credo).

Messaggioda 414N » mar ago 30, 2011 16:09

Prova a vedere col seguente comando quali e quanti pacchetti inerenti firefox hai installati nel sistema:
Codice: Seleziona tutto
ls /var/log/packages/*firefox*

e riportane l'output.
PS: usa i tag code per riportare spezzoni di codice/output di comandi (come ho appena fatto io col comando sopra), altrimenti il tutto diventa poco leggibile.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

RISOLTO-Re: Slackware non aggiornata (credo).

Messaggioda sgonnon » mar ago 30, 2011 20:48

Ma..l !! Guarda che roba :

root@myhost:/home/giorgio# ls /var/log/packages/*firefox*
/var/log/packages/mozilla-firefox-5.0.1-i486-1_slack13.37
/var/log/packages/mozilla-firefox-it-3.6.19-i686-1sl
/var/log/packages/mozilla-firefox-l10n-it-4.0.1-i686-2sl

Scusa l'esclamazione,come si spiega un affare del genere?
Debbo aggiungere una cosa che poi dirò anche nel post del suono.Da sempre,l'ho anche scritto per chiedere lumi,ho due slackware : una alla quale accedo come semplice utente ($) e l'altra da super utente (#).Adesso sono sulla prima che ha anche il suono però firefox è sempre il 3.6.20.Non so se questo possa avere peso,ma questa è la situazione.Mi dispiace se ho fatto confusione.
Ultima modifica di sgonnon il dom set 04, 2011 19:38, modificato 1 volta in totale.
sgonnon
Linux 1.0
Linux 1.0
 
Messaggi: 25
Iscritto il: mar ago 30, 2011 20:28
Nome Cognome: scubla giorgio
Slackware: 13.37
Kernel: 2.6.37-6
Desktop: Samsung

Re: Slackware non aggiornata (credo).

Messaggioda 414N » mar ago 30, 2011 21:10

sgonnon ha scritto:Ma..l !! Guarda che roba :
Codice: Seleziona tutto
root@myhost:/home/giorgio# ls /var/log/packages/*firefox*
/var/log/packages/mozilla-firefox-5.0.1-i486-1_slack13.37
/var/log/packages/mozilla-firefox-it-3.6.19-i686-1sl
/var/log/packages/mozilla-firefox-l10n-it-4.0.1-i686-2sl

Proprio come temevo... Probabilmente hai usato qualche installpkg "a sproposito".
Nulla di grave, comunque. Ti consiglio di rimuovere tutti quei pacchetti tramite un bel
Codice: Seleziona tutto
removepkg /var/log/packages/*firefox*

Puoi farlo anche da pkgtool se preferisci un'interfaccia che ti mostri anche tutti gli altri pacchetti che hai installato nel sistema.
Dopodiché, con un bel
Codice: Seleziona tutto
slackpkg install mozilla-firefox

dovresti scaricare ed installare l'ultima versione di firefox disponibile tra le patch di firefox, ovvero la 5.0.1.
sgonnon ha scritto:Debbo aggiungere una cosa che poi dirò anche nel post del suono.Da sempre,l'ho anche scritto per chiedere lumi,ho due slackware : una alla quale accedo come semplice utente ($) e l'altra da super utente (#).Adesso sono sulla prima che ha anche il suono però firefox è sempre il 3.6.20.Non so se questo possa avere peso,ma questa è la situazione.Mi dispiace se ho fatto confusione.

Come ti era stato già detto in quel thread, non hai installate due Slackware. Linux è un sistema multiutente, nel senso che, in contemporanea, possono coesistere più sessioni utente in parallelo, senza che nessuna intralci l'altra. Anche su Windows hai la possibilità di avere più utenti, anche se la loro presenza in contemporanea è limitata (mi pare dipenda però dalle versioni che usi).
Appena installi Slackware, hai un solo account utente pronto all'uso, ovvero quello di amministratore (root). Da root, però, puoi creare tutti gli utenti più o meno privilegiati che vuoi e questi, una volta creati, possono accedere al sistema sia in locale sia da remoto (tramite ssh, per esempio) in contemporanea.
Questo è valido anche per le sessioni grafiche: nessuno ti impedisce di utilizzare due o più sessioni X alla volta, anche se bisogna fare attenzione a non eseguirle dallo stesso utente, per via di problemi che possono sorgere a livello di configurazione delle applicazioni.
Offtopic: PS: nuovo utente con nome invertito? :D
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Slackware non aggiornata (credo).

Messaggioda sgonnon » mer ago 31, 2011 14:45

Grazie,la tua pazienza è infinita.Ho dovuto invertire l'username e non solo,ho dovuto mettere in moto anche un'altra e-mail (per fortuna avevo il contatto con Yahoo) per avere l'accesso al login.Le altre erano vecchie e strausate.Non ci sono problemi.Se non ti opprimo ti farò sapere l'esito della questione firefox.Devo rispondere a Emanuele sul suono.Grazie ciao.
sgonnon
Linux 1.0
Linux 1.0
 
Messaggi: 25
Iscritto il: mar ago 30, 2011 20:28
Nome Cognome: scubla giorgio
Slackware: 13.37
Kernel: 2.6.37-6
Desktop: Samsung

RISOLTO-Re: Slackware non aggiornata (credo).

Messaggioda sgonnon » mer ago 31, 2011 15:02

E' installata firefox 5.0.

Ciao.
sgonnon
Linux 1.0
Linux 1.0
 
Messaggi: 25
Iscritto il: mar ago 30, 2011 20:28
Nome Cognome: scubla giorgio
Slackware: 13.37
Kernel: 2.6.37-6
Desktop: Samsung

Re: Slackware non aggiornata (credo).

Messaggioda 414N » mer ago 31, 2011 16:17

Ok. Risolto, quindi?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Slackware non aggiornata (credo).

Messaggioda quasar2011 » dom dic 11, 2011 20:32

scusate ma come aggiorno il file dei repository? vengo da debian e aggiornando il sources.list aggiornavo i repo e qui come funziona? grazie
quasar2011
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: dom dic 04, 2011 14:05
Desktop: lxde
Distribuzione: debian

Re: Slackware non aggiornata (credo).

Messaggioda Vito » dom dic 11, 2011 21:15

attenzione Slackware NON è Debian!
Non c'è un vero e proprio repository da dove scaricare pacchetti extra.
Questa cosa la puoi fare con slapt-get e con repository di terze parti (slacky.eu) ma devi stare MOLTO attento.
In ogni caso i repository li aggiorni con :
Codice: Seleziona tutto
slackpkg update
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4131
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti