Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Headphones & kmix

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Headphones & kmix

Messaggioda Procopio » mar ago 30, 2011 19:19

Salve a tutti!

nel tentativo di configurare l'uscita delle cuffie del mio portatile sony vayo vgn ar41e in maniera che quando infilo il jack delle casse il suono esca solo dalle casse, ho scoperto che devo gestire il tutto da kmix, che però quando provo a far partire da applicazioni>multimedia fa finta di caricare ma poi sparisce tutto..... ho cercato nei repos di skacky.eu se ci fosse il pacchetto per reinstallarlo, ma non l'ho trovato, come posso fare per configurare l'uscita per le casse?

grazie mille a tutti!
Ultima modifica di Procopio il mer set 14, 2011 15:02, modificato 1 volta in totale.
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 589
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.10.5

Re: Headphones & kmix

Messaggioda 414N » mar ago 30, 2011 19:37

kmix non lo puoi trovare su slacky.eu perché fa parte dei pacchetti di KDE presenti nel disco di installazione Slackware, per la precisione del pacchetto kdemultimedia. Lo puoi reinstallare al volo tramite slackpkg (a patto di aver configurato un mirror per la tua versione di slackware):
Codice: Seleziona tutto
slackpkg reinstall kdemultimedia

Il fatto che non parta è sospetto. Prova a lanciarlo da terminale e a controllare eventuali messaggi di errore che fornisce.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Headphones & kmix

Messaggioda Procopio » mer ago 31, 2011 13:08

:roll: mmmm mi puoi spiegare rapidamente il concetto di mirror?

comunque ho reinstallato come mi hai suggerito, e sembrerebbe andato a buon fine (ho fatto sovrascrivere i nuovi file a quelli vecchi), però fa sempre lo stesso scherzetto: mi compare la scheda nel gestore dei processi nel pannello in basso, e dopo qualche secondo di finto caricamento scopmare tutto come se io non avessi neanche cliccato sull'icona di kmix.

Per dare il comando da terminale basta che scrivo kmix? se si mi da questo:
Codice: Seleziona tutto
root@darkstar:~# kmix
root@darkstar:~#
e ovviamente non mi si apre nulla
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 589
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.10.5

Re: Headphones & kmix

Messaggioda 414N » mer ago 31, 2011 13:17

Procopio ha scritto::roll: mmmm mi puoi spiegare rapidamente il concetto di mirror?

Un server mirror è un server "specchio" di un altro server, ovvero una copia esatta dei suoi contenuti. Si usano i mirror per togliere traffico dal server principale e anche per offrirti latenze minori, se trovi un mirror che geograficamente è anche vicino a te.
Nel caso in esame, devi scegliere uno e un solo mirror tra quelli presenti nel file /etc/slackpkg/mirrors e relativi alla versioni di slackware che utilizzi. Io utilizzo quello austriaco, che di solito va anche piuttosto veloce.
Procopio ha scritto:comunque ho reinstallato come mi hai suggerito, e sembrerebbe andato a buon fine (ho fatto sovrascrivere i nuovi file a quelli vecchi), però fa sempre lo stesso scherzetto: mi compare la scheda nel gestore dei processi nel pannello in basso, e dopo qualche secondo di finto caricamento scopmare tutto come se io non avessi neanche cliccato sull'icona di kmix.

Per dare il comando da terminale basta che scrivo kmix? se si mi da questo:
Codice: Seleziona tutto
root@darkstar:~# kmix
root@darkstar:~#
e ovviamente non mi si apre nulla

Vedo che usi root in ambito X... Lo usi dal login oppure fai un cambio utente al volo con su? Nel primo caso, ti consiglio caldamente di crearti un utente non privilegiato e di usare quello per operare normalmente sul pc.
alsamixer ti funziona da terminale?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Headphones & kmix

Messaggioda Procopio » mer ago 31, 2011 13:40

ho reinstallato da poco, ho già creato il mio utente, ma uso root da login più che altro per comodità, hai ragionissima, sono pigro, devo usare l'utente :) solo che configurare l'utente è, per adesso che non ho ancora cofigurato bene la disto, una perdita di tempo ulteriore...:)

alsamixer funziona, le cuffie sono presenti e il volume è regolabile, ma quando le metto non fungono...
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 589
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.10.5

Re: Headphones & kmix

Messaggioda 414N » mer ago 31, 2011 13:59

Procopio ha scritto:solo che configurare l'utente è, per adesso che non ho ancora cofigurato bene la disto, una perdita di tempo ulteriore...:)

Sarà ancora peggio dopo, nel senso che se configuri le normali applicazioni (intendendo con normali le applicazioni che non sono demoni di sistema ecc.) come root, poi tutte le impostazioni rimangono nella home di root (/root), e non nella home del tuo utente normale, col risultato di doverle poi spostare manualmente cambiando permessi/proprietario ecc.
Non so cosa tu debba impostare, ma a me è sempre bastato un terminale root in una sessione utente normale per aggiustare alcune configurazioni di sistema.
Procopio ha scritto:alsamixer funziona, le cuffie sono presenti e il volume è regolabile, ma quando le metto non fungono...

Nel senso che non senti niente dall'uscita cuffie ma gli speaker del portatile funzionano ancora?
Riporta l'output di lspci.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Headphones & kmix

Messaggioda Procopio » mer ago 31, 2011 14:30

414N ha scritto:Nel senso che non senti niente dall'uscita cuffie ma gli speaker del portatile funzionano ancora?
esattamente così :)

eccoti l'output:
Codice: Seleziona tutto
root@darkstar:~# lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8400M GT] (rev a1)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit Ethernet Controller (rev 13)
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
08:03.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
08:03.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
08:03.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/.)
root@darkstar:~#
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 589
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.10.5

Re: Headphones & kmix

Messaggioda Procopio » mar set 06, 2011 15:52

Null'altro qui ragazzi?

ho reinstallato per la seconda volta kdemultimedia ma nulla....il kmix ancora non mi parte, non penso proprio che basterà far partire kmix per avere anche l'output audio a posto, con speaker del portatile che si disattivano quando inserisco il jack delle cuffie e suono solo più in cuffia, ma sarebbe un inizio.....come posso controllare le dipendenze di kmix magari o di kdemultimedia direttamente?
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 589
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.10.5

Re: Headphones & kmix

Messaggioda rik70 » mar set 06, 2011 17:51

Ri-salve a tutti.

Su kmix non mi pronuncio - potrebbe essere un bug o qualcos'altro, ma senza alcun output è difficile avere una qualche idea: prova a vedere se nel file .xsession-errors appare qualcosa che abbia a che fare con kmix o con l'audio di KDE.

Quanto alla scheda audio, mi pare di capire che sia una Intel HDA.

Prova a postare qui gli output di:

Codice: Seleziona tutto
cat /proc/asound/cards


Codice: Seleziona tutto
cat /proc/asound/modules


Se salta fuori il modulo snd_hda_intel, allora si può provare a "passargli" qualche parametro del tipo:
Codice: Seleziona tutto
model=vaio


Ma prima fai sapere che "dicono" i comandi visti sopra.

Bye
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1037
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Headphones & kmix

Messaggioda Procopio » lun set 12, 2011 10:29

ciao! scusa il ritardo, i comandi sopra confermano ciò che sospettavi :)
Codice: Seleziona tutto
matteo@darkstar:~$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfc300000 irq 22
matteo@darkstar:~$ cat /proc/asound/modules
 0 snd_hda_intel
matteo@darkstar:~$

inserisco quella riga nel file /proc/asound/modules?
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 589
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.10.5

Re: Headphones & kmix

Messaggioda waka_jawaka » lun set 12, 2011 12:06

Avatar utente
waka_jawaka
Linux 2.6
Linux 2.6
 
Messaggi: 769
Iscritto il: mar ago 09, 2005 23:00
Nome Cognome: Alberto Palillo
Kernel: 2.6.35
Desktop: KDE 4.5
Distribuzione: Archlinux

Re: Headphones & kmix

Messaggioda Procopio » lun set 12, 2011 14:06

lì dice che ha aggiunto la stringa
Codice: Seleziona tutto
options snd-hda-intel model=vaio enable=1 index=0 position_fix=1
al file "/etc/modprobe.d/alsa-base", io però non ho quel file nè in quella directory ne in un altra, in quella directory non ce n'è uno simile e non saprei dove cercarlo altrove....

ma, oltre a questo, non c'è un modo per verificare quale problema possa incontrare kmix che non fa assulotamente nulla quando provo a farlo partire?
Codice: Seleziona tutto
matteo@darkstar:~$ kmix
matteo@darkstar:~$
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 589
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.10.5

Re: Headphones & kmix

Messaggioda waka_jawaka » lun set 12, 2011 15:24

Procopio ha scritto:lì dice che ha aggiunto la stringa
Codice: Seleziona tutto
options snd-hda-intel model=vaio enable=1 index=0 position_fix=1
al file "/etc/modprobe.d/alsa-base", io però non ho quel file nè in quella directory ne in un altra, in quella directory non ce n'è uno simile e non saprei dove cercarlo altrove....

Prova ad inserirlo in /etc/modprobe.d/sound.conf (come hanno fatto qui: viewtopic.php?p=302293#p298862)
Su kmix non saprei che dirti...hai provato con "ldd /usr/bin/kmix" per vedere se tutte le librerie da cui dipende sono presenti? (anche se, in genere, quando mancano delle librerie i messaggi di errore sulla console spuntano eccome).
Ciao
Avatar utente
waka_jawaka
Linux 2.6
Linux 2.6
 
Messaggi: 769
Iscritto il: mar ago 09, 2005 23:00
Nome Cognome: Alberto Palillo
Kernel: 2.6.35
Desktop: KDE 4.5
Distribuzione: Archlinux

Re: Headphones & kmix

Messaggioda Procopio » lun set 12, 2011 15:48

eh...non ho neanche sound.conf..... ho solo questo in quella directory:

Codice: Seleziona tutto
matteo@darkstar:/etc$ cd modprobe.d/
blacklist.conf       isapnp.conf          modprobe.conf        psmouse.conf         usb-controller.conf
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 589
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.10.5

Re: Headphones & kmix

Messaggioda waka_jawaka » lun set 12, 2011 17:57

Crealo
Codice: Seleziona tutto
touch /etc/modprobe.d/sound.conf

e poi ci copi la stringa.
Ciao
Avatar utente
waka_jawaka
Linux 2.6
Linux 2.6
 
Messaggi: 769
Iscritto il: mar ago 09, 2005 23:00
Nome Cognome: Alberto Palillo
Kernel: 2.6.35
Desktop: KDE 4.5
Distribuzione: Archlinux

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Bing [Bot], Google [Bot] e 1 ospite