Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Headphones & kmix

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Headphones & kmix

Messaggioda rik70 » mar set 13, 2011 18:38

Procopio ha scritto:purtroppo non mi trova già il primo comando:
Codice: Seleziona tutto
matteo@darkstar:~$ sudo rmmod -v snd_hda_intel
sudo: rmmod: command not found


Dallo da utente root, oppure fallo precedere da /sbin/:

Codice: Seleziona tutto
sudo /sbin/rmmod -v snd_hda_intel
sudo /sbin/modprobe -v snd_hda_intel


P.s.

Porta pazienza: siamo quasi alla fine ;)
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1279
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Headphones & kmix

Messaggioda Procopio » mar set 13, 2011 18:53

eh...picche
Codice: Seleziona tutto
matteo@darkstar:~$ sudo /sbin/rmmod -v snd_hda_intel
ERROR: Module snd_hda_intel is in use


grazie mille a te per la pazienza!!!!
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Headphones & kmix

Messaggioda rik70 » mar set 13, 2011 18:58

Uhm....strano, sei loggato su KDE?

Se si, devi uscire, o interrompere il soundserver o il processo che sta usando la scheda audio.

Se puoi fai un login su XFCE e rifai la prova.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1279
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Headphones & kmix

Messaggioda Procopio » mar set 13, 2011 19:13

da xfce4 mi da:
Codice: Seleziona tutto
bash-3.1$ sudo /sbin/rmmod -v snd_hda_intel
Password:
rmmod snd_hda_intel, wait=no
bash-3.1$
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Headphones & kmix

Messaggioda rik70 » mar set 13, 2011 19:17

Procopio ha scritto:da xfce4 mi da:
Codice: Seleziona tutto
bash-3.1$ sudo /sbin/rmmod -v snd_hda_intel
Password:
rmmod snd_hda_intel, wait=no
bash-3.1$


Perfetto!

Adesso dai l'altro [sempre da XFCE]:
sudo /sbin/modprobe -v snd_hda_intel

Posta l'output cosi vediamo se è andato tutto bene, e lancia alsamixer.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1279
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Headphones & kmix

Messaggioda Procopio » mar set 13, 2011 19:26

Codice: Seleziona tutto
bash-3.1$ sudo /sbin/modprobe -v snd_hda_intel                     
Password:
insmod /lib/modules/2.6.29.6-smp/kernel/sound/pci/hda/snd-hda-intel.ko


ho lanciato alsamixer e finalmente parte:)
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Headphones & kmix

Messaggioda rik70 » mar set 13, 2011 19:34

Hey man :thumbright:

Ora sei messo bene!

Sempre da XFCE - lascia stare kde per ora - da alsamixer regolati i volumi. Tira su tutti gli slide - occhio alle orecchie, non esagerare. Col tasto M puoi attivare o disattivare i controlli. Smanetta tutto quello che puoi, metti le cuffie, toglile, collega gli altoparlanti, scollegali....attiva disattiva i controlli (tasto M), etc. Alla fine vedi quello che funziona e ciò che non va.

Poi torni qui e ci fai il resoconto. Nel caso, proviamo a dare una raddrizzata a qual disgraziato di sn_hda_intel :)

In bocca al lupo e fai sapere appena puoi.

Ciao
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1279
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Headphones & kmix

Messaggioda Procopio » mar set 13, 2011 20:11

ok, ho regolato i volumi da alsamixer, le cuffie però non si sentono dinuovo più.... che faccio scommento il file /etc/modprobe.d/sound.conf? e poi posso ripristinare quel file che avevo modificato /etc/asound.conf.BAK?

Grazie mille per la competenza ed il sostegno rik70!!!!:)

purtroppo kmix non ne vuole ancora sapere, ma tanto vedrò se andrà a posto con l'upgrade!:)
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Headphones & kmix

Messaggioda rik70 » mar set 13, 2011 20:50

Eh, l'upgrade è una buona cosa, considerando kernel aggiornati e tutto il resto ... specie se l'hardware fa le bizze.

Prima di scommentare io fossi in te farei altri tentativi al "volo" come abbiamo fatto adesso: perché magari ci dovrai tornare anche dopo l'aggiornamento.

Sempre rimanendo su XFCE, utilizza i 2 comandi che abbiamo visto per fare delle prove:

/sbin/rmmod [] rimuove il modulo (driver) della scheda audio;

/sbin/modprobe [] lo carica.

Puoi dunque fare:

Codice: Seleziona tutto
sudo /sbin/rmmod -v snd_hda_intel


E caricare nuovamente il modulo passandogli dei parametri senza dover riavviare il pc ogni volta:
Codice: Seleziona tutto
sudo /sbin/modprobe -v snd_hda_intel model=vaio


In questo caso abbiamo aggiunto model=vaio, che ti carica il preset per i laptop della sony: come vedi il parametro è uno di quelli che hai messo in /etc/modprobe.d/sound.conf, anche se la sintassi è un pò diversa.

Possiamo passare anche tutti i parametri che hai messo in /etc/modprobe.d/sound.conf:
Codice: Seleziona tutto
sudo /sbin/modprobe -v snd_hda_intel model=vaio index=0 enable=1 position_fix=1


A questo punto sempre da XFCE lanci alsamixer, smanetti di brutto sui controlli e gli switch, e vedi se funziona e cosa cambia.
Io proverei a mettere all'inizio solo model=vaio e poi gli altri nei tentativi successivi.

Puoi provare diverse configurazioni:
per esempio anche 'model=ref' - che sta per reference board o qualcosa del genere - potrebbe andare.

Fai diversi tentativi, finché non becchi quello che funziona.

Ricordati che devi sempre prima rimuovere il modulo (/sbin/rmmod) e poi ricaricarlo (/sbin/modprobe) quando vuoi fare delle modifiche.

Puoi provare anche a ripristinare /etc/asound.conf.BAK e vedere cosa cambia, non credo sia un problema.

Poi fai sapere come va.

Ciao
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1279
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Headphones & kmix

Messaggioda Procopio » mer set 14, 2011 10:39

allora ho fato vari tentativi: l'unico che mi apre alsamixer è quello che avevamo provato ieri: con il file sound.conf commentato e il modulo della scheda audio caricato senza parametri aggiuntivi.

in tutte le altre combinazioni alsamixer mi dà quell'errore che mi aveva dato ieri: (scrivo le combinazioni)
-sound.conf commentato e mod caricato con sudo /sbin/modprobe -v snd_hda_intel model=vaio
-sound.conf commentato e mod caricato con sudo /sbin/modprobe -v snd_hda_intel model=vaio index=0 enable=1 position_fix=1

la cosa curiosa è che se scommento il sound.conf qualsiasi modulo della scheda audio io carichi contiene sempre i parametri del file sound.conf e al massimo se io li metto anche neò comando sudo /sbin/modprobe -v snd_hda_intel lui me li ripete...
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Headphones & kmix

Messaggioda rik70 » mer set 14, 2011 11:02

Procopio ha scritto:la cosa curiosa è che se scommento il sound.conf qualsiasi modulo della scheda audio io carichi contiene sempre i parametri del file sound.conf e al massimo se io li metto anche neò comando sudo /sbin/modprobe -v snd_hda_intel lui me li ripete...


Allora questo è normale: il file /etc/modprobe.d/sound.conf contiene i parametri che vengono passati al modulo del kernel in esso specificato, sia che il modulo venga caricato in automatico al boot "o manualmente" da te.

Questa è la ragione per cui ti dicevo di commentarlo per fare le prove, altrimenti comanda "lui" ;)

Ora la situazione è questa:

alsamixer non si apre se tu passi al modulo snd-hda-intel i parametri che abbiamo visto, sia che lo faccia a mano che tramite /etc/modprobe.d/sound.conf: ho capito bene? Va solo con snd_hda_intel "liscio", cioè senza alcun parametro aggiuntivo.

Questo può significare 2 cose:

1 - quei parametri non vanno bene per il tuo hardware, e occorre trovare quelli giusti altrimenti il mixer sw non funzionerà mai come si deve.

2 - la versione di slackware che utilizzi (la 13.0 mi pare di capire) contiene -forse- un kernel troppo vecchio per il tuo hardware, e quindi i driver non funzionano correttamente.

A questo punto ti consiglio di aggiornare il sistema all'ultima Slackware stable, e poi eventualmente ci si ribecca per sistemare le cose se continui ad avere problemi.

Nel frattempo, prova a postare qui l'output di questi comandi (se esce qualcosa), potrebbe essere utile:
Codice: Seleziona tutto
dmesg | grep -i hda_intel
dmesg | grep -i hda_codec
 


Tieni sempre quel /etc/[***]/sound.conf commentato e riavvia, altrimenti capiamo poco.

Ciao
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1279
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Headphones & kmix

Messaggioda rik70 » mer set 14, 2011 11:41

P.s.

Prova anche con questo:

Codice: Seleziona tutto
sudo /sbin/modprobe -v snd-hda-intel model=vaio enable=1 index=0 position_fix=1 probe_mask=1
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1279
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Headphones & kmix

Messaggioda Procopio » mer set 14, 2011 13:18

rik70 ha scritto:alsamixer non si apre se tu passi al modulo snd-hda-intel i parametri che abbiamo visto, sia che lo faccia a mano che tramite /etc/modprobe.d/sound.conf: ho capito bene? Va solo con snd_hda_intel "liscio", cioè senza alcun parametro aggiuntivo.
esattamente così.

eccoti gli out di quei due dmesg, il primo non ha restituito niente, il secondo questo che vedi qui sotto :)
Codice: Seleziona tutto
matteo@darkstar:~$ dmesg | grep -i hda_intel
matteo@darkstar:~$ dmesg | grep -i hda_codec
hda_codec: Unknown model for ALC262, trying auto-probe from BIOS...
hda_codec: Cannot set up configuration from BIOS.  Using base mode...
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Headphones & kmix

Messaggioda rik70 » mer set 14, 2011 13:26

Procopio ha scritto:
Codice: Seleziona tutto
hda_codec: Unknown model for ALC262, trying auto-probe from BIOS...
hda_codec: Cannot set up configuration from BIOS.  Using base mode...


Ok, probabilmente è quello l'errore, alla prima (e alla seconda) riga: interrogando il bios non riesce a capire il "model" da applicare al codec e ne spara su uno a caso.

Prova il modprobe che ti ho messo sopra, c'è in + il parametro probe_mask=1
/usr/src/linux/Documentation/sound/alsa/HD-Audio.txt lines 97-119/684 ha scritto:On a machine with a broken BIOS, sometimes you need to force the
driver to probe the codec slots the hardware doesn't report for use.


Vai.
Ultima modifica di rik70 il mer set 14, 2011 13:56, modificato 3 volte in totale.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1279
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Headphones & kmix

Messaggioda Procopio » mer set 14, 2011 13:28

sono tornato in fluxbox per provare il tuo ultimo suggerimento (xfce ha preso anche lui a dirmi che non puo disattivare il driver in uso come kde (ma la prima volta era andato...bah))

da qui con il file sound.conf commentato e con questi parametri alsamixer funziona anche se ho solo tre canali...ora torno su kde e provo se vanno speaker e headphones!

oops dimenticavo :D
Codice: Seleziona tutto
bash-3.1$     sudo /sbin/rmmod -v snd_hda_intel
rmmod snd_hda_intel, wait=no
bash-3.1$     sudo /sbin/modprobe -v snd-hda-intel model=vaio enable=1 index=0 position_fix=1 probe_mask=1
insmod /lib/modules/2.6.29.6-smp/kernel/sound/pci/hda/snd-hda-intel.ko model=vaio enable=1 index=0 position_fix=1 probe_mask=1
bash-3.1$ alsamixer

bash-3.1$
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

PrecedenteProssimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti