Repository 32bit  Forum
Repository 64bit  Wiki

Portatile non vede la batteria all'avvio

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Portatile non vede la batteria all'avvio

Messaggioda pino » ven set 23, 2011 14:20

Ho notato che se interrogo con: "cat /proc/acpi/battery/BAT1/state"
all'avvio del portatile con batteria, senza alimentazione, mi risponde che la batteria è assente, ma se mando la macchina in sospensione o collego l'alimentatore allora la batteria viene vista correttamente. Sulla macchina è installato salix 13.37
Qualcuno ha idea del perchè di questa stranezza?
Ciao Pino
pino
Linux 2.4
Linux 2.4
 
Messaggi: 485
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde

Re: Portatile non vede la batteria all'avvio

Messaggioda targzeta » ven set 23, 2011 14:44

Ma che versione del kernel hai? Possibile che esista ancora quel path obsoleto? Hai provato a guardare i file sotto:
Codice: Seleziona tutto
/sys/class/power_supply/BAT?
dove il '?' indica il numero della batteria (che di solito inizia con 0 e non con 1)?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Portatile non vede la batteria all'avvio

Messaggioda pino » ven set 23, 2011 14:54

spina ha scritto:Ma che versione del kernel hai? Possibile che esista ancora quel path obsoleto? Hai provato a guardare i file sotto:
Codice: Seleziona tutto
/sys/class/power_supply/BAT?
dove il '?' indica il numero della batteria (che di solito inizia con 0 e non con 1)?

Emanuele

Sotto quel file c'è un mucchio di roba comprese delle sottodirettori device,power, subsystem.
Il kernel è il 26.37.6 smp
Cosa è " quel path obsoleto"
pino
Linux 2.4
Linux 2.4
 
Messaggi: 485
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde

Re: Portatile non vede la batteria all'avvio

Messaggioda targzeta » ven set 23, 2011 14:59

Tutta la directory /proc/acpid è stata deprecata da un bel po', evidentemente chi ha compilato il kernel ha lasciato quei file. Dovresti provare ad usare i file che ti ho indicato io. Se guardi, il contenuto di ogni file indica una cosa ben specifica della tua batteria.

Dal menù del kernel:
Codice: Seleziona tutto
ACPI (Advanced Configuration and Power Interface) Support
---
Deprecated /proc/acpi files
Deprecated power /proc/acpi directories
Deprecated /proc/acpi/event suppor

Però non so se questo risolve il tuo problema, che tra l'altro non ho ben capito :),
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Portatile non vede la batteria all'avvio

Messaggioda pino » ven set 23, 2011 15:03

Questo è il contenuto della dir
Codice: Seleziona tutto
/sys/class/power_supply/BAT1# ls
alarm        charge_full_design  current_now  device@       model_name  present        status      technology  uevent              voltage_now
charge_full  charge_now          cycle_count  manufacturer  power/      serial_number  subsystem@  type        voltage_min_design

Ma non ho idea di dove mettere le mani
pino
Linux 2.4
Linux 2.4
 
Messaggi: 485
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde

Re: Portatile non vede la batteria all'avvio

Messaggioda targzeta » ven set 23, 2011 15:14

Da utente normale fai:
Codice: Seleziona tutto
cd /sys/class/power_supply/BAT1
e poi fai un cat ai file, tu che vuoi sapere? Ogni domanda trova risposta in ogni file. Proprio come per la directory /proc/acpid. Non c'è poi tanta differenza.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Portatile non vede la batteria all'avvio

Messaggioda pino » ven set 23, 2011 15:24

spina ha scritto:e poi fai un cat ai file, tu che vuoi sapere? Ogni domanda trova risposta in ogni file. Proprio come per la directory /proc/acpid. Non c'è poi tanta differenza.

Si questo lo ho capito, ma altra stranezza che anche le cuffie prendono a funzionare dopo che si esce dal sospendi. E' come se parte dell'ardware non venisse visto finche non si rientra da un sospendi
pino
Linux 2.4
Linux 2.4
 
Messaggi: 485
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde

Re: Portatile non vede la batteria all'avvio

Messaggioda RedSkull92 » sab set 24, 2011 12:18

Io ho un problema simile, la mia batteria viene riconosciuta in modo errato.
Cioè mi vede la batteria sempre connessa all'alimentatore e la carica al 100%
acpitool mi restituisce:
AC adapter : on-line
Thermal info : <not available>
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 554
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox


Torna a Slackware

Chi c’è in linea

Visitano il forum: Bing [Bot], Google [Bot] e 1 ospite