Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto]: Problema con usb VirtualBox

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto]: Problema con usb VirtualBox

Messaggioda james2221 » ven ott 28, 2011 21:18

ciao
ho installato virtualbox senza il benchè minimo problema, esattamente il seguente pacchetto preso da oracle
Codice: Seleziona tutto
VirtualBox-4.1.4-74291-Linux_amd64.run
.
Senza problemi ho virtualizzato Seven senza necessità di installarlo in quanto ho già una directory in una partizione dedicata con seven virtualizzato, da cui attingo con le varie distro linux installate (Arch, Sabayon, Debian).
Attingendo appunto dalla partizione dedicata Seven si apre, posso aprire internet explorer o qualsiasi altro programma installato, riconosce le directory condivise ma non mi riconosce le usb, mi dice
Codice: Seleziona tutto
Devices>Usb devices>no usb devices connected
.
Eppure nella finestra iniziale, quella piccola prima che si apra seven vado su setting>USB e mi ritrovo la voce
Codice: Seleziona tutto
Enable USB Controller
regolarmente spuntata.
Inoltre le guest additions sono installate, altrimenti non vedrebbe le directory condivise.
Qualche mago della virtualizzazione in ascolto?
inoltre ancora, dato che il file che leggo, SevenDebian.vbox è comune alle altre distro, come mai solo Slack mi da 'sto problema?
potrebbe essere una questione di permessi ?
grazie
james
Ultima modifica di james2221 il sab ott 29, 2011 7:30, modificato 1 volta in totale.
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: Problema con usb VirtualBox

Messaggioda miklos » ven ott 28, 2011 22:19

proprio oggi ho avuto lo stesso problema :D
in pratica è dovuto al fatto che slackware di default non monta un filesystem particolare chiamato usb device filesystem che serve a virtualbox per avere accesso ai device usb.

la soluzione è abbastanza semplice

1) aggiungi la seguente riga al file /etc/fstab
Codice: Seleziona tutto
none            /proc/bus/usb             usbdevfs        gid=id_gruppo_virtualbox   0   0


il parametro gid indica il gruppo che avrà permessi di accesso al filesystem io per semplicità mi sono andato a pescare dal file /etc/groups l'id del gruppo che viene creato con virtualbox (di solito è vboxusers).

2) devi assicurarti che l'utente che usi di solito appartenga al gruppo indicato nel punto 1.

fatto questo, io ho riavviato e magicamente i device usb li vedevo all'interno della macchina emulata.
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1240
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: Problema con usb VirtualBox

Messaggioda phobos3576 » ven ott 28, 2011 22:38

Ne approfitto per chiedervi se conoscete qualche tutorial ben fatto per l'installazione e l'uso di VirtualBox sotto Slackware; mi vorrei tuffare nel mondo della virtualizzazione, per cui in questo settore sono proprio alle prime armi.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Problema con usb VirtualBox

Messaggioda Plaoo » ven ott 28, 2011 23:52

phobos3576 ha scritto:Ne approfitto per chiedervi se conoscete qualche tutorial ben fatto per l'installazione e l'uso di VirtualBox sotto Slackware; mi vorrei tuffare nel mondo della virtualizzazione, per cui in questo settore sono proprio alle prime armi.

E' cosi semplice che non c'è bisogno di nessuna guida, fidati è molto intuitivo.
Il canale ufficiale di slacky.eu si trova sui server irc.syrolnet.org canale #slackware
Avatar utente
Plaoo
Linux 2.6
Linux 2.6
 
Messaggi: 809
Iscritto il: gio apr 10, 2008 16:40
Località: Ittiri (SS)
Slackware: 14 64
Kernel: 3.2.9
Desktop: KDE

Re: Problema con usb VirtualBox

Messaggioda phobos3576 » sab ott 29, 2011 1:32

Plaoo ha scritto:E' cosi semplice che non c'è bisogno di nessuna guida, fidati è molto intuitivo.

Leggendo i vari post qui su Slacky non si direbbe :lol:
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Problema con usb VirtualBox

Messaggioda james2221 » sab ott 29, 2011 6:47

@miklos ti voglio trooopo bene!
tutto ok, sistemato fstab e gruppi, ho raggiunto lo scopo della mia vita, ovvero far andare la mia maledetta stampante su Slack: è un anno che ci provo.
Grazie tante
james

@phobos
effettivamente è elementare ma come tutte le cose lo è dopo che lo hai provato, pertanto:
1) scarica dal sito https://www.virtualbox.org/wiki/Linux_Downloads

Codice: Seleziona tutto
All distributions i386 | AMD64

a secondo se hai 32 o 64 bit. E' un file autoinstallante pertanto quando gli clichi sopra (attenzione, devi essere root !) si installa per conto suo.
Già fatto? già fatto !
segui le modifiche a /etc/fstab in questo thread, aggiungiti al gruppo e tutto funge.
Il passo successivo è avere un cd o dvd del SO da virtualizzare, lo inserisci nel lettore e avvii VBox. Da qui in avanti, lo dico con un certo senso di vergogna, è modello windows, ovvero >avanti>avanti>avanti.

adesso devo chiudere, devo uscire con urgenza, se serve qualcosa ho virtualizzato mezzo mondo in questi giorni, chiedi e ti sarà dato
ciao
james
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: [Risolto]: Problema con usb VirtualBox

Messaggioda brainvision » sab ott 29, 2011 10:55

io volevo chiedere, visto che siamo in argomento: ma avete mai provato ad installare un gioco in emulazione su VirtualBox?, un gioco abbastanza recente e bello tosto, intendo.. Come si comporta? Io ho fatto qualche prova e mi è sembrato che VirtualBox non fosse assolutamente adatto ai giochi..

voi avete qualche esperienza al riguardo??

Grazie mille..
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: [Risolto]: Problema con usb VirtualBox

Messaggioda miklos » sab ott 29, 2011 12:32

tempo fa provai un gioco online gratuito chiamato rappelz... requisiti di sistema manco troppo spinti.. purtroppo non c'e' stato verso di farlo andare nè con wine.. nè con virtualbox...
non so se dipende dall'ancora acerbo supporto all'accellerazione 3d(quindi col tempo migliorabile) o dalle solite combinazioni hardware emulato.. hardware fisico :(
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1240
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: [Risolto]: Problema con usb VirtualBox

Messaggioda brainvision » sab ott 29, 2011 19:51

miklos ha scritto:tempo fa provai un gioco online gratuito chiamato rappelz... requisiti di sistema manco troppo spinti.. purtroppo non c'e' stato verso di farlo andare nè con wine.. nè con virtualbox...
non so se dipende dall'ancora acerbo supporto all'accellerazione 3d(quindi col tempo migliorabile) o dalle solite combinazioni hardware emulato.. hardware fisico :(


http://appdb.winehq.org/objectManager.php?sClass=application&iId=4112
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Problema con usb VirtualBox

Messaggioda phobos3576 » sab ott 29, 2011 21:04

james2221 ha scritto:effettivamente è elementare ma come tutte le cose lo è dopo che lo hai provato, pertanto:
1) scarica dal sito https://www.virtualbox.org/wiki/Linux_Downloads

Codice: Seleziona tutto
All distributions i386 | AMD64

a secondo se hai 32 o 64 bit. E' un file autoinstallante pertanto quando gli clichi sopra (attenzione, devi essere root !) si installa per conto suo.
Già fatto? già fatto !
segui le modifiche a /etc/fstab in questo thread, aggiungiti al gruppo e tutto funge.
Il passo successivo è avere un cd o dvd del SO da virtualizzare, lo inserisci nel lettore e avvii VBox. Da qui in avanti, lo dico con un certo senso di vergogna, è modello windows, ovvero >avanti>avanti>avanti.

Grazie mille.

Io vorrei usare WinXP virtualizzato anche per aggiornare il mio TomTom; quei disgraziati usano Linux (OpenTom) su tutti i loro navigatori ma si rifiutano di rilasciare il programma di interfaccia TomTom HOME per il Pinguino. Ai numerosi messaggi di protesta hanno risposto di usare Wine, ma purtroppo questo metodo non funziona (Wine ha gravi carenze con il supporto USB).

Sapete se con XP da VirtuaBox ci sono problemi simili con i navigatori?

EDIT: Ho appena aggiornato il navigatore. Funziona alla perfezione!
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: [Risolto]: Problema con usb VirtualBox

Messaggioda pino » lun ott 31, 2011 18:10

miklos ha scritto:la soluzione è abbastanza semplice1) aggiungi la seguente riga al file /etc/fstabCodice: Seleziona tuttonone            /proc/bus/usb             usbdevfs        gid=id_gruppo_virtualbox   0   0


Ho applicato quanto sopra, ma pur avendo messo il mio utente nel gruppo vboxusers, mi funziona solo da root
Perchè?
Ciao pino
pino
Linux 2.4
Linux 2.4
 
Messaggi: 485
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde

Re: [Risolto]: Problema con usb VirtualBox

Messaggioda phobos3576 » mer nov 02, 2011 0:19

pino ha scritto:
miklos ha scritto:la soluzione è abbastanza semplice1) aggiungi la seguente riga al file /etc/fstabCodice: Seleziona tuttonone            /proc/bus/usb             usbdevfs        gid=id_gruppo_virtualbox   0   0


Ho applicato quanto sopra, ma pur avendo messo il mio utente nel gruppo vboxusers, mi funziona solo da root
Perchè?
Ciao pino

Dalle verifiche che ho fatto io, pare che quella riga non sia necessaria in /etc/fstab (o forse serviva per il vecchio standard USB 1.x).
Ho provveduto semplicemente ad installare (da root) l'estensione "Oracle_VM_VirtualBox_Extension_Pack-4.1.4-74291.vbox-extpack" e le periferiche USB 2.x funzionano perfettamente anche per gli utenti normali.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: [Risolto]: Problema con usb VirtualBox

Messaggioda pino » mer nov 02, 2011 18:36

phobos3576 ha scritto:Dalle verifiche che ho fatto io, pare che quella riga non sia necessaria in /etc/fstab (o forse serviva per il vecchio standard USB 1.x).Ho provveduto semplicemente ad installare (da root) l'estensione "Oracle_VM_VirtualBox_Extension_Pack-4.1.4-74291.vbox-extpack" e le periferiche USB 2.x funzionano perfettamente anche per gli utenti normali.

Il problema che usando slackware 12,1 l'unica volta che ho provato ad installare la vd 4x mi ha dato problemi quindi sono tornato alla 3x che funziona bene.
La stranezza che con la riga in fstab da root la porta usb funziona benissimo, non capisco perchè aggiungendo l'utente al gruppo vboxusers non debba funzionare con l'utente
pino
Linux 2.4
Linux 2.4
 
Messaggi: 485
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde


Torna a Slackware

Chi c’è in linea

Visitano il forum: TurnitinBot [Bot] e 4 ospiti