Repository 32bit  Forum
Repository 64bit  Wiki

Current 11.11.11 Problemi con glibc

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Current 11.11.11 Problemi con glibc

Messaggioda Bart » dom nov 13, 2011 11:29

Per chi è in current segnalo alcune anomalie dovute all'ultimo aggiornamento di glibc. Viene riportata anche la patch per risolvere il problema.

http://www.linuxquestions.org/questions ... em-913135/
Bart
Staff
Staff
 
Messaggi: 4248
Iscritto il: dom ago 08, 2004 23:00
Località: Rimini

Re: Current 11.11.11 Problemi con glibc

Messaggioda targzeta » dom nov 13, 2011 11:46

Sì, avevo notato anche io qualcosa che non andava. MPlayer mi crasha come descritto nel link che hai postato. Ero combattuto se tornare sui miei passi e reinstallare la precedente versione delle glibc. Comunque per ora solo mplayer crasha quindi mi sa che per un po' farò a meno di lui :). Spero che Pat applichi il prima possibile la patch.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6157
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Current 11.11.11 Problemi con glibc

Messaggioda conraid » dom nov 13, 2011 12:22

ho l'impressione che, come anche indicato in quel post (che avevo già letto) , sia un problema a 64bit.
Nella mia current, 32 bit, non ho problemi ne con mplayer ne con libreoffice (uso la versione di alien)
a 64 bit non ho provato quei due programmi, però ieri ho usato il notebook con firefox, chrome e compilando qualcosa, e tutto era ok
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12002
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Current 11.11.11 Problemi con glibc

Messaggioda targzeta » dom nov 13, 2011 12:34

Io ho un sistema puro a 64bit e nessun programma che uso mi ha dato problemi, neanche il compilatore per intenderci. L'unico problema è con mplayer, per questo ho deciso che aspetterò invece di fare un downgrade delle glibc.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6157
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Current 11.11.11 Problemi con glibc

Messaggioda shark1500 » dom nov 13, 2011 18:17

Io su Slackware -current a 32bit non riesco ad utilizzare libreoffice (di alien). Spero che Pat rilasci presto un aggiornamento.
Avatar utente
shark1500
Linux 2.6
Linux 2.6
 
Messaggi: 785
Iscritto il: gio apr 03, 2008 13:33
Località: Modna
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde

Re: Current 11.11.11 Problemi con glibc

Messaggioda shark1500 » dom nov 13, 2011 20:54

Problema risolto con un nuovo aggiornamento.
Avatar utente
shark1500
Linux 2.6
Linux 2.6
 
Messaggi: 785
Iscritto il: gio apr 03, 2008 13:33
Località: Modna
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde

Re: Current 11.11.11 Problemi con glibc

Messaggioda Procopio » dom nov 27, 2011 11:24

mmmh non so quanto sia risolto, io ho slackware-current a 32 bit dal repos di Alien, e lo slackbuild di "lash", un programma per l'audio, mi si blocca qua:
Codice: Seleziona tutto
lash.c:36:21: fatal error: rpc/xdr.h: No such file or directory
compilation terminated.
make[2]: *** [lash.lo] Error 1
make[2]: Leaving directory `/tmp/SBo/lash-0.6.0.594/liblash'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/lash-0.6.0.594'
make: *** [all] Error 2
e pare che sia perchè mi manca il pacchetto glibc-2.13-i486-4.txz....cioè forse dovrei veramente reinstallare il pacchetto vecchio?
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 606
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: Current 11.11.11 Problemi con glibc

Messaggioda conraid » dom nov 27, 2011 12:44

Procopio ha scritto:mmmh non so quanto sia risolto, io ho slackware-current a 32 bit dal repos di Alien, e lo slackbuild di "lash", un programma per l'audio, mi si blocca qua:
Codice: Seleziona tutto
lash.c:36:21: fatal error: rpc/xdr.h: No such file or directory
compilation terminated.
make[2]: *** [lash.lo] Error 1
make[2]: Leaving directory `/tmp/SBo/lash-0.6.0.594/liblash'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/lash-0.6.0.594'
make: *** [all] Error 2
e pare che sia perchè mi manca il pacchetto glibc-2.13-i486-4.txz....cioè forse dovrei veramente reinstallare il pacchetto vecchio?


questo è un problema di glibc 2.14 che ha tolto gli header rpc. Un problema che affligge tutte le distribuzioni, alcune sono rimaste a 2.13 (gentoo mi sembra), altre installano gli header ugualmente (arch per esempio), altre ancora applicano patch.
Slackware non si sa ancora che strada prenderà, forse Pat aspetta che il progetto alternativo libtirpc sistemi alcune cose. Del resto è pur sempre una -current
Segui la discussione su LQ
http://www.linuxquestions.org/questions ... xz-913702/
Ponce ha creato alcuni pacchetti molto utili per questo "problema"
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12002
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite