Pagina 4 di 4

Re: wicd: Nessuna rete wireless trovata

Inviato: ven gen 27, 2012 16:50
da miklos
scusa la domanda banale, ma hai riavviato il picci??!!? mi sono scordato di dirti che questa è una di quelle modifiche che necessitano del riavvio.. sorry :(

Re: wicd: Nessuna rete wireless trovata

Inviato: ven gen 27, 2012 17:35
da DrSlump
Sìsì, ho riavviato!

Re: wicd: Nessuna rete wireless trovata

Inviato: ven gen 27, 2012 17:46
da targzeta
Scusami, ma il tuo router ha bisogno di una chiave oppure no? E se sì, la chiave è WEP o WPA? Fai un cosa, posta l'output del comando:

Codice: Seleziona tutto

iwlist wlan0 s
ovviamente solo rispetto alla tua rete (magari nascondi il nome della rete e il MAC dell'AP se vuoi).

Emanuele

Re: wicd: Nessuna rete wireless trovata

Inviato: ven gen 27, 2012 19:08
da DrSlump
Ops, scusami tu!

Codice: Seleziona tutto

root[leonardo]# iwlist wlan0 s
wlan0     Scan completed :
          Cell 01 - Address: xxxxxxxxxxxxxx
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=56/70  Signal level=-54 dBm 
                    Encryption key:off
                    ESSID:"xxxxxxxxx"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000000075d7e5138
                    Extra: Last beacon: 88ms ago
                    IE: Unknown: 0007776C616E2D6170
                    IE: Unknown: 010482848B96
                    IE: Unknown: 030101
                    IE: Unknown: 2A0104
                    IE: Unknown: 32080C1218243048606C

Re: wicd: Nessuna rete wireless trovata

Inviato: sab gen 28, 2012 9:15
da targzeta
Quindi hai una rete aperta a chiunque. Al solito, svuota il kernel ring (da root 'dmeg -c') e poi prova il comando (da root):

Codice: Seleziona tutto

iwconfig wlan0 essid tuo_essid
dove, tuo essid è il nome della tua rete 'ESSID:"xxxxxxxxx"' (solo le 'xxx' per intenderci). Quando il comando finisce controlla se sei associato, o tramite kernel ring facendo 'dmesg' e osservando se qualche riga ti riporta 'wlan0: associated'. oppure tramite 'iwconfig' stesso se riporta le infomazioni sulla tua rete.

Una volta associato esegui il comando (sempre da root):

Codice: Seleziona tutto

dhcpcd wlan0
e poi postaci l'output.

Il problema potrebbe essere sempre legato al driver brcm80211 che non sa usare bene la tua scheda. Visto che con una rete ad-hoc navighi il problema potrebbe essere lì, anche se è strano che non sappia gestire una scheda in modalità 'Managed', di solito danno problemi nel settare il device come 'Master'.

Emanuele

Re: wicd: Nessuna rete wireless trovata

Inviato: sab gen 28, 2012 12:50
da DrSlump
Spina, ancora ti ringrazio per la tua infinita pazienza.

Codice: Seleziona tutto

root[leonardo]# dhcpcd wlan0
dhcpcd[2775]: version 5.2.12 starting
dhcpcd[2775]: wlan0: broadcasting for a lease
dhcpcd[2775]: wlan0: offered 192.168.1.101 from 192.168.1.254 `router'
dhcpcd[2775]: wlan0: acknowledged 192.168.1.101 from 192.168.1.254 `router'
dhcpcd[2775]: wlan0: checking for 192.168.1.101
dhcpcd[2775]: wlan0: leased 192.168.1.101 for 86400 seconds
dhcpcd[2775]: forked to background, child pid 2810
root[leonardo]#

Re: wicd: Nessuna rete wireless trovata

Inviato: sab gen 28, 2012 16:24
da targzeta
Non ti preoccupare, il problema semmai e che ci colleghiamo in orari differenti e la cosa si porta per le lunghe.

Detto questo, dall'output di dhcpcd sembra proprio che il tuo AP abbia un server dhcp attivo e che hai ottenuto correttamente un IP. Quindi, mi chiedo e ti chiedo, cosa c'è che non va? Dovresti poter navigare a questo punto.

Emanuele

Re: wicd: Nessuna rete wireless trovata

Inviato: sab gen 28, 2012 19:48
da DrSlump
spina ha scritto:Quindi, mi chiedo e ti chiedo, cosa c'è che non va? Dovresti poter navigare a questo punto.


Sì, mi fa navigare, ma ogni volta che accedo devo fare in ordine le seguenti operazioni?

Codice: Seleziona tutto

dmesg -c

Codice: Seleziona tutto

iwconfig wlan0 essid mio_essid

Codice: Seleziona tutto

dhcpcd wlan0


?

Insomma, ogni volta che riavvio il pc, wicd continua a tirarmi fuori il solito errore "impossibile acquisire l'indirizzo IP".
Poi, effettivamente, con la procedura da te consigliata si connette e tutto ok. Ma la devo fare ogni volta che accendo il computer? :oops:

Re: wicd: Nessuna rete wireless trovata

Inviato: dom gen 29, 2012 14:34
da targzeta
No, basta configurare bene la rete. Però qui non ti posso più aiutare perché io uso degli scriptini tutti miei per collegarmi alle varie wireless. Sicuramente chi ci legge ha più esperienza di me in queste cose.

Quello che si può dire, però. è che se con quella procedura (il 'dmesg -c' non serve) tutto funziona bene, allora non è un problema del driver ma più che altro di come usi wicd, forse (però come ti dicevo io wicd non lo conosco). Comunque, detto tra noi, dare due comandini non è che poi costa così tanto.

Magari mettere una chiave WPA all'AP non farebbe male.

Emanuele

Re: wicd: Nessuna rete wireless trovata

Inviato: dom gen 29, 2012 15:21
da DrSlump
D'accordo, grazie.
(per la chiave comunque c'è un motivo se non c'è)


Mi sento comunque soddisfatto e i due comandini non mi pesano affatto :)
Grazie a tutti per l'aiuto!