Pagina 1 di 2

kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 15:56
da Procopio
Salve a tutti!

scrivo qua per un problema con kde che mi si e' presentato oggi quando ho aggiornato la current: alla fine dell'aggiornamento mi ha chiesto se volevo sovrascrivere tutti i files di sistema .new ed io gli ho detto si.
Al riavvio del sistema, (io sono in runlevel 4) per un attimo il pc e' passato in modalita grafica ma quando era ora di mostrarmi il gestore della sessione dove fare il login e' tornato in modalita riga di comando e ho fatto il login cosi.
A quel punto ho dato startx ed e' partito il plymouth ma al momento di arrivare al desktop lo schermo e diventato tutto nero, ma si era spento, tanto che vedevo il puntatore del mouse e potevo muoverlo. ho gia' provato a rimpiazzare i file /etc/kde/kdm/kdmrc e Xsession con i vecchi file, ma nulla.....che posso provare secondo voi?

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 17:31
da erio
sicuro che non hai fatto l'upgrade anche del kernel? se si devi rimettere i driver video.

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 17:39
da Procopio
si l'ho fatto, ma mi crea lo stesso problema anche con gli altri due kernel che uso, quello real time e quello di Con Kolivas... ad ogni modo... io non uso i driver proprietari nvidia, ma i canonical, come faccio a reinstallarli?

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 17:51
da erio
cerca quelli che sono stati compilati con il tuo kernel, cioe' quello che ti da da console, uname -a se trovi il pacchetto lo installi,prima rimuovi i vecchi.

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 18:16
da Procopio
l'ho dato, ma purtroppo non mi da informazioni sul driver, comunque io so che i driver che monto sono i vesa,lo vedo dall'xorg.con, ma non so da dove scraricarli ne come poi installarli, sul forum e su slack for dummies non c'é niente sui driver vesa.....

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 18:43
da Procopio
allora, qui http://search.slackware.eu/cgi-bin/pack ... xz/Austria ho trovato e scaricato i driver vesa, dopo di che li ho provati a installare, ma mi dice che ci sono gia (nota che sono su ubuntu, per poter vedere il forum e ho montato la partizione di slackware in /mnt dopo di che ho fatto un chroot)

Codice: Seleziona tutto

kxstudio@ubuntu:~$ mount /dev/sda7 /mnt
mount: è possibile solo per root
kxstudio@ubuntu:~$ sudo mount /dev/sda7 /mnt
[sudo] password for kxstudio:
kxstudio@ubuntu:~$ sudo chroot /mnt
bash-4.1# ls
bin  boot  dev  etc  fat-c  home  lib  lost+found  media  mnt  opt  proc  root  sbin  srv  sys  tmp  u  usr  var
bash-4.1# cd /mnt/tmp/
bash-4.1# upgradepkg --install-new xf86-video-vesa-2.3.0-i486-3.txz

+==============================================================================
| Skipping package xf86-video-vesa-2.3.0-i486-3 (already installed)
+==============================================================================


bash-4.1#

quindi non 'il driver???

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 18:57
da erio
se hai una nvidia metti su i driver .run loro ti fanno il modulo del kernel e kde viaggia tranquillo, con i vesa,che sono i driver base,non credo che possa farlo partire.ma posso sbagliare...

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 19:00
da Procopio
eh no questo allora e' un problema perche io non posso installare i driver invidia dato che la mia scheda video non li supporta vedi qui viewtopic.php?f=6&t=34920&hilit=driver+vesa#p309712 (tra l'altro avevi partecipato pure te ;))

ma dal momento che comunque al desktop ci arriva e che vedo il puntatore del mouse e lo posso muovere, non puo essere solo un problema di kde?

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 19:13
da erio
se hai un'altro desktop manager prova a entrare in init 3 xwmconfig e lo scegli poi dai startx,credo che il problema sia init 4 per te,cerca di fare il log in normale a init 3,e startx.

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 19:25
da Procopio
ok provo anche quella, intanto adesso stavo cercando di installare i driver nvidia, tra l'altro nell'installazione ho avuto un problemino

Codice: Seleziona tutto

                                                                                                                                                                               
                                                                                                                                                                                       
  The CC version check failed:                                                                                                                                                         
                                                                                                                                                                                       
  /proc/version does not exist.                                                                                                                                                       
                                                                                                                                                                                       
  If you know what you are doing and want to ignore the gcc version check, select "No" to continue installation.  Otherwise, select "Yes" to abort installation, set the CC           
  environment variable to the name of the compiler used to compile your kernel, and restart installation.  Abort now?                                                                 
                                                                                                                                                                                       
                                                                                   Yes           No                                                                                   
            NVIDIA Software Installer for Unix/Linux 


EDIT:
ho risposto di no 'andato avanti, ma poi e fallita l'installazione...

Codice: Seleziona tutto

                                                                                                                                                                       
                                                                                                                                                                                       
  ERROR: Unable to load the kernel module 'nvidia.ko'.  This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources,     
         with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb, nvidiafb, or nouveau is present and prevents the NVIDIA       
         kernel module from obtaining ownership of the NVIDIA graphics device(s), or NVIDIA GPU installed in this system is not supported by this NVIDIA Linux graphics driver         
         release.                                                                                                                                                                     
                                                                                                                                                                                       
         Please see the log entries 'Kernel module load error' and 'Kernel messages' at the end of the file '/var/log/nvidia-installer.log' for more information.                     
                                                                                                                                                                                       
                                                                                          OK                                                                                           
                                                                         
ora provo come suggerisci tu!

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 19:35
da Procopio
purtroppo anche partendo dal runlevel 3 ho lo stesso identico errore allo startx....tu non mi sai suggerire dove possono essere eventuali log dello startx, che magari scopriamo qualcosa?

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 20:57
da roberto67
dopo l'aggiornamento alla -current, è comunque necessario reinstallare i pacchetti della directory 'deps' del kde-4.8, dal momento che vengono sovrascritti. io ho dovuto reinstallare tutto:
-current->driver nvidia->nuove multilib->kde

Ad ogni modo il tuo problema sembrerebbe indirizzare proprio a ciò di cui si sta discutendo..

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 21:29
da Procopio
uuuu ok!grazie mille! allora parto con la reinstallazione, le multilib sono anche loro in "deps"?

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 21:49
da roberto67
Procopio ha scritto:uuuu ok!grazie mille! allora parto con la reinstallazione, le multilib sono anche loro in "deps"?


con 'deps' intendevo la directory apposita del kde4.8 di Alien, ovvero i prerequisiti di kde.
Se hai installato la current e non aggiornato le multilib scoprirai che non ti funzionano i pacchetti a 32b, perchè la current sovrascrive gcc e glibc, ed essendo la current basata su altre versioni, è necessario installare questi pacchetti freschi del buon Alien http://slackware.com/~alien/multilib/ChangeLog.txt

Re: kde4.8 bloccato dalla current

Inviato: ven feb 03, 2012 21:59
da Procopio
roberto67 ha scritto:
Procopio ha scritto:uuuu ok!grazie mille! allora parto con la reinstallazione, le multilib sono anche loro in "deps"?


con 'deps' intendevo la directory apposita del kde4.8 di Alien, ovvero i prerequisiti di kde.

sisi, certo, ho confuso io:)

roberto67 ha scritto:Se hai installato la current e non aggiornato le multilib scoprirai che non ti funzionano i pacchetti a 32b, perchè la current sovrascrive gcc e glibc, ed essendo la current basata su altre versioni, è necessario installare questi pacchetti freschi del buon Alien http://slackware.com/~alien/multilib/ChangeLog.txt
ma io la current l'ho installata con i comandi

Codice: Seleziona tutto

slackpkg update
slackpkg install-new
slackpkg upgrade-all
che fino agli ultimi aggiornamenti della current si occupava lui di aggiornare le glibc e le altre multilib per prime, adesso non e´ piu´ cosi? per installare tutti quei pacchetti cosa devo fare? riconfigurare il mirror e dare dinuovo quei tre comandi?


anche persh'adesso il mio vecchio repos non me lo trova piu

Codice: Seleziona tutto

bash-4.1# slackpkg update

                        Downloading http://taper.alienbase.nl/mirrors/slackware/slackware-current/GPG-KEY...
--2012-02-03 22:04:00--  http://taper.alienbase.nl/mirrors/slackware/slackware-current/GPG-KEY
Risoluzione di taper.alienbase.nl (taper.alienbase.nl)... fallito: Errore temporaneo nella risoluzione del nome.
wget: impossibile risolvere l'indirizzo dell'host "taper.alienbase.nl"
Updating the package lists...
        Downloading...
                        Downloading http://taper.alienbase.nl/mirrors/slackware/slackware-current/ChangeLog.txt...
--2012-02-03 22:04:00--  http://taper.alienbase.nl/mirrors/slackware/slackware-current/ChangeLog.txt
Risoluzione di taper.alienbase.nl (taper.alienbase.nl)... fallito: Errore temporaneo nella risoluzione del nome.
wget: impossibile risolvere l'indirizzo dell'host "taper.alienbase.nl"

Error downloading from http://taper.alienbase.nl/mirrors/slackware/slackware-current/.
Please, check your mirror and try again.

bash-4.1#