Repository 32bit  Forum
Repository 64bit  Wiki

Scheda ethernet NON rilevata.

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Scheda ethernet NON rilevata.

Messaggioda yAri » sab feb 11, 2012 16:03

Salve. Come nei altri argomenti che ho aperto, premetto che sono ancora abbastanza confuso nell'ambiente di slackware quindi chiedo cortesemente di descrivere passo-passo i passaggi da fare :)

Allora il problema è questo. Installando Slackware 13.37 a 32 bit, non avevo connessione. In qualche modo (forse anche molto sporco) sono riuscito ad installare i driver per la scheda di rete wireless una Broadcom Corporation BCM4322. Ho installato wicd e con la connessione wireless non ho problemi. Il problema è che non mi rileva alcuna scheda di rete ethenet per la connessione via cavo. Allora posto qualche output:

ifconfig -a:
Codice: Seleziona tutto
root@casa:~# ifconfig -a
eth1      Link encap:Ethernet  HWaddr 00:21:00:B0:E0:4C 
          inet addr:192.168.1.106  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::221:ff:feb0:e04c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2185 errors:0 dropped:0 overruns:0 frame:134754
          TX packets:1967 errors:23 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2469492 (2.3 Mb)  TX bytes:247619 (241.8 Kb)
          Interrupt:16

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:120 errors:0 dropped:0 overruns:0 frame:0
          TX packets:120 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:9304 (9.0 Kb)  TX bytes:9304 (9.0 Kb)


lspci:
Codice: Seleziona tutto
root@casa:~# lspci 
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 01)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 01)
08:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)


e dmesg | grep eth0:
Codice: Seleziona tutto
root@casa:~# dmesg | grep eth0
[   16.638814] eth0: Broadcom BCM432b 802.11 Hybrid Wireless Controller 5.100.82.112
[   16.652320] udev[1494]: renamed network interface eth0 to eth1


Spero che potete darmi una mano ad attivare questa scheda di rete perchè mi serve veramente. Grazie a tutti in anticipo. ;)
Ultima modifica di yAri il lun feb 13, 2012 18:17, modificato 4 volte in totale.
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Scheda ethernet NON rilevata.

Messaggioda targzeta » sab feb 11, 2012 16:49

Scusa, ma la tua scheda di rete qual'è? Dall'output di lspci sembra che ci sia solo la wireless...mi sto perdendo qualche cosa?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6168
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Scheda ethernet NON rilevata.

Messaggioda yAri » sab feb 11, 2012 17:02

E' proprio questo il problema. Prima che installassi i driver Broadcom BCM 4322 c'èra..
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Scheda ethernet NON rilevata.

Messaggioda targzeta » sab feb 11, 2012 17:08

Ma la scheda wireless l'hai messa tu? Non è che c'è qualche conflitto, no?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6168
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Scheda ethernet NON rilevata.

Messaggioda yAri » sab feb 11, 2012 17:09

No non l'ho messa io, è un netbook HP MINI. Ripeto prima che installassi i driver la riconosceva
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Scheda ethernet NON rilevata.

Messaggioda rik70 » sab feb 11, 2012 17:12

Prova a incollare qui l'output di:
Codice: Seleziona tutto
cat /etc/udev/rules.d/70-persistent-net.rules
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1206
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Scheda ethernet NON rilevata.

Messaggioda yAri » sab feb 11, 2012 18:42

Sono appena tornato e ho acceso il netbook e..................................
qua è tutto apposto non mi spiego in che modo.. prima ho riavviato più volte...
l'output richiesto:
Codice: Seleziona tutto
bash-4.1# cat /etc/udev/rules.d/70-persistent-net.rules
# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x11ab:0x436c (sky2)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:24:81:41:b8:6f", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x14e4:0x432b (wl)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:21:00:b0:e0:4c", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"


lspci:
Codice: Seleziona tutto
bash-4.1# lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 01)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 01)
08:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)
20:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8072 PCI-E Gigabit Ethernet Controller (rev 10)


ifconfig -a:
Codice: Seleziona tutto
bash-4.1# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:24:81:41:B8:6F 
          inet6 addr: fe80::224:81ff:fe41:b86f/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:15 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2464 (2.4 Kb)  TX bytes:2091 (2.0 Kb)
          Interrupt:19

eth1      Link encap:Ethernet  HWaddr 00:21:00:B0:E0:4C 
          inet addr:192.168.1.106  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::221:ff:feb0:e04c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1009 errors:0 dropped:0 overruns:0 frame:87419
          TX packets:838 errors:10 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1175081 (1.1 Mb)  TX bytes:80392 (78.5 Kb)
          Interrupt:16

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0


Non mi spiego in che modo ma ho risolto... Metto il topic come risolto oppure lo cancello proprio?
Grazie comunque per il vostro aiuto.
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: [RISOLTO] Scheda ethernet NON rilevata.

Messaggioda yAri » sab feb 11, 2012 20:09

Ok ho capito. Quando accendo il computer con il cavo ethernet inserito, parte il dhcp e prende l'ip per eth0 e la scheda viene riconosciuta. Se accendo il computer senza il cavo ethernet inserito, non viene riconosciuta ne eth0 ne la scheda. Come si fa a risolvere?
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: [RISOLTO] Scheda ethernet NON rilevata.

Messaggioda zoros » sab feb 11, 2012 21:50

yAri ha scritto:Ok ho capito. Quando accendo il computer con il cavo ethernet inserito, parte il dhcp e prende l'ip per eth0 e la scheda viene riconosciuta. Se accendo il computer senza il cavo ethernet inserito, non viene riconosciuta ne eth0 ne la scheda. Come si fa a risolvere?

io non ho capito, hai scritto: "risolto" :-k ... comunque ci sono alcune cose, secondo me:

probabilmente nello smanettare si sono creati dei devices nel posto sbagliato, quindi conviene rimuovere il persistent-net.rules:
Codice: Seleziona tutto
# rm /etc/udev/rules.d/70-persistent-net.rules

... al riavvio le cose si dovrebbero aggiustare

altra cosa: wicd lavora in background e va in qualche modo in conflitto con lo script che avvia la rete: /etc/rc.d/rc.inet1 ... al riavvio sarà bene impostare la sezione "Wired Network" di wicd con un IP statico ... oppure settarla in modo che non sovrascriva le impostazioni di default ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Scheda ethernet NON rilevata.

Messaggioda targzeta » sab feb 11, 2012 21:52

Io invece non riesco a capire come possa scomparire un device dalla lista elencata da lspci.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6168
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Scheda ethernet NON rilevata.

Messaggioda zoros » sab feb 11, 2012 21:59

spina ha scritto:Io invece non riesco a capire come possa scomparire un device dalla lista elencata da lspci.

Emanuele

anch'io credo sia difficile ... per me nel primo post si è scordato di copiare l'ultima riga :shock:
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Scheda ethernet NON rilevata.

Messaggioda targzeta » sab feb 11, 2012 22:08

zoros ha scritto:
spina ha scritto:Io invece non riesco a capire come possa scomparire un device dalla lista elencata da lspci.

Emanuele

anch'io credo sia difficile ... per me nel primo post si è scordato di copiare l'ultima riga :shock:
Aspettiamo yAri ma non credo, leggendo i primi tre post del thread si evince abbastanza chiaramente che la periferica non viene proprio mostrata dall'output di lspci. Inoltre, hai visto com'è alto l'indirizzo dello slot? '20:00.0'.

Una volta a me è capitato che lspci non mostrasse dei device, però li avevo disabilitati io (sono molto "precisì" per queste cose) da BIOS. Fortunatamente me ne sono ricordato e quando ho detto al BIOS che rivolevo avere i miei device, eccoli comparire anche nell'output di lscpi. Però qui il problema sembra diverso.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6168
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Scheda ethernet NON rilevata.

Messaggioda zoros » sab feb 11, 2012 22:55

è un po' strano il 20.00.0, ma googolando la stringa si trova in giro ... comunque è il conflitto rc.wicd <-> rc.inet1 il problema, si deve decidere per uno o l'altro ... non si può disabilitare rc.inet1 pena il blocco dei servizi di rete (mancherebbe anche localhost), però si può configurare tenendo nulli tutti i campi di /etc/rc.d/rc.inet1.conf, tipo:
Codice: Seleziona tutto
...
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""
...

ed impostare i parametri di rete in wicd ...

può anche essere che con wicd attivo l'eth si blocchi in modo anomalo e irreversibile, tanto da riavviare la macchina ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Scheda ethernet NON rilevata.

Messaggioda yAri » dom feb 12, 2012 11:48

Non credo di essermi dimenticato l'ultima riga .. è cosi l'lspci.
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Scheda ethernet NON rilevata.

Messaggioda targzeta » dom feb 12, 2012 12:46

yAri, hai letto il suggerimento di zoros? Magari è proprio lì l'errore.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6168
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti