Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Problema dualboot Slack-Windows7

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Problema dualboot Slack-Windows7

Messaggioda erio » gio mar 01, 2012 19:22

questo:Il sistema mi restituisce bootmgr is missing, di solito dice che non hai lilo installato o grub o altro, reinstalla lilo e poi editi le opzioni per linux e windows
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1067
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

[RISOLTO] Problema dualboot Slack-Windows7

Messaggioda NevHack » ven mar 02, 2012 10:56

Grazie
il problema era in un punto del lilo.conf c'era un table di troppo..

ricapitolando per fare una sorta di guida..

Installazione dualboot Slackware/Windows7

1° hdd1 con Windows7 /dev/sda
hdd con Slackware /dev/sdb

2° suddividere le partizioni per Slackware lanciando il comando cfdisk /dev/sdb
creare un albero di questo tipo:
/dev/sdb1 Linux Swap
/dev/sdb2 Linux abbastanza grande per il sistema
/dev/sdb3 Linux per la /home grande quanto vi occore ed in base al suo utilizzo
/dev/sdb4 Linux per /tmp

3° seguire la procedura di installazione del DVD fino al punto dove installare lilo, selezionare expert mode
e selezionare la terza opzione, sovrascrivere l'MBR e scegliere la partizione dove installarlo, assegnare la partizione
di Linux, quella di Windows:
sda1 di circa 100mb
sda2 con il sistema
scegliere /dev/sda come insttallazione di LILO, scegliere installa e proseguire l'installazione fino al riavvio.

4° Al riavvio dovrebbe partire LILO e se tutto è andato a buon fine dovrebbe funzionare tutto, se come a me non partiva
windows7 bisogna configurare lilo.conf . Al riavvio scegliere Linux ed arrivare fino alla linea di comando, entrare in /etc
e con un editor di testo aprire il file lilo.conf, la parte riguardante windows dovrebbe essere cosi come suggerito da erio

# Windows bootable partition config begins
other = /dev/sda1 "che è la partizione dov'è il boot di windows"
label = Windows
# table = /dev/sda
"aggiungere un cancelletto o eliminare questa riga a me non faceva partire windows"
salvate e al prossimo riavvio tutto dovrebbe funzionare.
NevHack
Linux 1.0
Linux 1.0
 
Messaggi: 18
Iscritto il: mer feb 22, 2012 1:42
Nome Cognome: Aldo Nevi
Slackware: 13.1

Precedente

Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 3 ospiti