Pagina 3 di 3

Re: UTF-8, non ci riesco!!!

Inviato: sab apr 07, 2012 13:04
da targzeta
Beh, allora non è la più grande che include la più piccola, ma sono i programmi che sanno adeguarsi all'una e all'altra codifica. Oppure ho capito male?

Comunque questi informatici, potevano pensarci prima invece di iniziare a lavorare su alfabeti di 256 lettere (e se non ricordo male alcuni anche con meno)!!!

Emanuele

Re: UTF-8, non ci riesco!!!

Inviato: sab apr 07, 2012 13:31
da rik70
spina ha scritto:Inoltre guardate qui:

Codice: Seleziona tutto

$> ò
bash: $'\303\262': command not found




Uhm...
Ma quell'output te lo da ovunque o solo su icwm?

A me restituisce sempre

Codice: Seleziona tutto

~$ ò
bash: ò: command not found

Re: UTF-8, non ci riesco!!!

Inviato: sab apr 07, 2012 14:00
da targzeta
Ah, pensavo fosse un problema comune. Me lo da su xterm.

Emanuele

Re: UTF-8, non ci riesco!!!

Inviato: sab apr 07, 2012 14:09
da rik70
Qui va bene anche su xterm.

Ma non è che hai qualche settaggio "strano" su bash? O è il font che hai su xterm che non va bene? Provato con monospace?

Vado a tentativi, perché ne so meno di te :)

Re: UTF-8, non ci riesco!!!

Inviato: sab apr 07, 2012 14:32
da targzeta
Sì è la readline della bash, infatti il problema ce l'ho anche sulla console (fuori X, per intenderci). Io la readline la personalizzo solo per i tasti strani o le combinazioni di tasti (alt+qualcosa o ctrl+qualcosa). Comunque anche con /etc/inputrc il problema rimane. Purtroppo non posso provare un kernel di default, il mio lo compilo per il mio PC e non vorrei ci fosse qualche problema a livello di kernel.

Tirando le somme i problemi che ho riscontrato per ora sono 3:
  • settare LANG via ssh sui server in cui condivido un account
  • icewm e i titoli delle finestre che scompaiono
  • readline (o bash) per il problema su citato
Tutti problemi con cui posso convivere, però...
Emanuele

Re: UTF-8, non ci riesco!!!

Inviato: sab apr 07, 2012 15:11
da conraid
spina ha scritto:Beh, allora non è la più grande che include la più piccola, ma sono i programmi che sanno adeguarsi all'una e all'altra codifica. Oppure ho capito male?



Mi spiego. Quel che voglio dire è che i caratteri della codifica iso-8859-1 per esempio li ritrovi in utf8 e così bia. UTF8 contiene le lettere accentate, l'euro, i font cirillici, cinesi, giapponesi, simboli vari, etc... quindi se il programma gestisce utf8 ed il font ha tutti i caratteri vedi ogni cosa (anche se poi è uscito uft-16 perché non era proprio ogni cosa, comunque per capirci) senza "problemi". Se invece mantieni una codifica "limitata", allora altri set di caratteri non li vedi proprio. Che poi ci siano errori tra una codifica e l'altra purtroppo dipende dai vari programmi, perché viene usato un modo diverso di rappresentare lo stesso "carattere".
Mi spiego da cani lo so

p.s.
quell'errore in bash ce l'ho pure io

Codice: Seleziona tutto

$ ò
bash: $'\303\262': command not found

sia in konsole (il terminale di kde) sia su una console normale

Re: UTF-8, non ci riesco!!!

Inviato: dom apr 08, 2012 12:37
da fgcl2k
conraid ha scritto:p.s.
quell'errore in bash ce l'ho pure io

Codice: Seleziona tutto

$ ò
bash: $'\303\262': command not found

sia in konsole (il terminale di kde) sia su una console normale

Non mi pare sia già stato detto nel thread, però \303\262 è la codifica (ottale) in UTF-8 della o accentata. Io ottengo:

Codice: Seleziona tutto

$ ò
bash: ò: command not found

Re: UTF-8, non ci riesco!!!

Inviato: mar apr 10, 2012 23:43
da targzeta
Beh sì, si intuiva che erano i due caratteri che in UTF-8 formano la o accentata. Ma come mai ad alcuni funziona bene e ad altri invece no? Misteri???

Emanuele

Re: UTF-8, non ci riesco!!!

Inviato: mer apr 11, 2012 9:05
da fgcl2k
spina ha scritto:Beh sì, si intuiva che erano i due caratteri che in UTF-8 formano la o accentata. Ma come mai ad alcuni funziona bene e ad altri invece no? Misteri???

Emanuele

E' una vita che cerco di capire i vari misteri di codifiche, impostazioni di sistema, impostazioni del terminale, ecc. e ogni volta che mi sembra di aver capito tutto mi capita qualcosa che dimostra il contrario.
Comunque, in questo caso, mi pare che il terminale funzioni, perché la 'ò' si vede. Forse è bash che non riesce a trattare il carattere e formatta il messaggio in modo strano.

Re: UTF-8, non ci riesco!!!

Inviato: mer apr 11, 2012 10:31
da rik70
spina ha scritto:Ma come mai ad alcuni funziona bene e ad altri invece no? Misteri???


Non sarà perché siete in current?

P.s.

Sto sperimentando il font 'LatArCyrHeb-16'. Su console sembra dare risultati migliori. Provate ad esempio a visualizzare il manuale xorg.conf. Le doppie virgolette si vedono correttamente. In questa frase nella sezione DESCRIPTION:
`man xorg.conf` ha scritto:where <cmdline> is a relative path (with no “..” components)
col font lat9w-16 le virgolette non si vedono - al loro posto appaiono 2 quadrati - stessa cosa con lat1-16. Inoltre quando una riga viene "spezzata" per andare a capo, non appaiono caratteri strani.

PP.SS.
Per la cronaca: unicode_start io non lo faccio partire.

Re: UTF-8, non ci riesco!!!

Inviato: mer apr 11, 2012 11:46
da conraid
unicode_start lo lancio come retaggio del passato forse :-)
in teoria setta il font ed altre cose, ma anche fermandolo da lo stesso. Poi provo a fare il boot senza.
Il font non so. Quel font che dici tu, che poi è il default lanciato da unicode_start a me non mostra il simbolo dell'euro per esempio. E trovo anche io che però sia migliore, tra l'altro lo feci mettere io a Pat come default nel comando unicode_start, quello precedente fu cancellato ed in pratica c'era un errore nel comando stesso. Un font "totale" per la console non l'ho ancora trovato. In un emulatore di terminale le cose sono decisamente diverse.

Re: UTF-8, non ci riesco!!!

Inviato: mer apr 11, 2012 12:02
da rik70
Hai ragione, niente simbolo dell'euro con 'ALTGr+E' su console, non me n'ero accorto sorry.
Dunque non serve nemmeno caricare la keymap it2.

Comunque provalo il boot senza unicode_start, anche se - come dicevi - non risolve il problema con xterm.
conraid ha scritto: tra l'altro lo feci mettere io a Pat come default nel comando unicode_start, quello precedente fu cancellato ed in pratica c'era un errore nel comando stesso.

Uhau, questa non la sapevo. :)

Non vorrei sbagliarmi, ma mi sembra che quel font sia utlizzato anche su Arch.
Vabbè, occorre trovare il giusto compromesso.

Re: UTF-8, non ci riesco!!!

Inviato: sab apr 14, 2012 21:10
da targzeta
Aggiornamento. Ho risolto il problema più rognoso di icewm ed i titoli delle finestre. In pratica, data la mia mania nel minimizzare, compilavo icewm senza il supporto all'internazionalizzazione (i18n) e quindi il tutto era in ascii inglese. Gimp ha ripreso a scrivermi i nomi dei file nei titoli delle finestre mentre non posso ancora controllare FF perché su quel PC non ho la wifi.

Vi aggiorno lunedì, così vi dico anche le effettive opzioni che ho abilitato (o meglio, tolto).

Il mistero della 'ò' in bash invece è molto simpatico, chissà se davvero non dipende dalla current. Ho guardato un po' il man di bash ma non ho trovato nulla che parli di utf8.

Emanuele

Re: UTF-8, non ci riesco!!!

Inviato: dom apr 15, 2012 10:02
da targzeta
Allora, prima avevo settato nello SlackBuild le seguenti direttive:

Codice: Seleziona tutto

--disable-i18n          Disable internationalization
--disable-nls           Disable internationalized message
ora ho ricompilato icewm eliminandole, e funziona tutto bene, anche Firefox.

Emanuele