Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] dvipng vs libgd

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] dvipng vs libgd

Messaggioda roberto67 » mer apr 11, 2012 15:36

Da ieri sto cercando di compilare dvipng su una slackware 13.37 (prerequisito di tex per mediawiki). Ecco cosa ottengo:
Codice: Seleziona tutto
checking for gdImageCreate in -lgd... no
configure: error: cannot find/use libgd
This drawing library can be downloaded at http://www.boutell.com/gd

Naturalmente ho le gd library installate con la slackware 13.37 e su google non ho trovato nulla.

grazie per ogni aiuto
Ultima modifica di roberto67 il gio apr 12, 2012 11:23, modificato 1 volta in totale.
roberto67
Packager
Packager
 
Messaggi: 291
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: dvipng vs libgd

Messaggioda 414N » mer apr 11, 2012 19:26

Forse devi usare una versione aggiornata.
Puoi trovare gli ultimi sorgenti sul sito bitbucket qui,
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2884
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: dvipng vs libgd

Messaggioda roberto67 » mer apr 11, 2012 20:10

414N ha scritto:Forse devi usare una versione aggiornata.
Puoi trovare gli ultimi sorgenti sul sito bitbucket qui,


grazie per la risposta, 414N :-)
mi pare che non ci sia nulla di aggiornato da 5 anni a questa parte. L'ultima versione è antecedente a quella rilasciata con la slackware 13.37..
roberto67
Packager
Packager
 
Messaggi: 291
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: dvipng vs libgd

Messaggioda targzeta » gio apr 12, 2012 6:22

Devi controllare il file di log 'config.log' per capire come mai non trova quella libreria. Se apri quel file e fai una ricerca per libgd dovrei anche vedere che test esegue e perché non la trova.

Emanuele

:edit: ho provato un attimo a scaricare dvipng-1.14 e ad eseguire il configure. All'inizio dava anche a me quel problema, però poi, installando il pacchetto 'l/gd-2.0.35' è "andata". Nel senso che gd me le trova, però ora non mi trova:
Codice: Seleziona tutto
checking for gdImageCreate in -lgd... yes
checking for kpse_set_program_name in -lkpathsea... no
configure: error: cannot find/use libkpathsea
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6200
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: dvipng vs libgd

Messaggioda roberto67 » gio apr 12, 2012 11:22

spina ha scritto:Devi controllare il file di log 'config.log' per capire come mai non trova quella libreria. Se apri quel file e fai una ricerca per libgd dovrei anche vedere che test esegue e perché non la trova.

Emanuele

grazie Emanuele infatti non trovava alcuni prerequisiti di gd che stanno nel gruppo x (ma che ignorante che sono..)

spina ha scritto::edit: ho provato un attimo a scaricare dvipng-1.14 e ad eseguire il configure. All'inizio dava anche a me quel problema, però poi, installando il pacchetto 'l/gd-2.0.35' è "andata". Nel senso che gd me le trova, però ora non mi trova:
Codice: Seleziona tutto
checking for gdImageCreate in -lgd... yes
checking for kpse_set_program_name in -lkpathsea... no
configure: error: cannot find/use libkpathsea


Così mi funziona. Le librerie di tex infatti sono fuori dalle posizioni linkate
Codice: Seleziona tutto
./configure \
        LDFLAGS='-L/usr/share/texmf/lib/' \
        CPPFLAGS='-I/usr/share/texmf/include/'
roberto67
Packager
Packager
 
Messaggi: 291
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite