Pagina 4 di 4

Re: aggiornamento a current (X)

Inviato: gio mag 10, 2012 20:23
da appo
Una qualche informazione per gli utenti ATI.
I driver proprietari per alcune schede, a seguito dell'aggiornamento di X, vanno in "segmentation fault".
Qui una breve discussione: https://www.linuxquestions.org/questions/slackware-14/latest-update-causes-ati-driver-segfault-943527/.
A me accade con una HD5600 su Slackware64.
Per ora sto usando il "driver" radeon, che a parte qualche bizza alla partenza di X mi consente di utilizzare il gestore delle finestre.

EDIT: dimenticavo di aggiungere che personalmente utilizzo la "current".

Re: aggiornamento a current (X)

Inviato: mar mag 15, 2012 12:41
da Roland
appo ha scritto:Una qualche informazione per gli utenti ATI.
I driver proprietari per alcune schede, a seguito dell'aggiornamento di X, vanno in "segmentation fault".
Qui una breve discussione: https://www.linuxquestions.org/questions/slackware-14/latest-update-causes-ati-driver-segfault-943527/.
A me accade con una HD5600 su Slackware64.
Per ora sto usando il "driver" radeon, che a parte qualche bizza alla partenza di X mi consente di utilizzare il gestore delle finestre.

EDIT: dimenticavo di aggiungere che personalmente utilizzo la "current".


Grazie per la dritta!
Come suggerito in quel thread: un (abbastanza) rapido

Codice: Seleziona tutto

slackpkg reinstall x
e driver proprietario nuovamente funzionante :D

Re: aggiornamento a current (X)

Inviato: mar mag 15, 2012 14:42
da appo
Roland <-- stai usando il driver proprietario e lo xorg-server 1.12? Questo è strano, dato che il problema si presenta con questa accoppiata.

Re: aggiornamento a current (X)

Inviato: mer mag 16, 2012 8:24
da Roland
appo ha scritto:Roland <-- stai usando il driver proprietario e lo xorg-server 1.12? Questo è strano, dato che il problema si presenta con questa accoppiata.


Sono su -current 64...
Dopo aver tentato inutilmente, subito dopo l'aggiornamento, la disinstallazione e reinstallazione dei driver (gli ultimi amd-ati versione 12.4), il problema si è risolto quando ho seguito il consiglio di reinstallare x come si dice nel thread postato da te.
Prima dello startx ho dato un rm /etc/X11/xorg.conf e poco dopo kde era nuovamente up and running ;)

Re: aggiornamento a current (X)

Inviato: gio mag 17, 2012 11:32
da appo
Chiaro, quindi non stai usando il driver ATI ma il driver radeon.
Giusto per capire, potresti postare l'output di lsmod?

Re: aggiornamento a current (X)

Inviato: gio mag 17, 2012 15:35
da Roland
appo ha scritto:Chiaro, quindi non stai usando il driver ATI ma il driver radeon.
Giusto per capire, potresti postare l'output di lsmod?


Uhm...in effetti lsmod mi restituisce come caricati sia il modulo radeon che quello fglrx e, inoltre, il catalyst control center va in errore per mancanza dei driver proprietari.
Sembrava troppo semplice... :D
Provo a reisntallare i driver proprietari.

Re: aggiornamento a current (X)

Inviato: gio mag 17, 2012 16:57
da Roland
La normale disinstallazione aveva lasciato qualche file e il modulo continuava a caricarsi anche se non funzionante.
Questo mi ha ingannato, poiché

Codice: Seleziona tutto

lsmod | grep fglrx
me lo restituiva come caricato e ho dato per scontato che radeon non lo fosse.
Perciò ho giusto fatto la prova del nove disinstallando i driver proprietari con

Codice: Seleziona tutto

sh /usr/share/ati/amd-uninstall.sh --force
e reinstallandoli per constatare che non vanno.
Non ci resta che attendere driver aggiornati, credo... ;)

Re: aggiornamento a current (X)

Inviato: gio mag 17, 2012 19:14
da appo
Temo che sia così.
Il supporto sarà introdotto, teoricamente, con la prossima versione che speriamo arrivi presto.

Re: aggiornamento a current (X)

Inviato: ven giu 29, 2012 11:40
da appo
L'ultimo driver rilasciato da ati (12-6 o 8.98) funziona su current64.
Beh, funziona è una parola grossa. X parte, ecco.

Re: aggiornamento a current (X)

Inviato: ven giu 29, 2012 15:43
da IamSOMBER
appo ha scritto:L'ultimo driver rilasciato da ati (12-6 o 8.98) funziona su current64.
Beh, funziona è una parola grossa. X parte, ecco.


A me nemmeno quello :( anzi se avete un consiglio...
Ho una Radeon 6870 e installando gli ultimi 12.6, su un 3.3.8 vanilla, lo schermo resta nero e non va più nulla nemmeno la console con CTRL-Fn.
Finora ho utilizzato il modulo radeon che però manda la ventola al massimo e dopo una mezz'ora é un ottimo deterrente per spegnere tutto.
Con il kernel 3.4.4 nemmeno compilano, in perfetto legacy-style ATI (ora AMD).

Re: aggiornamento a current (X)

Inviato: ven giu 29, 2012 17:34
da appo
Il log di xorg ti da qualche informazione?
Inoltre, che versione di X stai usando?

In effetti è un vero sbattimento questo dei driver ati. "F**k you n****a" e tutto, sono pure d'accordo, ma quella roba funziona (almeno credo).

Re: aggiornamento a current (X)

Inviato: sab giu 30, 2012 10:39
da Trotto@81
appo ha scritto:Il log di xorg ti da qualche informazione?
Inoltre, che versione di X stai usando?

In effetti è un vero sbattimento questo dei driver ati. "F**k you n****a" e tutto, sono pure d'accordo, ma quella roba funziona (almeno credo).

Eccome se funziona!! ;)

Re: aggiornamento a current (X)

Inviato: sab giu 30, 2012 14:35
da IamSOMBER
Aggiornamento!!
Ho installato per provare il kernel di Pat 3.2.21.
Adesso i drivers compilano e sembrano funzionare senza problemi..almeno da dieci minuti a questa parte ;)

In risposta ad Appo ho xorg della current e i log non davano informazioni utili, almeno per quello che ci capivo io...

Re: aggiornamento a current (X)

Inviato: mar lug 17, 2012 15:21
da hashbang
slucky ha scritto:
Se usi driver nvidia legacy (173 o precedenti) puoi dire loro addio.
Non supportano infatti le release più recenti di Xorg.
Se usi i driver più recenti non dovresti avere problemi di sorta.


quindi nelle future releases di Slackware non sarà più possibile utilizzare questi vecchi driver, e come faremo noi che ancora abbiamo vecchie schede nvidia? :roll:

Scusate l'offtopic.
Dopo quasi un anno, i driver nvidia 173.14.35 sono stati rilasciati.
Ora dovrebbero avere il supporto a Xorg 1.11 e quindi dovrebbero poter essere utilizzabili anche su Slackware -current.