Repository 32bit  Forum
Repository 64bit  Wiki

Pendrive

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Pendrive

Messaggioda kireime » mar gen 27, 2004 10:09

Ho installato Slack9.1 e tutto è andato liscio e durante l´installazione ho anche attivato l´hotplug, solo che quando inserisco la mia pendrive sul desktop non compare nulla e non so dove trovare la periferica, il led della pendrive lampeggia e questo mi fa pensare che l´ha riconosciuta. <BR> <BR>Un´altra curiosità, ho un mouse usb che funziona bene solo che se lo disinserisco e poi lo rinserisco non funziona più, <BR>ma il bello delle periferiche usb non è che posso collegarle a mio piacimento anche a sistema avviato? <BR> <BR>Grazie<br>
kireime
Linux 2.0
Linux 2.0
 
Messaggi: 179
Iscritto il: lun gen 26, 2004 0:00

Pendrive

Messaggioda glpiana » mar gen 27, 2004 10:25

come root digita in una console "tail -F /var/log/messages" dopo avere inserito la penna. se hai caricato i moduli che ti servono dovrebbe vederti la chiave come sda (a me sda1). in questo caso monta /dev/sda1 in una directory tipo chessò /mnt/penna-usb con il comando mount /dev/sda1 /mnt/penna-usb. se non dovesse capire di cosa si tratta prova con modprobe usb-storage e rifai tail -F..... <BR>ciao<br>
Avatar utente
glpiana
Linux 2.6
Linux 2.6
 
Messaggi: 636
Iscritto il: lun gen 12, 2004 0:00

Pendrive

Messaggioda manny » mar gen 27, 2004 14:09

<!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE> <BR> 27-01-2004 alle ore 10:09, kireime : <BR>Ho installato Slack9.1 e tutto è andato liscio e durante l´installazione ho anche attivato l´hotplug, solo che quando inserisco la mia pendrive sul desktop non compare nulla e non so dove trovare la periferica, il led della pendrive lampeggia e questo mi fa pensare che l´ha riconosciuta. <BR> <BR></BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>Ciao Kireime, <BR>la chiave usb la devi montare come un dispositivo... <BR> <BR>Creati una direttori in /mnt, io per esempio l´ho chiamata usb_key, modifichi il tuo /etc/fstab aggiungendo una riga come questa: <BR>/dev/sda1 /mnt/usb_key vfat noauto,rw,users (io ho usato vfat perchè utilizzo anche windows) <BR>e per ultimo, per montarla digita da shell: <BR>mount /dev/sda1 ,e invio. <BR> <BR>Naturalmente puoi montarla con un semplice click del mouse da KDE aggiungendo un´icona sul desktop con il link al dispositivo, cioè /dev/sda1. <BR> <BR>ciao, <BR>Manny <BR><BR><BR>[ Questo Messaggio è stato Modificato da: manny il 27-01-2004 17:16 ]<br>
Avatar utente
manny
Linux 2.4
Linux 2.4
 
Messaggi: 277
Iscritto il: mer ott 29, 2003 0:00
Slackware: 13.1 (fisso)
Kernel: 2.6.33.4
Desktop: kde
Distribuzione: Debian 5 (notebook)

Pendrive

Messaggioda kireime » mar gen 27, 2004 15:31

Ho combinato un macello!! <BR> <BR>per far funzionare il touchpad e fare in modo che il mouse usb funzionasse meglio ho cambiato alcune impostazioni al XF86config <BR> <BR>così: <BR> <BR>Section "InputDevice" <BR>Identifier "Mouse2" <BR>Driver "mouse" <BR>Option "Protocol" "PS/2" <BR>Option "Device" "/dev/psaux" <BR>Option "Emulate3Buttons" <BR>Option "Emulate3Timeout" "50" <BR>EndSection <BR> <BR>nella sezione server layout (l´ultima): <BR> <BR>InputDevice "Mouse2" "SendCoreEvents" <BR> <BR>Ma adesso non funziona più niente, in fase di boot non riconosce il mouse e si blocca tutto portandomi su una finestra che però non riesco ad usare <BR> <BR>Cosa ho sbagliato e come faccio a ripristinare il tutto? <BR><br>
kireime
Linux 2.0
Linux 2.0
 
Messaggi: 179
Iscritto il: lun gen 26, 2004 0:00

Pendrive

Messaggioda manny » mar gen 27, 2004 17:28

Sono solo un principiante, quindi potrei sbagliarmi, ma xfree86config non serve solo per il server X e quindi per l´ambiente grafico? Il boot che intendi tu è quello per arrivare alla console di login o l´avvio di KDE/gnome dopo startX? <BR>Se hai modificato solo l´Xfree86config in maniera sbagliata potresti non avviare l´ambiente grafico, quindi digita vi /etc/X11/Xfree86config e correggilo di conseguenza. (prima dai un´occhiata ai comandi basilari di vi, li trovi anche sullo slackware book, mi sembra) <BR>Se invece non arrivi neanche alla console di login (non dipende quindi dall´Xfree86config) prova con il dischetto di avvio (che avrai senz´altro fatto). <BR>Scusa se non sono stato chiaro o se ho detto alcune gastonerie ma mi viene in mente solo questo. <BR>Ciao, <BR>Manny<br>
Avatar utente
manny
Linux 2.4
Linux 2.4
 
Messaggi: 277
Iscritto il: mer ott 29, 2003 0:00
Slackware: 13.1 (fisso)
Kernel: 2.6.33.4
Desktop: kde
Distribuzione: Debian 5 (notebook)

Pendrive

Messaggioda G3N3S1S » mar gen 27, 2004 17:39

il fatto che nn riconosca il mouse al boot nn dipende da X, quindi prova a fare un <BR># mouseconfig <BR>e restartare.. <BR>see ya<br>
G3N3S1S
Linux 2.0
Linux 2.0
 
Messaggi: 109
Iscritto il: ven ott 17, 2003 23:00

Pendrive

Messaggioda kireime » mar gen 27, 2004 17:52

il problema è che si chianta prima. come posso fare per entrare in modalità testuale?<br>
kireime
Linux 2.0
Linux 2.0
 
Messaggi: 179
Iscritto il: lun gen 26, 2004 0:00

Pendrive

Messaggioda kireime » mer gen 28, 2004 9:04

Niente, credo che rinstallerò tutto da capo ma questa volta starò attento a non combinare casini con il mouse. <BR>Anzi qual´è la giusta configurazione per far funzionare sia il mouse (usb con scroll) e il touchpad (ho un fujitsu siemens amilo) ? <BR> <BR>Ciao<br>
kireime
Linux 2.0
Linux 2.0
 
Messaggi: 179
Iscritto il: lun gen 26, 2004 0:00

Pendrive

Messaggioda useless » mer gen 28, 2004 9:48

noooo, niente reinstallazione: LINUX <!-- BBCode Start --><B>NON È</B><!-- BBCode End --> WINDOWS, e non si reinstalla ogni 2 x 3! <BR> <BR>x avviare in modalità testuale basta che aggiungi "init 3" al comando di lilo con cui lanci il kernel (e x chi ha l´avvio testuale "init 4" parte in modalità grafica). questo lo puoi fare al volo, subito dopo che hai selezionato il kernel in lilo, scriviglielo semplicemente dietro. <BR> <BR>quanto al mouse usb: basta avere hotplug e un kernel recente (>= 2.4.22 così su 2 piedi) col supporto usb attivato, ovviamente. aggiungi poi al tuo /etc/X11/XF86Config: <BR> <BR>Option "ZAxisMapping" "4 5" <BR> <BR>nella sezione del mouse e tutto sarà funzionante! x maggiori info cerca vecchi thread su questo forum, che ci sono sicuro! <BR> <BR>se vuoi fare funzionare mouse e touchpad insieme... devi aggiungere una sezione x ogni dispositivo, come hai cercato di fare. inizia a farne funzionare uno che poi ti aiutiamo x l´altro 8-).<br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Pendrive

Messaggioda kireime » mer gen 28, 2004 10:03

Ho trovo <!-- BBCode Start --><A HREF="http://www.abul.org/IMG/txt/amilod7830.XF86Config-4.txt" TARGET="_blank">qui</A><!-- BBCode End --> il giusto settaggio per un Amilo D 7830, può essere utile anche per qualcun´altro. <BR> <BR>Poi però non ho capito quando devo inserire init3. <BR>Ho letto su un altro <!-- BBCode Start --><A HREF="http://www.slacky.it/modules.php?mop=modload&name=Splatt_Forums&file=viewtopic&topic=361&forum=1" TARGET="_blank">thread</A><!-- BBCode End --> che se il mouse non funziona X blocca comunque il boot, se non entro in modalità testuale non potrò mai configurare lilo.<br>
kireime
Linux 2.0
Linux 2.0
 
Messaggi: 179
Iscritto il: lun gen 26, 2004 0:00

Pendrive

Messaggioda kireime » gio gen 29, 2004 10:03

Ok, sono riuscito ad entrare in modalità testo e a settare il mouse, <BR>adesso però mi da questo errore: No screen found <BR>e X non si avvia.<br>
kireime
Linux 2.0
Linux 2.0
 
Messaggi: 179
Iscritto il: lun gen 26, 2004 0:00

Pendrive

Messaggioda cRoW2k » ven gen 30, 2004 9:08

Devi settare il file /etc/X11/XF86Config. O a manina, o tramite xf86config <BR> <BR>Se hai una nVidia, scarica i nuovi driver (ora con pieno supporto per il 2.6).<br>
cRoW2k
Linux 2.4
Linux 2.4
 
Messaggi: 261
Iscritto il: gio nov 20, 2003 0:00
Slackware: -current

Pendrive

Messaggioda kireime » mer feb 04, 2004 15:36

Sono riuscito a risolvere tutti i miei problemini ed adesso tutto sembra funzionare per il meglio, riesco anche da utente a spegnere completamente attraverso il menu di kde e a montare le varie partizioni, però non c´è verso di montare nè il cdrom nè la pen drive come utente. <BR> <BR>Questo è il mio fstab per la parte che mi interessa: <BR> <BR>/dev/cdrom /mnt/cdrom iso9660 noauto,uid=xxx,ro,exec,dev 00 <BR>/dev/sda1 /mnt/pendrive auto noauto,rwx,uid=xxx 00 <BR> <BR>e ho dato chmod 777 a /dev/cdrom /mnt/cdrom /dev/sda1 /mnt/pendrive <BR> <BR>e ho provato anche altre combinazioni nel fstab ma nn c´è verso. <BR> <BR>Come posso fare? come root ci riesco.<br>
kireime
Linux 2.0
Linux 2.0
 
Messaggi: 179
Iscritto il: lun gen 26, 2004 0:00

Pendrive

Messaggioda kireime » ven feb 06, 2004 10:24

Ok tutto risolto, anche i problemi che avevo scritto in altri post. <BR> <BR>Adesso la mia Slack è proprio una favola<br>
kireime
Linux 2.0
Linux 2.0
 
Messaggi: 179
Iscritto il: lun gen 26, 2004 0:00

Pendrive

Messaggioda samiel » ven feb 06, 2004 11:36

Dicci come hai fatto a montare tutto... <BR>Può servire anche a noi!!!! <BR> <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Bing [Bot], Yahoo [Bot] e 1 ospite