Repository 32bit  Forum
Repository 64bit  Wiki

Problemi con ruby 1.9.1

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problemi con ruby 1.9.1

Messaggioda mitia64 » dom set 09, 2012 23:07

Salve a tutti.
Sto provando ad installare su Slackware 13.1 il software flvtool2, ma, ho trovato alcuni problemi durante l'installazione legati al software ruby utilizzato da flvtool2.
Mi e' stato suggerito di installare ruby versione 1.8.1 oppure 1.9.3 (Norman Timmler) ma malgrado abbia installato la versione superiore utilizzando il comando
'upgardepkg --install-new ruby-1.9.3_p0-i486-1_vb.txz'
e come verifica ho eseguito il comando
'ruby -v'
ottenendo
'runy 1.9.3p0 (2011-10-30 revision 33570) [i486-linux]'
non sono riuscito ad installare flvtool2 perche' sembr faccia sempre riferimento alla versione di ruby 1.9.1.
Qualcuno ha esperienza con ruby oppure con flvtool2.
Grazie
mitia64
mitia64
Linux 1.0
Linux 1.0
 
Messaggi: 32
Iscritto il: mar gen 12, 2010 14:32
Slackware: 13.0
Kernel: 2.6.24.5
Desktop: acer5920G

Re: Problemi con ruby 1.9.1

Messaggioda 414N » lun set 10, 2012 7:58

Sei sicuro che il vecchio pacchetto di ruby non sia ancora in giro?
Controlla in /var/log/packages o tramite pkgtool.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Problemi con ruby 1.9.1

Messaggioda lablinux » mar set 11, 2012 16:35

dai un occhiata a rvm https://rvm.io//rvm/install/.
Puoi gestire più interpreti ruby sulla stessa macchiana, mantendo separati gli ambienti.
Puoi avere una gestione a livello di sistema oppure a livello di utente.
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 754
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4


Torna a Slackware

Chi c’è in linea

Visitano il forum: TurnitinBot [Bot] e 4 ospiti