Pagina 1 di 1

Problemi con ruby 1.9.1

Inviato: lun set 10, 2012 0:07
da mitia64
Salve a tutti.
Sto provando ad installare su Slackware 13.1 il software flvtool2, ma, ho trovato alcuni problemi durante l'installazione legati al software ruby utilizzato da flvtool2.
Mi e' stato suggerito di installare ruby versione 1.8.1 oppure 1.9.3 (Norman Timmler) ma malgrado abbia installato la versione superiore utilizzando il comando
'upgardepkg --install-new ruby-1.9.3_p0-i486-1_vb.txz'
e come verifica ho eseguito il comando
'ruby -v'
ottenendo
'runy 1.9.3p0 (2011-10-30 revision 33570) [i486-linux]'
non sono riuscito ad installare flvtool2 perche' sembr faccia sempre riferimento alla versione di ruby 1.9.1.
Qualcuno ha esperienza con ruby oppure con flvtool2.
Grazie
mitia64

Re: Problemi con ruby 1.9.1

Inviato: lun set 10, 2012 8:58
da 414N
Sei sicuro che il vecchio pacchetto di ruby non sia ancora in giro?
Controlla in /var/log/packages o tramite pkgtool.

Re: Problemi con ruby 1.9.1

Inviato: mar set 11, 2012 17:35
da lablinux
dai un occhiata a rvm https://rvm.io//rvm/install/.
Puoi gestire piĆ¹ interpreti ruby sulla stessa macchiana, mantendo separati gli ambienti.
Puoi avere una gestione a livello di sistema oppure a livello di utente.