Repository 32bit  Forum
Repository 64bit  Wiki

Nas server networking Windows Linux

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Nas server networking Windows Linux

Messaggioda guybrush.d » mer gen 23, 2013 1:11

Ciao a tutti,
grazie ai vostri consigli e dopo 11 condensatori sostituiti :D :D :D sono riuscito a mettere su il mio serverino NAS,
che con il recupero/eliminazione di tutti i dischi usb è arrivato alla modica dimensione di 2TB in LVM :D , adesso ho un
piccolo dubbio però:
Io sono costretto sotto rete fastweb, la mia rete è formata da 3 pc che sono:
il server nas in oggetto
un pc linux desktop
ed il portatile della mia ragazza con windows 7
per non espormi al "mondo" ho recuperato un zyxel P-660HN-T1A senza porta WAN, per cui ho montato una vecchia realtek
sul nas per farlo funzionare da gateway,quindi la mia LAN è diventata:

NAS con due schede 1 verso fastweb e 1 verso router zyxel a cui sono collegati il desktop linux ed il portatile.
ho impostato iptables e subito il nas è diventato un gateway, sull'altra scheda ho attivato il dhcp del router che però
ha iniziato a darmi problemi con windows 7 infatti la connessione ad internet va a singhiozzo ed ho sempre quel cavolo
di popup che mi dice che la connessione è assente! Così ho provato ad usare il server dhcp del nas senza successo, così
ho tagliato la testa al toro ed ho impostato tutti gli indirizzi statici riuscendo a configurare persino samba (che presto toglierò in favore di NFS),
solo che comunque la connessione di W7 salta, così ho eliminato il router zyxel e ho collegato un solo pc con il cavo crossato al NAS ma non
riesco assoulatemente neanche ad effettuare un ping tra il nas e la macchina W7, ho disabilitato l'IPV6 e ho creato la regola sul firewall di w7
per bypassare il blocco del ping ma nulla, neanche dal nas riesco a pingare la macchina W7 e nemmeno la macchina Linux, adesso sia i pc che il nas
danno risposta al ping sul proprio indirizzo. Ho sostituito il cavo crossato (ne ho due) ma nulla, per cui arrivati a questo punto ho la seguente configurazione:
NAS 1 scheda collegata a FASTWEB + 1 scheda di rete configurata con ip statico
n°1 pc collegato con cavo cross alla 2a scheda del NAS
impostata con indirizzo statico e con gateway l'ip del nas.

So che è una pappardella ma datemi qualche dritta che sto impazzendo... :(
Avatar utente
guybrush.d
Linux 2.0
Linux 2.0
 
Messaggi: 155
Iscritto il: lun apr 26, 2010 23:04
Località: Varie
Nome Cognome: Diego
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: Xfce 4.10

Re: Nas server networking Windows Linux

Messaggioda rik70 » mer gen 23, 2013 11:06

Perché invece non fai fare il routing - ehm... cioè il dhcp - al Nas, disabilitando quello dello Zyxel? In pratica lo useresti come semplice switch.

Poi metti in ascolto dnsmasq sull'interfaccia LAN del Nas e ti fa tutto, pure da dns.

Io ho fatto una cosa del genere con una wlan0 e eth0: alla fine via iptables si fa il MASQUERADE su wlan0 e tutto quello che è collegato all'interfaccia eth0 va in rete dietro il firewall LInux.

In pratica: PC1 = Gateway + DNS + ROUTER + FIREWALL (+ SAMBA); interfacce di rete: wlan0, eth0.

PC2 = Windows client; interfacce di rete: ethernet.

Cavo: LAN incrociato ("autocostruito" :) ), dato che nel mio caso il pc da collegare al "NAS" è uno solo.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 995
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Nas server networking Windows Linux

Messaggioda guybrush.d » mer gen 23, 2013 13:00

rik70 ha scritto:Perché invece non fai fare il routing - ehm... cioè il dhcp - al Nas, disabilitando quello dello Zyxel? In pratica lo useresti come semplice switch.

Poi metti in ascolto dnsmasq sull'interfaccia LAN del Nas e ti fa tutto, pure da dns.

Io ho fatto una cosa del genere con una wlan0 e eth0: alla fine via iptables si fa il MASQUERADE su wlan0 e tutto quello che è collegato all'interfaccia eth0 va in rete dietro il firewall LInux.

In pratica: PC1 = Gateway + DNS + ROUTER + FIREWALL (+ SAMBA); interfacce di rete: wlan0, eth0.

PC2 = Windows client; interfacce di rete: ethernet.

Cavo: LAN incrociato ("autocostruito" :) ), dato che nel mio caso il pc da collegare al "NAS" è uno solo.

In effetti ho fatto una cosa del genere, senza dhcp sul nas perchè non sono riuscito a farlo funzionare e non ho capito
perchè, ma impostando gli indirizzi fisici, il mio problema consiste nel fatto che avendo il nas con due schede volevo eliminare temporaneamente lo zyxel e far fare tutto al nas, tanto il pc windows si collega una tantum, ma non riesco nemmeno a
fare il ping! Il dhcp del nas rilascia l'indirizzo ma non viene impostato sull'altro pc, per cui ho utilizzato ip statici, ma neanche così mi funziona, non riesco a capire se è un problema di cavo crossato, ne ho due che funzionavano di cui uno nuovo, il ping mi risponde sui rispettivi indirizzi, ma non risponde a quelli della subnet. Se non risolvo riporto tutto sotto dhcp del router e basta, così mi rimane solo il problema che il pc w7 perde una tantum la connessione.
Avatar utente
guybrush.d
Linux 2.0
Linux 2.0
 
Messaggi: 155
Iscritto il: lun apr 26, 2010 23:04
Località: Varie
Nome Cognome: Diego
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: Xfce 4.10

Re: Nas server networking Windows Linux

Messaggioda rik70 » mer gen 23, 2013 17:41

Ooops ... non avevo letto bene il post e mi son messo a fare il maestro - di che poi non lo so :D

Sorry.

Strano che non faccia il ping ... nemmeno da windows sull'ip del gateway?

Problema alla scheda di rete - escludendo i cavi?
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 995
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: R: Nas server networking Windows Linux

Messaggioda guybrush.d » mer gen 23, 2013 22:52

rik70 ha scritto:Ooops ... non avevo letto bene il post e mi son messo a fare il maestro - di che poi non lo so :D

Sorry.

Strano che non faccia il ping ... nemmeno da windows sull'ip del gateway?

Problema alla scheda di rete - escludendo i cavi?

Ciao be no adesso ho ripristinato lo zyxel senza dhcp tutti ip statici e la rete funziona, anche samba e con, ma su win7 la Lan salta una tantum quindi nn so proprio come risolvere!

Inviato dal mio HTC One X con Tapatalk 2
Avatar utente
guybrush.d
Linux 2.0
Linux 2.0
 
Messaggi: 155
Iscritto il: lun apr 26, 2010 23:04
Località: Varie
Nome Cognome: Diego
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: Xfce 4.10

Re: Nas server networking Windows Linux

Messaggioda guybrush.d » gio gen 24, 2013 1:41

Ok ragazzi,
sono ritornato alla configurazione iniziale, per cui:
server nas con due schede di rete una sotto hag fastweb e l'altra collegata allo zyxel
un pc desktop collegato allo zyxel
nas, pc desktop e zyxel configurati con indirizzi statici
samba ed nfs funzionanti
il problema si verifica anche sotto linux ad intervalli la connessione salta, e poi si ripristina da sola
lo zyxel ha il server dhcp disabilitato ed il nas pure, perchè salta?

PS.: Un'altra cosa strana è che se clicco il tasto home di firefox mi esce fuori la pagina dello zyxel che mi dice
che la connessione internet è assente, perchè?
Avatar utente
guybrush.d
Linux 2.0
Linux 2.0
 
Messaggi: 155
Iscritto il: lun apr 26, 2010 23:04
Località: Varie
Nome Cognome: Diego
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: Xfce 4.10

Re: Nas server networking Windows Linux

Messaggioda rik70 » gio gen 24, 2013 9:57

Come l'hai impostato il router Zyxel?

In particolare Indirizzo IP e subnet.

E la scheda LAN?
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 995
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Nas server networking Windows Linux

Messaggioda guybrush.d » gio gen 24, 2013 10:13

rik70 ha scritto:Come l'hai impostato il router Zyxel?

In particolare Indirizzo IP e subnet.

E la scheda LAN?


Ciao, classica configurazione di subnet in classe C,
192.168.125.1 Zyxel
192.168.125.2 Nas
192.168.125.3 PC Desktop
subnet 255.255.255.0

il pc desktop ha come gateway il nas con cui faccio il formarding con IPTables, la scheda LAN? Cioè? Di chi?
Avatar utente
guybrush.d
Linux 2.0
Linux 2.0
 
Messaggi: 155
Iscritto il: lun apr 26, 2010 23:04
Località: Varie
Nome Cognome: Diego
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: Xfce 4.10

Re: Nas server networking Windows Linux

Messaggioda rik70 » gio gen 24, 2013 10:17

Uhm.... forse dico una fesseria, ma:

dato che il gateway è il NAS, 192.168.125.1 dovrebbe essere la scheda LAN, e 192.168.125.2 lo Zyxel.

Giusto? O mi sbaglio?

Poi gli altri PC collegati allo Zyxel prendono gli ip successivi.

P.s.

Per scheda LAN intendo quella del NAS collegata al router Zyxel.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 995
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Nas server networking Windows Linux

Messaggioda guybrush.d » gio gen 24, 2013 15:08

rik70 ha scritto:Uhm.... forse dico una fesseria, ma:

dato che il gateway è il NAS, 192.168.125.1 dovrebbe essere la scheda LAN, e 192.168.125.2 lo Zyxel.

Giusto? O mi sbaglio?

Poi gli altri PC collegati allo Zyxel prendono gli ip successivi.

P.s.

Per scheda LAN intendo quella del NAS collegata al router Zyxel.

Ciao rik,
no è importante l'ordine è solo una convenzione, gli indrizzi riservati sono quelli di broadcast (x.x.x.255), del
device di loopback (127.0.0.1), ed altri che non ricordo! Nell'RFC 1918 si trovano le definizioni, per cui il problema
non è l'indirizzamento...ma che cavolo?
Avatar utente
guybrush.d
Linux 2.0
Linux 2.0
 
Messaggi: 155
Iscritto il: lun apr 26, 2010 23:04
Località: Varie
Nome Cognome: Diego
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: Xfce 4.10

Re: Nas server networking Windows Linux

Messaggioda rik70 » sab gen 26, 2013 10:01

Uh... non la sapevo questa cosa.

Ho sempre penato che se il gateway è sul secondo indirizzo utile, un dispositivo non può prendere l'ip precedente ma solo il successivo. Perdona l'ignoranza e grazie per la spiegazione :)

Rimane la questione irrisolta: dov'è il problema? Iptables?

Strano però: la LAN deve funzionare, a prescindere dalla connessione all'hag di fweb.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 995
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Nas server networking Windows Linux

Messaggioda guybrush.d » sab gen 26, 2013 13:12

rik70 ha scritto:Uh... non la sapevo questa cosa.

Ho sempre penato che se il gateway è sul secondo indirizzo utile, un dispositivo non può prendere l'ip precedente ma solo il successivo. Perdona l'ignoranza e grazie per la spiegazione :)

Rimane la questione irrisolta: dov'è il problema? Iptables?

Strano però: la LAN deve funzionare, a prescindere dalla connessione all'hag di fweb.


Ciao rik, prego figurati credo che alla fine il problema sia proprio iptables l'ho configurato
copiando le chains da un tutorial e forse devo cercare di impostare delle regole più personalizzate,
ora inizio un pò di studio e poi ne riparliamo. Ciao e grazie intanto.
Avatar utente
guybrush.d
Linux 2.0
Linux 2.0
 
Messaggi: 155
Iscritto il: lun apr 26, 2010 23:04
Località: Varie
Nome Cognome: Diego
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: Xfce 4.10

Re: R: Nas server networking Windows Linux

Messaggioda guybrush.d » mar feb 26, 2013 1:35

Ok credo di aver svelato l'arcano sembra che il problema fosse un cavo arrotolato! Una volta sciolto nn ho più i problemi di prima e la connessione é sempre attiva, lo stesso dmesg nn mi mostra più lo sfarfallio ifconfig up e down! Misteri del tcp/ip! :shock:

Inviato dal mio HTC One X con Tapatalk 2
Avatar utente
guybrush.d
Linux 2.0
Linux 2.0
 
Messaggi: 155
Iscritto il: lun apr 26, 2010 23:04
Località: Varie
Nome Cognome: Diego
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: Xfce 4.10


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti