Repository 32bit  Forum
Repository 64bit  Wiki

Adduser e Userdel - Problemi con X?

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Adduser e Userdel - Problemi con X?

Messaggioda MichaelG » ven feb 01, 2013 14:04

Ciao a tutti,
mi è appena capitato un problema.

Versione: Slackware 14.0
Kernel: 3.2.29-smp

Stavo navigando tranquillo, quando ad un certo punto decido di switchare nell'account di mia moglie, anche se avevo libreoffice aperto e il browser aperto, clicco su logout, pensando mi chiudesse tutto in automatico, attendo un attimo non succede nulla, allora chiudo manualmente libreoffice e faccio per autenticarmi su facebook (giusto per darvi un idea del tempo passato), e in quel momento schermo nero e mi va nella shell, quindi ha effettuato il logout. Decido di entrare immediatamente ancora con il mio e digito semplicemente startx.

X si avvia, ma non vedo + il mouse, anche se in realtà c'è perchè se vado sulle icone o sul menù si illuminano, quindi diciamo che è invisibile... Altra cosa, non c'è più la barra del titolo con relativo iconizza, ingrandisci e chiudi. Decido quindi di fare logout e startx dinuovo, niente uguale a prima.
Da root navigo fino a /home/mionome/.config/ e faccio rm -rf xfc4, quindi logout, e ancora startx, imposto desktop di default, ma il problema della barra del titolo e del mouse invisibili persistono.

Decido allora sempre tramite root di salvare la mia home in una directory in /home/miacartellamionome temporanea
quindi faccio userdel mionome, e confermo
quando vado a fare useradd mionome il terminale mi risponde:
Creazione del file della casella di posta: File già esistente

Ho cercato su internet che cavolo è questo file della casella di posta, purtroppo non l'ho capito.
Le mie domande sono:

1) Come elimino questo file della casella di posta che è già esistente?
2)Come mai si è "danneggiata" la configurazione?

Era successo anche nel computer di mio papà, anche a lui ha Slackware, quando me lo disse, gli dissi che non doveva toccare le cose a caso, evidentemente non aveva toccato nulla, probabilmente aveva fatto la mia stessa operazione.
o0o0o0 Powered By Slackware GNU/Linux 0o0o0o
MichaelG
Linux 1.0
Linux 1.0
 
Messaggi: 27
Iscritto il: gio nov 08, 2012 8:12
Località: Varese
Slackware: 14.0
Kernel: 3.2.29
Desktop: XFC4

Re: Adduser e Userdel - Problemi con X?

Messaggioda hashbang » ven feb 01, 2013 14:45

MichaelG ha scritto:1) Come elimino questo file della casella di posta che è già esistente?



hier(7) ha scritto:/var/mail
Users' mailboxes. Replaces /var/spool/mail.

Controlla se esiste un file /var/mail/<tuonomeutente>.

Se sì, eliminalo e riprova.


PS:
rm -rf xfc4
È un errore di battitura per ~/.config/xfce4 o hai scritto proprio così?
Nel caso tu abbia scritto proprio così, allora la tua configurazione non è stata eliminata perché hai sbagliato nome. Ovviamente rm(1) non ti ha avvisato del fatto che non esiste perché hai usato il parametro "-f".

rm(1) ha scritto: -f, --force
ignore nonexistent files and arguments, never prompt
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1835
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Adduser e Userdel - Problemi con X?

Messaggioda MichaelG » ven feb 01, 2013 15:03

Ciao hashbang, ero già nella directory .config quando ho lanciato rm -rf xfc4.

comunque sia, effettivamente sì in /var/mail c'era la directory mionome, ma il problema non era questo, in quanto la directory in /var/mail viene eliminata solo con comando userdel -r mionome, con userdel mionome rimane.

Il problema era che invece di utilizzare Adduser, utilizzavo userAdd (diversamente da quanto ho scritto nel titolo) mentre il comando è Adduser.
Ora tutto è sistemato, anche se, vorrei capire il perché è capitato questo problema semplicemente facendo "logout".

A voi è mai capitato?
o0o0o0 Powered By Slackware GNU/Linux 0o0o0o
MichaelG
Linux 1.0
Linux 1.0
 
Messaggi: 27
Iscritto il: gio nov 08, 2012 8:12
Località: Varese
Slackware: 14.0
Kernel: 3.2.29
Desktop: XFC4

Re: Adduser e Userdel - Problemi con X?

Messaggioda hashbang » ven feb 01, 2013 15:25

MichaelG ha scritto:Ciao hashbang, ero già nella directory .config quando ho lanciato rm -rf xfc4.
Mi sono espresso male. Intendevo dire hai scritto proprio xfc4 o hai sbagliato a scrivere qui? Perchè il nome corretto è xfce4. Quindi se scrivi rm -rf xfc4 non elimini nulla, anche se sembra che tu l'abbia fatto, dato che, con -f, rm(1) non esce mai in errore in caso di file inesistente.

in quanto la directory in /var/mail viene eliminata solo con comando userdel -r mionome, con userdel mionome rimane.
Infatti ti ho scritto di rimuoverlo a mano, perchè leggendo il post, avevo capito che non avevi passato il parametro -r a userdel.

Ora tutto è sistemato, anche se, vorrei capire il perché è capitato questo problema semplicemente facendo "logout".

A voi è mai capitato?
No. Mai capitato. Anche se la mia esperienza conta poco, dato che XFCE non lo uso.
Da una rapida lettura, il fatto che mancassero la barra del titolo ed il mouse mi danno l'impressione che la configurazione di XFCE fosse corrotta a causa di una chiusura non corretta della sessione di X.
Se accade un'altra volta, puoi comunque provare a lanciare a mano il window manager (/usr/bin/xfwm4) dal terminale, dopo che sei entrato nella tua sessione grafica, e leggere l'output.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1835
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Adduser e Userdel - Problemi con X?

Messaggioda MichaelG » ven feb 01, 2013 15:30

Eh si è un errore di battitura hehe, intendevo xfce4 :)

comunque sia non credo che si sia corrotto direttamente xfce4 "della" directory ~/.config/xfce4
perchè in precedenza l'ho eliminata, poi fatto logout e riavviato x, come di consuetudine mi ha avviato la configurazione automatica, quindi avevo una nuova configurazione.
Il fatto che mi lascia perplesso, è che non c'è alcun tipo di controllo sulla chiusura della sessione, in modo da prevenire questi errori.

Boh, comunque se mi ricapita andrò più a fondo del problema :)
o0o0o0 Powered By Slackware GNU/Linux 0o0o0o
MichaelG
Linux 1.0
Linux 1.0
 
Messaggi: 27
Iscritto il: gio nov 08, 2012 8:12
Località: Varese
Slackware: 14.0
Kernel: 3.2.29
Desktop: XFC4

Re: Adduser e Userdel - Problemi con X?

Messaggioda hashbang » ven feb 01, 2013 15:36

MichaelG ha scritto:Il fatto che mi lascia perplesso, è che non c'è alcun tipo di controllo sulla chiusura della sessione, in modo da prevenire questi errori.
Potresti provare ad usare un gestore di sessione come xdm o un login manager come slim, in modo da far gestire la gestione della sessione di X ai software precedentemente citati.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1835
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Adduser e Userdel - Problemi con X?

Messaggioda brainvision » ven feb 01, 2013 20:23

beh non è proprio vero che no c'è nessun controllo sul fine sessione.. anche Xfce ad esempio ha un piccolo tool nelle impostazioni che ti consente cosa avviare in automatico all'avvio e se salvare o meno la sessione quando esegui il logout..

Per tornare al tuo problema all'inizio, io ho eliminato tantissime volte l'utente usato perché facevo delle prove o perché ripartivo da zero eccetera.. sempre usato l'opzione -fr e poi subito dopo adduser e non è mai capitato nulla di strano..
Comunque puoi stare sicuro al 100% che se clicchi su Esci, il computer lancia il logout, non ci sono cacchi!, se tarda un po' ci saranno motivi validi, certo non è consigliabile - imo - aprire un browser e mettersi a navigare, anche solo per fare prove..
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Adduser e Userdel - Problemi con X?

Messaggioda MichaelG » sab feb 02, 2013 14:04

brainvision ha scritto:[..] io ho eliminato tantissime volte l'utente usato [..] sempre usato l'opzione -fr e poi subito dopo adduser e non è mai capitato nulla di strano..


Infatti se rileggi bene ciò che ho scritto utilizzavo il comando useradd, al posto di adduser :)

Adduser è uno shell script che lavora su useradd.

comunque si, sono d'accordo che facendo la procedura di logout non si debba aprire il browser, ma se io ho il browser _già_ aperto e faccio logout dovrebbe chiudermi tutto da solo forzatamente, cosa che non ha fatto e forse per questo l'ha mandato in crisi ^^
o0o0o0 Powered By Slackware GNU/Linux 0o0o0o
MichaelG
Linux 1.0
Linux 1.0
 
Messaggi: 27
Iscritto il: gio nov 08, 2012 8:12
Località: Varese
Slackware: 14.0
Kernel: 3.2.29
Desktop: XFC4


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite