Repository 32bit  Forum
Repository 64bit  Wiki

VLC e libavutil. Versione sbagliata

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

VLC e libavutil. Versione sbagliata

Messaggioda invalid_packet » dom mag 19, 2013 9:25

Da quando ho installato da zero la 14.0 vlc non funzionava.
Sembra che la versione di libavutil non fosse quella che vlc si aspettava di trovare:

Codice: Seleziona tutto
[0x88d7ae8] main libvlc warning: cannot load module `/usr/lib/vlc/plugins/demux/libavformat_plugin.so' (libavutil.so.51: impossibile aprire il file oggetto condiviso: File o directory non esistente)


mentre nel sistema è installata una versione successiva:
Codice: Seleziona tutto
[beppe@ganimede ~]$ ll /usr/lib/libavutil.so*
lrwxrwxrwx 1 root root   22 19.05.2013 09:10 /usr/lib/libavutil.so -> libavutil.so.52.13.100*
lrwxrwxrwx 1 root root   22 19.05.2013 09:10 /usr/lib/libavutil.so.52 -> libavutil.so.52.13.100*
-rwxr-xr-x 1 root root 188K 21.02.2013 12:27 /usr/lib/libavutil.so.52.13.100*


fornita da ffmpeg (1.1.2).

Ho risolto il problema scaricando la tarball di ffmpeg 1.0.7, cioè l'ultima con la avutil a 5.1, e ho compilato solo lo stretto necessario, copiando poi la libreria in /usr/lib...

Qualcuno ha avuto lo stesso problema? Mi sembra strano non trovare post a riguardo, dato che sia vlc che ffmpeg provengono dai repo di slacky.
Avatar utente
invalid_packet
Packager
Packager
 
Messaggi: 15
Iscritto il: gio mag 17, 2012 7:40
Nome Cognome: Giuseppe Manzo
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: kde4

Re: VLC e libavutil. Versione sbagliata

Messaggioda miklos » dom mag 19, 2013 14:56

il problema è 'semplice', sostanzialmente quando sui nostri repo è stato aggiornato ffmpeg non è stato fatto altrettanto per le dipendenze che lo usano non attraverso il binario, ma linkandoci direttamente le librerie fornite (tipo vlc).
di conseguenza vlc evidenzia questo problema all'avvio.
la tua soluzione è funzionale, ma andrebbe comunque ricompilato il pacchetto di vlc (tra l'altro versione piu' recente uscita nel frattempo).
ti chiedo la cortesia appena puoi di inserire il report col problema in modo che venga visto dai packager e messo apposto:D

ciau
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1205
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2

Re: VLC e libavutil. Versione sbagliata

Messaggioda miklos » dom mag 19, 2013 18:47

ho caricato il pacchetto aggiornato di vlc nel repository a 32bit della 14.

ciau
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1205
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2


Torna a Slackware

Chi c’è in linea

Visitano il forum: Exabot [Bot] e 2 ospiti