Repository 32bit  Forum
Repository 64bit  Wiki

14.1: il server X crasha

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: 14.1: il server X crasha

Messaggioda rik70 » mar nov 19, 2013 14:59

E se reinstalli il pacchetto libXxf86vm-*.txz ?

P.s.

Lascia stare il downgrade dei driver ati perché qui il problema è un altro.

PP.SS

Oltre alle librerie del pacchetto visto sopra, sembra che ti manchino anche alcune librerie di kde.

Io proverei così:

configurati slackpkg.

Poi dai:
Codice: Seleziona tutto
slackpkg update

slackpkg reinstall kde x

slackpkg install kde x

slackpkg upgrade-all


Correggi dove sbaglio: non so se quella sequenza sia corretta, ma l'idea è quella di scaricare i pacchetti da un mirror aggiornato e reinstallare, e infine scaricare e installare eventuali aggiornamenti.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1191
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: 14.1: il server X crasha

Messaggioda samiel » mar nov 19, 2013 20:27

Ho già provato a installare il pacchetto, ma come scrivevo sopra
lamenta altre mancanze. Adesso provo a reinstallare,
ma in realtà ho già installato, poi formattato, riscaricata la ISO,
controllato tutto e REinstallato ex novo senza risultati.
comunque in un'altra partizione ho Debian e no va in crash nulla,
anzi ho tutti gli effetti del desktop, per cui il problema
non dipende dai driver o dall'hardware, ma da qualche
specifica impostazione o non so cos'altro di Slack....
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

Re: 14.1: il server X crasha

Messaggioda rik70 » mer nov 20, 2013 9:43

samiel ha scritto:Ho già provato a installare il pacchetto, ma come scrivevo sopra
lamenta altre mancanze.


Appunto, la domanda è: perché ci sono queste mancanze? Tu dici che hai la ISO integra. Ma non è che è un problema del lettore/masterizzatore - la ram del pc è a posto? - per cui "salta" qualcosa? Hai provato a fare un check del dvd d'installazione con dd? Hai detto K3b? Perché non provi a masterizzare anche con growisofs?

Le butto così a 'casaccio' perché non è normale che tu non hai /usr/lib/libXxf86vm.so.1 e devi metterlo a mano o reinstallare il pacchetto. Così come non è normale che poi saltino fuori altre mancanze. Soffermati su queste piuttosto che reinstallare di nuovo da capo.

Io consigliavo proprio per questi motivi la reinstallazione da un mirror aggiornato. Qualcosa va storto questo è sicuro, ma non mi sembra un problema di impostazioni.
Ultima modifica di rik70 il mer nov 20, 2013 13:01, modificato 1 volta in totale.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1191
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: 14.1: il server X crasha

Messaggioda aschenaz » mer nov 20, 2013 10:50

Se non ricordo male, anni fa si era verificato un caso simile e poi s'era appurato che era proprio il masterizzatore ad essere difettoso.
Prova a masterizzare altrove...
pensieriemotivi.aschenaz.eu - music-blog
Avatar utente
aschenaz
Staff
Staff
 
Messaggi: 4423
Iscritto il: mar lug 27, 2004 23:00
Località: Reggio Calabria
Nome Cognome: Nino
Slackware: current 64bit
Kernel: 3.14.16
Desktop: KDE 4.10.5

Re: 14.1: il server X crasha

Messaggioda lablinux » mer nov 20, 2013 17:41

a me kde non parte mai al primo colpo, devo installare i driver close, nel mio caso nvidia, dopo parte e va che è una meraviglia.
E ho un i7 con 6g di ram.
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 751
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: 14.1: il server X crasha

Messaggioda samiel » ven nov 22, 2013 23:44

Masterizzatore a posto. RAM ecc a posto.
D'altro canto la partizione di Windows funziona
e anche Debian. Questo esclude problemi hardware
di qualsiasi natura. Inoltre tutto va appunto su Debian
per cui non è nemmno un problema di driver.
Appena ho una mezz'ora tento con slackpkg

m
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

Precedente

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti