Repository 32bit  Forum
Repository 64bit  Wiki

montaggio di condivisioni NFS al boot time...non funziona

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

montaggio di condivisioni NFS al boot time...non funziona

Messaggioda F4B1CK » lun giu 02, 2014 17:11

Ciao a tutti,
ho il seguente problema che non so come risolvere: ho un piccolo NAS casalingo della dlink che mi permette di creare condivisioni NFS.
Ho così creato due condivisioni dall'interfaccia del NAS e, per semplicità, porto come esempio come monto una delle due :

#>mount /mnt/nas/multimedia

questo comando richiama la stringa di configurazione messa in fstab :

192.168.0.88:/mnt/HD/HD_a2/multimedia /mnt/nas/multimedia nfs noauto,nolock 0 0

ed il tutto funziona.
Il "noauto" l'ho aggiunto nei parametri perché ho problemi anche al boot dato che l'interfaccia di rete viene tirata su dopo le relative operazioni di mounting e quindi il montaggio dell'nfs và in timeout.

I problemi dunque sono due : al boot il montaggio di nfs và in timeout (come scritto su) e quindi avevo pensato di ovviare lanciando a mano il mounting degli nfs una volta avviato tutto (anche perché il pc viene riavviato di rado), ma se uso il comando :

#>mount -a -t nfs

non succede nulla. Non mi da nessun messaggio d'errore ma non monta nulla! Ovviamente tutto il resto è ok, compresa rete attiva e capacità di pingare il NAS

se invece uso il comando :

#>mount /mnt/nas/multimedia

il montaggio avviene regolarmente. Questo è il secondo problema (perché il primo comando non funziona ed il secondo si?)

Come posso ritardare il montaggio di NFS dopo il boot della rete, oppure effettuarlo a mano (o aggiungere una stringa in rc.local per esempio) lasciando però la configurazione in fstab?
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: montaggio di condivisioni NFS al boot time...non funzion

Messaggioda Naitso » mar giu 03, 2014 21:06

ciao, ricercando in rete una soluzione potrebbe essere quella di utilizzare autofs
https://help.ubuntu.com/community/Autofs

Personalmente utilizzando una configurazione simile alla tua mi ero fatto lo script seguente...
https://github.com/naitso/rc.nfs/blob/master/rc.nfs
normalmente lo eseguo a mano, mentre per il pc della mia ragazza l'ho messo in cron, in pratica può accendere il NAS quando gli serve, e dopo pochi minuti se lo trova collegato, così non deve smanettare nulla, se cambio / aggiorno il pc basta ricopiare lo script e basta.

Se trovi altre soluzioni postale.
Ciao
Avatar utente
Naitso
Linux 2.0
Linux 2.0
 
Messaggi: 194
Iscritto il: lun nov 10, 2008 15:09

Re: montaggio di condivisioni NFS al boot time...non funzion

Messaggioda F4B1CK » mer giu 04, 2014 14:30

Grazie per la risposta. Penso che utilizzerò lo script debitamente modificato per adattarlo alle mie esigenza mettendolo in coda ad rc.local. Purtroppo non ho trovato altre soluzioni senza l'utilizzo di script, ma va bene così.
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: montaggio di condivisioni NFS al boot time...non funzion

Messaggioda lablinux » mer giu 04, 2014 14:49

Eseguire uno script in rc.local?
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 737
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: montaggio di condivisioni NFS al boot time...non funzion

Messaggioda F4B1CK » gio giu 05, 2014 13:06

Quello che intendevo è creare uno script ad hoc e poi farlo richiamare da rc.local al termine del caricamento del sistema
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: montaggio di condivisioni NFS al boot time...non funzion

Messaggioda Naitso » ven giu 06, 2014 8:17

occhio che rc.local viene eseguito solo a fine boot, se per qualche motivo il NAS non è visibile (perché ancora in fase di boot) non te lo monta più, salvo eseguire nuovamente lo script.
Avatar utente
Naitso
Linux 2.0
Linux 2.0
 
Messaggi: 194
Iscritto il: lun nov 10, 2008 15:09

Re: montaggio di condivisioni NFS al boot time...non funzion

Messaggioda F4B1CK » ven giu 06, 2014 13:56

Si ne sono consapevole. Ma essendo il mio un sistema acceso H24, in realtà lo script verrebbe chiamato solo nel caso dovesse essere necessario effettuare un reboot della macchina (per esempio se aggiorno il kernel) ed in tal caso il NAS verrebbe comunque rilevato.
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: montaggio di condivisioni NFS al boot time...non funzion

Messaggioda targzeta » ven giu 06, 2014 20:13

Dal man di mount:
Codice: Seleziona tutto
noauto Can only be mounted explicitly (i.e., the -a option will not cause the filesystem to be mounted).


Come hai configurato la rete, perché lo script rc.inet2 inizia così:
Codice: Seleziona tutto
# At this point, we are ready to talk to The World...


# Mount remote (NFS) filesystems:
il che mi fa pensare che, se configurato a modo, non devi fare nulla, se non ovviamente eliminare il 'noauto' dall'fstab.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6149
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: montaggio di condivisioni NFS al boot time...non funzion

Messaggioda F4B1CK » sab giu 07, 2014 15:39

Grazie per la dritta. Ho dato una lettura al contenuto di rc.inet2 ed effettivamente dovrebbe richiamare a boot-time lo script rc.rpc.
Questo a sua volta deve avviare rpc.portmap, rpc.lockd e rpc.statd. Ho verificato se tali file fossero presenti sul sistema ed ho attivato rc.rpc (adesso è eseguibile). Però il problema penso che sia l'assenza nel mio sistema di rpc.lockd.
Essendo in current penso che dovrebbe essere presente di default.

Ora non so se questo crea il problema, fatto sta che se riavvio rc.inet2, questo è il risultato :

ounting remote (NFS) file systems: /sbin/mount -a -t nfs
mount.nfs: an incorrect mount option was specified
mount.nfs: an incorrect mount option was specified
Starting Internet super-server daemon: /usr/sbin/inetd
Starting OpenSSH SSH daemon: /usr/sbin/sshd
/etc/rc.d/rc.yp: NIS not configured. Hint: set up /etc/defaultdomain.


che è lo stesso che mi crea quando manualmente eseguo il mounting, infatti la riga di comando all'interno dello script è :

/sbin/mount -a -t nfs

che credo vada in tilt per via dell'assenza nel sistema di rpc.lockd.

Vedo se riesco a sistemare l'assenza di questo file e riprovo ad eseguire l'auto mount.
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: montaggio di condivisioni NFS al boot time...non funzion

Messaggioda F4B1CK » sab giu 07, 2014 15:59

Ok, ho risolto l'arcano (beata ignoranza...).

Come riportato quì http://www.linuxquestions.org/questions/slackware-14/no-rpc-lockd-on-slackware-13-a-809441/

rpc.lockd non esiste più dalla Slackware 11.

Per avere un funzionamento corretto a boot-time bisogna rendere eseguibile /etc/rc.d/rc.rpc di modo che venga lanciato da rc.inet2, dopodiché in /etc/fstab alle righe che gestiscono i mount-point NFS bisogna mettere i parametri "rw,defaults" e pare che tutto inizi a funzionare come si deve.

Grazie a tutti per il supporto =D> :thumbright:
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: montaggio di condivisioni NFS al boot time...non funzion

Messaggioda targzeta » sab giu 07, 2014 20:13

In realtà basta avercelo in file rc.rpc. Come dice sempre nel rc.inet2:
Codice: Seleziona tutto
# If you have uncommented NFS partitions in your /etc/fstab, rc.rpc is run
# whether it is set as executable or not.  If you don't want to run it,
# comment the NFS partitions out in /etc/fstab or erase/rename rc.rpc.
if [ -r /etc/rc.d/rc.rpc ]; then
  sh /etc/rc.d/rc.rpc start
fi
Il tuo problema era semplicemente una sbagliata configurazione nell'fstab, come diceva anche l'output del comando mount.

Emauele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6149
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti