[RISOLTO] touchpad disabilitato

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
amevolley
Linux 0.x
Linux 0.x
Messaggi: 70
Iscritto il: gio nov 16, 2006 18:50
Località: bologna

[RISOLTO] touchpad disabilitato

Messaggioda amevolley » lun dic 01, 2014 18:59

HELP!
ho una Slackware 14.1 perfettamente funzionante da anni (upgradata da vecchie versioni), su un glorioso HP NC4400.
Ieri devo aver pigiato un combinazione di tasti per cui il touchpad ha smesso di funzionare.
Ora sto usando un mouse esterno, ma ho gia' verificato che sullas schermata di login e sull'utente root non ho questo problema, che quindi deduco che :
- il problema e' limitato al mio profilo;
- il touchpad non e' disabilitato a livello hardware (come e' possibile fare su alcuni portatili).

Dove posso mettere le mani per ripristinare il touchpad? Nelle impostazioni di sistema di KDE non ho trovato alcunche'...

grazie per eventuali suggerimenti...
Ultima modifica di amevolley il mar dic 02, 2014 14:32, modificato 1 volta in totale.

Avatar utente
urka58
Linux 3.x
Linux 3.x
Messaggi: 542
Iscritto il: mer dic 07, 2005 23:29

Re: touchpad disabilitato

Messaggioda urka58 » lun dic 01, 2014 22:00

Prova

Codice: Seleziona tutto

/usr/bin/synclient TouchpadOff=0

Se è un toucpad synaptics, dovrebbe riattivarsi, anche se non capisco come si sia disattivato...
Qui ci sono alcune istruzioni che potrebbero tornarti utili
https://wiki.archlinux.org/index.php/Touchpad_Synaptics_%28Italiano%29
Ciao

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1126
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: touchpad disabilitato

Messaggioda lablinux » mar dic 02, 2014 10:15

kde? Ho visto da qualche parte la possibilità di disabilitarlo. Vai in configurazione -> dispositivi di input (o qualcosa del genere).

Avatar utente
fgcl2k
Linux 1.x
Linux 1.x
Messaggi: 137
Iscritto il: gio ott 29, 2009 10:14
Nome Cognome: Federico
Slackware: 14.1 (64bit)
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: touchpad disabilitato

Messaggioda fgcl2k » mar dic 02, 2014 12:24

Una delle cose più fastidiose degli ambienti tipo KDE è la miriade di combinazioni di tasti/mouse/touchpad che "fanno qualcosa" alle tue spalle. Ho perso molto tempo a scoprire perché l'ora di KDE ogni tanto passava a UTC: la combinazione Ctrl+rotella mouse sull'orologio cambia il fuso orario tra quelli impostati dall'utente. Ma perché deve essere abilitata di default una "feature" del genere (idem per tante altre)?
Per quanto riguarda il touchpad potresti provare con xinput

Codice: Seleziona tutto

xinput set-prop NOME_DEVICE Enabled 1

Codice: Seleziona tutto

xinput list --name-only

fornisce l'elenco dei device.

amevolley
Linux 0.x
Linux 0.x
Messaggi: 70
Iscritto il: gio nov 16, 2006 18:50
Località: bologna

Re: touchpad disabilitato

Messaggioda amevolley » mar dic 02, 2014 13:44

Intanto grazie a tutti, purtroppo nonostante i suggerimenti interessanti non ho risolto.

Continua a fare difetto (cioe' touchpad muto e neanche i tasti dx e sx funzionano), che e' circoscritto a KDE.
Se al login seleziono altri DE funziona tutto regolarmente; Se seleziono KDE, appena la barra di caricamento supera il 10% il puntatore non e' piu' pilotabile da trackpad.

- L'approccio synclient non da' risultato (il parametro TouchpadOff e' comunque gia' 0)
- Nelle preferenze non trovo niente (in dispositivi di immissione trovo solo le preferenze del mouse, non c'e' traccia di touchpad)
- xinput list --name-only da' il seguente output:
Logitech USB mouse (quello esterno che uso ora )
SynPS/2 Synaptics Touchpad

ma un:
xinput set-prop "SynPS/2 Synaptics Touchpad" --type=int Enabled 1

non da' nessun risultato...

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1126
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: touchpad disabilitato

Messaggioda lablinux » mar dic 02, 2014 13:59

amevolley ha scritto:Logitech USB mouse (quello esterno che uso ora )
SynPS/2 Synaptics Touchpad

Dai, è un'impostazione di KDE, nell'impostazioni cerca (in alto a destra) touchpad
[edit]
ciapa https://forum.kde.org/viewtopic.php?f=20&t=97445#p206001
[/edit]

ps ciapa nel senso prendi questo link che ti risolve il problema (magari non il tuo :D )
Ultima modifica di lablinux il mar dic 02, 2014 14:02, modificato 1 volta in totale.

Avatar utente
fgcl2k
Linux 1.x
Linux 1.x
Messaggi: 137
Iscritto il: gio ott 29, 2009 10:14
Nome Cognome: Federico
Slackware: 14.1 (64bit)
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: touchpad disabilitato

Messaggioda fgcl2k » mar dic 02, 2014 14:01

amevolley ha scritto:xinput set-prop "SynPS/2 Synaptics Touchpad" --type=int Enabled 1

non da' nessun risultato...

Che cosa dice

Codice: Seleziona tutto

xinput watch-props "SynPS/2 Synaptics Touchpad"

amevolley
Linux 0.x
Linux 0.x
Messaggi: 70
Iscritto il: gio nov 16, 2006 18:50
Località: bologna

[RISOLTO] Re: touchpad disabilitato

Messaggioda amevolley » mar dic 02, 2014 14:31

Ale'!!!
ho insistito con le indicazioni di Urka58 perche' il link indicato mi era sembrato molto interessante.

Alla fine grazie all'opzione "list-props" mi sono accorto che oltre al parametro:
"Enabled"
ne esiste un altro che si chiama:
"Device Enabled"

quindi con un :
xinput set-prop "SynPS/2 Synaptics Touchpad" "Device Enabled" 1
tutto e' tornato a posto!!!

Grazie a tutti per la collaborazione,
aggiungo solo che:

- in KDE4 non trovo traccia di "touchpad", neanche con la ricerca (con riferimento al suggerimento di Lablinux)
- a memoria mi ero cacciato in questa sistuazione premendo FN+F11 che normalmente serve per abilitare il sensore di luce ambientale.
Ebbene, ho ripetuto l'operazione ed in effetti oltre che ad abilitare tale sensore, mi ha di nuovo disabilitato il touchpad!
Quindi c'e' una shortcut (di cui non ho trovato traccia nelle apposite impostazioni di KDE) che e' sovrapposta a tale funzionalita' nativa del portatile HP!
Con la Slackware 14.0 sicuramente non mi faceva questo difetto, ma ora che c'e' il workaround sono tranquillo...

hashbang
Packager
Packager
Messaggi: 1975
Iscritto il: ven giu 04, 2010 10:27
Nome Cognome: Luca De Pandis
Distribuzione: macOS Catalina
Località: Lecce / Bergamo / Milano
Contatta:

Re: [RISOLTO] Re: touchpad disabilitato

Messaggioda hashbang » mar dic 02, 2014 18:18

amevolley ha scritto:aggiungo solo che:

- in KDE4 non trovo traccia di "touchpad", neanche con la ricerca (con riferimento al suggerimento di Lablinux)
Slackware non fornisce il modulo kcm relativo di default.
O installi synaptiks (non più mantenuto, ma penso ancora funzionante), oppure il più recente kcm-touchpad.

Al limite potete scrivere sul topic di LQ per chiedere l'integrazione di quest'ultimo in Slackware -current, visto che l'uso dei laptop è piuttosto frequente.

Avatar utente
sya54M
Master
Master
Messaggi: 1641
Iscritto il: mer giu 06, 2007 14:44
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 4.19.x
Desktop: KDE
Località: (Salerno)
Contatta:

Re: [RISOLTO] touchpad disabilitato

Messaggioda sya54M » gio dic 18, 2014 9:42

hashbang ha scritto:Slackware non fornisce il modulo kcm relativo di default.

potete usare il mio finché non verrà incluso
http://www.sya54m.eu/repository.php