[RISOLTO] errore /usr/lib/libstdc++.so.5

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2411
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.1/14.2
Kernel: 4.11.3-smp
Desktop: xfce4
Distribuzione: freeBSD-12.0-beta3

[RISOLTO] errore /usr/lib/libstdc++.so.5

Messaggioda slucky » dom giu 26, 2016 18:52

Ciao a tutti gli slackers!! con la 14.1, installo il vetusto giochino, ma sempre valido ut2003... ma quando provo a lanciarlo mi dà questo errore:

Codice: Seleziona tutto

bash-4.3$ ./ut2003
./ut2003-bin: /usr/lib/libstdc++.so.5: version `GLIBCPP_3.2' not found (required by ./ut2003-bin)
./ut2003-bin: /usr/lib/libstdc++.so.5: version `CXXABI_1.2' not found (required by ./ut2003-bin)


ho provato a linkare la libreria e ad aggiornare i pacchetti gcc alla 5.0.3 della current....ma niente....mi dà sempre questo errore :evil:
qualcuno sa come fixare? grazie per le dritte!
Ultima modifica di slucky il lun giu 27, 2016 0:32, modificato 1 volta in totale.

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2411
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.1/14.2
Kernel: 4.11.3-smp
Desktop: xfce4
Distribuzione: freeBSD-12.0-beta3

[RISOLTO] Re: errore /usr/lib/libstdc++.so.5

Messaggioda slucky » lun giu 27, 2016 0:30

il problema nasce perchè quella libreria è mancante, gcc4 o 5 non la creano, nè linkarla risolve il problema, le librerie presenti di default nella 14.1 linkano a versioni differenti:

Codice: Seleziona tutto

bash-4.3# strings /usr/lib/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4


Codice: Seleziona tutto

bash-4.3# strings /usr/lib/libstdc++.so.6 | grep CXXABI
CXXABI_1.3


mentre dà errore perchè la lib mancante cerca le versioni 3.2 e 1.2, quindi sarebbe necessario compilare e installare gcc3, ma per evitare problemi di conflitti (non si sa mai) e farla breve, ho scaricato il pacchetto rpm compat-libstdc++, convertito con rpm2tgz e installato e il problema è stato subito fixato. Lo segnalo, qualora capiti ad altri utenti di trovarsi nello stesso problemino...

Saluti a tutti!
Ultima modifica di slucky il lun giu 27, 2016 17:41, modificato 1 volta in totale.

Avatar utente
conraid
Staff
Staff
Messaggi: 13221
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: [RISOLTO] errore /usr/lib/libstdc++.so.5

Messaggioda conraid » lun giu 27, 2016 8:25

Stai attento però, che libstdc++.so.5 è nel pacchetto aaa_elflibs, guarda in una 14.2 (current) cosa hai:

Codice: Seleziona tutto

grep libstdc++.so.5 /var/log/packages/*       
/var/log/packages/aaa_elflibs-14.2-x86_64-23:usr/lib64/libstdc++.so.5.0.7


però la libreria non ha la versione come ti aspetti con strings

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2498
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: [RISOLTO] errore /usr/lib/libstdc++.so.5

Messaggioda ponce » lun giu 27, 2016 8:54

per evitare casini pesi ti conviene estrarre quello che ti serve dagli rpm (o da vecchi pacchetti di Slackware), copiarli nella directory di ut2003 e lanciare ut2003 con qualcosa del tipo

Codice: Seleziona tutto

LD_LIBRARY_PATH=$LD_LIBRARY_PATH:. ./ut2003

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2411
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.1/14.2
Kernel: 4.11.3-smp
Desktop: xfce4
Distribuzione: freeBSD-12.0-beta3

Re: [RISOLTO] errore /usr/lib/libstdc++.so.5

Messaggioda slucky » lun giu 27, 2016 17:38

Ciao Conraid!! no ho controllato, nella 14.1 in quel pacchetto c'è la libreria /usr/lib/libstdc++.so.6.0.20... allora basterebbe aggiornare al pacchetto della 14.2 o current per fixare, Grazie della dritta Conraid !!! :)

Ponce ha scritto:
per evitare casini pesi ti conviene estrarre quello che ti serve dagli rpm (o da vecchi pacchetti di Slackware), copiarli nella directory di ut2003 e lanciare ut2003 con qualcosa del tipo

Codice: Seleziona tutto
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:. ./ut2003


sì giusto, infatti quel pacchetto rpm ti installa le sole librerie mancanti, comunque buona idea anche questa... proverò a lanciare il gioco così!
Grazie Ragazzi per l'Aiuto, Sempre Viva la Slack e Buona Vita!!! :D

Avatar utente
conraid
Staff
Staff
Messaggi: 13221
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: [RISOLTO] errore /usr/lib/libstdc++.so.5

Messaggioda conraid » mer giu 29, 2016 10:49

slucky ha scritto:Ciao Conraid!! no ho controllato, nella 14.1 in quel pacchetto c'è la libreria /usr/lib/libstdc++.so.6.0.20... allora basterebbe aggiornare al pacchetto della 14.2 o current per fixare, Grazie della dritta Conraid !!! :)


No, non farlo mai eh. Un pacchetto così delicato come tutti quelli aaa_ non andrebbero nemmeno aggiornati nella stessa distribuzione se non nel momento in cui escono, farlo tra versioni diverse significa mettersi nei casini immediatamente.

Segui il consiglio di ponce, è il migliore modo per usare librerie personalizzate.

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2411
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.1/14.2
Kernel: 4.11.3-smp
Desktop: xfce4
Distribuzione: freeBSD-12.0-beta3

Re: [RISOLTO] errore /usr/lib/libstdc++.so.5

Messaggioda slucky » lun lug 04, 2016 17:21

coraid ha scritto: No, non farlo mai eh. Un pacchetto così delicato come tutti quelli aaa_ non andrebbero nemmeno aggiornati nella stessa distribuzione se non nel momento in cui escono, farlo tra versioni diverse significa mettersi nei casini immediatamente.


e infatti, non l'ho fatto, alla fine ho lasciato la mia soluzione che ha funzionato subito e non ha creato problemi alla mia slack-box...ciao e buona vita! :D