[Risolto] Grub2 rimosso

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Charles
Linux 0.x
Linux 0.x
Messaggi: 9
Iscritto il: dom apr 24, 2016 11:55
Slackware: 14.1
Kernel: 4.4.14

[Risolto] Grub2 rimosso

Messaggioda Charles » ven set 02, 2016 13:12

Salve a tutti :')
Di recente, seguendo questa guida credo di aver fatto ingenuamente un grosso errore che molto probabilmente mi ha rovinato l'MBR del pc. Il comando in questione è questo:

Codice: Seleziona tutto

lilo -C /mnt/memory/etc/lilo.conf

Ciò mi ha tolto il Grub2 che stava già lasciandomi senza boot loader sia sul pc che sulla chiavetta.
Ho provato ad accedere sul mio tramite un'altra chiavetta fatta per l'installazione di Slackware con successo, da tale drive ho tentato in vari modi di ripristinare il master boot record:

Codice: Seleziona tutto

dd if=/dev/zero of=/dev/sda bs=440 count=1
dd if=/usr/share/syslinux/mbr.bin of=/dev/sda bs=440 count=1

e di reinstallare grub2 tramite un:

Codice: Seleziona tutto

grub-install /dev/sda

senza successo. Ecco l'errore risultante:

Codice: Seleziona tutto

/usr/sbin/grub-bios-setup: avviso: Sector 32 is already in use by the program `FlexNet'; avoiding it.  This software may cause boot or other problems in future.  Please ask its authors not to store data in the boot track.
/usr/sbin/grub-bios-setup: avviso: Sector 33 is already in use by the program `FlexNet'; avoiding it.  This software may cause boot or other problems in future.  Please ask its authors not to store data in the boot track.
/usr/sbin/grub-bios-setup: avviso: other software is using the embedding area, and there is not enough room for core.img.  Such software is often trying to store data in a way that avoids detection.  We recommend you investigate.
/usr/sbin/grub-bios-setup: avviso: L'embed non è possibile. GRUB può essere installato con questa configurazione solo usando blocklist. Le blocklist non sono comunque affidabili e ne viene sconsigliato l'uso..
/usr/sbin/grub-bios-setup: errore: impossibile procedere con le blocklist.

Ho anche fatto un tentativo per disinstallare LIlo con :

Codice: Seleziona tutto

lilo -U

ma dà questo errore:

Codice: Seleziona tutto

Fatal: Boot sector of /dev/sda doesn't have a LILO signature

La mia versione di Slackware è la 14.2, con kernel 4.4.14.
L'output di parted -l è questo:

Codice: Seleziona tutto

Modello: ATA Maxtor 6Y080L0 (scsi)
Disco /dev/sda: 80,0GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: msdos
Flag del disco:

Numero  Inizio  Fine    Dimensione  Tipo      File system     Flag
 1      32,3kB  35,1GB  35,1GB      primary   ntfs            avvio
 4      35,1GB  56,0GB  21,0GB      primary   ext4
 2      56,0GB  78,5GB  22,5GB      primary   ext4
 3      78,5GB  80,0GB  1476MB      extended
 5      78,5GB  80,0GB  1476MB      logical   linux-swap(v1)


La partizione su cui è installata Slackware è la numero 4, sulla 2 c'è una Debian jessie dal quale è stato installato Grub2 e sulla 1 un WIndows Xp malfunzionante per motivi troppo lunghi da spiegare qui.
Al momento non saprei come comportarmi, a parte per l'idea di usare una distro tipo Rescatux per riparare la situazione o provare a reinstallare il boot-loader su /dev/sda1 invece che nell' Mbr.
MI potreste aiutare? Grazie.
PS: Dopo la cancellazione dell' Mbr con dd all' avvio del pc tenta a caricarsi Windows XP :shock: È probabile che grub sia stato installato in origine su /dev/sda1 e non nell' mbr.
Ultima modifica di Charles il ven set 02, 2016 14:16, modificato 2 volte in totale.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2368
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.16.2
Desktop: lxde
Località: Pisa
Contatta:

Re: Grub2 rimosso

Messaggioda ponce » ven set 02, 2016 13:22

http://www.chimerarevo.com/linux/risolv ... nux-83081/

leggi bene il link sopra, e prima di fare qualunque cosa, fai un backup di qualunque cosa ti interessi.

Charles
Linux 0.x
Linux 0.x
Messaggi: 9
Iscritto il: dom apr 24, 2016 11:55
Slackware: 14.1
Kernel: 4.4.14

Re: Grub2 rimosso

Messaggioda Charles » ven set 02, 2016 13:25

Grazie, provo subito :)
EDIT: grazie mille, la tua soluzione ha funzionato. In realtà avevo già incontrato e risolto il problema di FlexNet su un altro pc, ma non pensavo fosse la stessa causa anche in questo caso.
Grazie ancora per l'aiuto :D
Buona giornata.