qt5 su slackware14

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
pino
Linux 2.6
Linux 2.6
Messaggi: 591
Iscritto il: ven gen 18, 2008 15:34
Nome Cognome: Pino
Slackware: 14
Desktop: kde
Località: Torino

qt5 su slackware14

Messaggioda pino » lun set 05, 2016 17:40

E' possibile installare le qt5 su slackware14? Se si come?
Ho visto che sul sito di alien c'è la versione per la 14.1 può funzionare?

Avatar utente
brg
Linux 2.4
Linux 2.4
Messaggi: 413
Iscritto il: sab mar 12, 2011 14:20
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE4
Località: Montecatini
Contatta:

Re: qt5 su slackware14

Messaggioda brg » lun set 05, 2016 19:07

C'è anche su slackbuilds.org. Io lo ho installato usando lo slackbuild e funziona, ma la compilazione richiede un pomeriggio.

Avatar utente
conraid
Staff
Staff
Messaggi: 12954
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: qt5 su slackware14

Messaggioda conraid » lun set 05, 2016 19:13

14 cosa? 14.0? 14.1 o 14.2?
Quelle di alien installate per il sistema per cui le ha create.
Altrimenti compilale da slackbuilds.org

Avatar utente
tgmx
Linux 3.x
Linux 3.x
Messaggi: 1336
Iscritto il: ven apr 28, 2006 14:40
Slackware: 14.1
Desktop: KDE 4
Località: Ancona

Re: qt5 su slackware14

Messaggioda tgmx » lun set 05, 2016 23:15

Dipende che ci devi fare.
Se ti serve Qt 5.x.y per sviluppare applicazioni ti basta scaricare l'installer direttamente da:
https://www.qt.io/download-open-source/#section-2
In questo modo hai un'installazione pulita dato che viene messo tutto nella tua home.

Se pero' ti servono come "dipendenza" di qualche applicazione allora devi modificare /etc/ld.so.conf inserendo il path alle librerie richieste.

In quest'ultimo caso forse e' piu' comodo utilizzare le librerie di Alien che probabilmente vanno a mettersi nei path giusti per essere subito disponibili ad eventuali applicazioni.

Io ho sempre utilizzato sulla mia Slack il primo modo.

pino
Linux 2.6
Linux 2.6
Messaggi: 591
Iscritto il: ven gen 18, 2008 15:34
Nome Cognome: Pino
Slackware: 14
Desktop: kde
Località: Torino

Re: qt5 su slackware14

Messaggioda pino » mar set 06, 2016 17:24

conraid ha scritto:14 cosa? 14.0? 14.1 o 14.2?

14.0
tgmx ha scritto:Se pero' ti servono come "dipendenza"

Per questo
brg ha scritto:C'è anche su slackbuilds.org. Io lo ho installato usando lo slackbuild e funziona, ma la compilazione richiede un pomeriggio

Farò cosi
Grazie
Ciao

pino
Linux 2.6
Linux 2.6
Messaggi: 591
Iscritto il: ven gen 18, 2008 15:34
Nome Cognome: Pino
Slackware: 14
Desktop: kde
Località: Torino

Re: qt5 su slackware14

Messaggioda pino » mar set 06, 2016 17:32

Su slackbuilds.org ho trovato le qt5 per la 14.1 e 14.2 ma non per la 14.0