[SOLVED] impossibile fare "qualcosa" che booti

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5051
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: [SOLVED] impossibile fare "qualcosa" che booti

Messaggioda ZeroUno » sab set 16, 2017 15:46

Cavolo, hai scoperto il mio segreto... :D

In verità è di questi giorni un post su linuxquestions riguardo l'impossibilità di boot da cd a cui ha risposto Didier - autore di slint - citando xorriso.
Patrik non è rimasto a guardare e l'ha inserito in current

https://www.linuxquestions.org/question ... ost5757877
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

rik70
Master
Master
Messaggi: 1781
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: 4.0.x-smp
Desktop: Xfce 4.12

Re: [SOLVED] impossibile fare "qualcosa" che booti

Messaggioda rik70 » sab set 16, 2017 19:26

Bisogna vedere però dove sta l'inghippo: è colpa del software utilizzato per la creazione dell'iso, oppure è GRUB? Slint nel post di LQ si dice che usi elilo anche se la iso è fatta con Xorriso.

Ecco, io qui ho una iso di systemrescuecd: usa GRUB per il Boot UEFI, Syslinux per il boot da BIOS - come da regola - ed è stata creata con Xorriso(non è ibrida):

Codice: Seleziona tutto

Data preparer id: XORRISO-1.4.6 2016.09.16.133001, LIBISOBURN-1.4.6, LIBISOFS-1.4.6, LIBBURN-1.4.6


Ora, se la do in pasto ad una macchina virtuale qemu/kvm con firmware UEFI ed emulando un cd-rom, non parte: appare solo la shell di grub.

Ma se la "post-processo" - come dicono sempre su LQ - con isohybrid

Codice: Seleziona tutto

isohybrid -u systemrescuecd-x86-5.1.0.iso
parte senza problemi.

Come controprova, ho creato una iso di slackware64-curent col comando mkisofs descritto nella documentazione, ma su qemu non parte. Se invece gli faccio la stessa cura con isohybrid, va che è una bellezza.

Quindi?
Forse il firmware in questione vuole una iso ibrida, ma non digerisce grub da cdrom (vuole elilo?), mentre da usb funziona ma solo con dd.

Domanda: la iso di ubuntu è ibrida?