Pagina 1 di 1

wicd; problemino di configurazione

Inviato: sab dic 16, 2017 9:57
da tigerwalk
Il "problemino" è questo: utilizzo un hd usb con slackware 13.37 e quando cambio computer, wicd mi riconosce la scheda wifi come wlan0 o come wlan1 e restando con la configurazione memorizzata del precedente computer, non si connette automaticamente ma devo cambiare manualmente il dispositivo (wlan0 o wlan1) e riavviare wicd. Non è la fine del mondo ma vorrei sapere se c'è la possibilità di dire a wicd di collegarsi tramite l'una o l'altra scheda indifferentemente e quindi, automaticamente.

Re: wicd; problemino di configurazione

Inviato: lun dic 18, 2017 12:53
da albatrosla
Credo che la soluzione migliore sia dire al sistema che il device sia sempre wlan0. Forse si riesce a fare con una eudev rule ad hoc?
Sono arrugginito sulla questione e non ho una macchina su cui provare, ma penso sia la cosa giusta.

Re: wicd; problemino di configurazione

Inviato: lun dic 18, 2017 14:15
da miklos
albatrosla ha scritto:Sono arrugginito sulla questione e non ho una macchina su cui provare, ma penso sia la cosa giusta.
si anche secondo me è la via piu' facile.
eudev genera e salva delle regole, basate sul macaddress, proprio per non confondere eventuali programmi che fanno affidamento al nome del device.
Il caso in questione non è contemplato, pero come detto si puo' ovviare facendo in modo che al device wlan0 siano associate due schede differenti.
Sotto la directory /etc/eudev/rules.d/ trovi un file di cui non ricordo il nome preciso (ma esiste in qualsiasi installaizone slackware recente) dove vengono associati ai mac address dei nomi logici.
Dovresti editarlo facendo in modo che entrambe le schede wireless vengano chiamate wlan0.

Ovviamente sto partendo dall'assunto che queste schede wireless non si trovino mai contemporaneamente attive (immagino il caso di device usb) perchè in quel caso non sarebbe la scelta migliore.

p.s: eudev è recente, sulla 13.37 forse c'era ancora il vecchio udev, comunque il principio è lo stesso.

Re: wicd; problemino di configurazione

Inviato: gio dic 21, 2017 13:45
da tigerwalk
grazie ad entrambi per le risposte.