Repository 32bit  Forum
Repository 64bit  Wiki

Problema Samba+Cups+hp3520

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema Samba+Cups+hp3520

Messaggioda valfe » mar feb 10, 2004 9:52

Ho installato Samba e sono riuscito a condividere una directory <BR>"/home/condivisi" con winXP per un utente generico "nobody" <BR>sulla mia piccola LAN (2pc Slack9.1 e WinXP). Fino a qui tutto <BR>bene, ma ora nn riesco a condividere la stampante hp usb con <BR>cups, cioè la vedo da win ma mi da accesso negato, vi posto la <BR>mia configurazione di samba: <BR> <BR>[global] <BR> workgroup = INTRANET <BR> server string = mrPink Samba Server! <BR> interfaces = 192.168.0.1/24, 127.0.0.1 <BR> security = SHARE <BR> log file = /var/log/samba.%m <BR> max log size = 50 <BR> os level = 65 <BR> preferred master = Yes <BR> domain master = Yes <BR> dns proxy = No <BR> valid users = nobody <BR> hosts allow = 192.168.0., 127. <BR> printing = cups <BR> <BR>[printers] <BR> comment = All Printers <BR> path = /var/spool/samba <BR> guest ok = Yes <BR> printable = Yes <BR> browseable = No <BR> <BR>[condivisi] <BR> comment = Condivisi su mrPink! <BR> path = /home/condivisi <BR> read only = No <BR> create mask = 0777 <BR> guest ok = Yes <BR> <BR>help!!! <BR><br>
valfe
Linux 2.4
Linux 2.4
 
Messaggi: 342
Iscritto il: mar nov 04, 2003 0:00

Problema Samba+Cups+hp3520

Messaggioda useless » mar feb 10, 2004 11:55

credo che ti manchi questo nella sezione globale: <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>printcap name = /etc/printcap <BR>load printers = yes</BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>la cosa divertente è che a me funziona tutto, anche se ho appena scoperto la riga "printing = lprng" nel mio smb.conf... e uso cups! :-D <BR> <BR>prima che ci perdi tempo: occhio a decommentare nei vari /etc/cups/mime* le linee che si riferiscono a octet-stream!<br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Problema Samba+Cups+hp3520

Messaggioda valfe » mar feb 10, 2004 12:28

<!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE> <BR>prima che ci perdi tempo: occhio a decommentare nei vari /etc/cups/mime* le linee che si riferiscono a octet-stream!<br> <BR></BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>li lascio così come stanno giusto? <BR> <BR>ho provato ad aggiungere quelle due righe ma nn stampa uguale. <BR>quando do il comando sembra che si connette a \\mrpink\lp0 ma nn <BR>succede niente .......... mah!?!<br>
valfe
Linux 2.4
Linux 2.4
 
Messaggi: 342
Iscritto il: mar nov 04, 2003 0:00

Problema Samba+Cups+hp3520

Messaggioda useless » mar feb 10, 2004 14:04

no, non li lasci così! DEcommentare = TOGLIERE i # all´inizio! nella fattispecie deve essere così: <BR> <BR>mime.convs (righe 105 e successive): <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>######################################################################## <BR># <BR># Raw filter... <BR># <BR># Uncomment the following filter and the application/octet-stream type <BR># in mime.types to allow printing of arbitrary files without the -oraw <BR># option. <BR># <BR> <BR>application/octet-stream application/vnd.cups-raw 0 -</BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>mime.types (righe 148 e successive): <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>######################################################################## <BR># <BR># Raw print file support... <BR># <BR># Uncomment the following type and the application/octet-stream <BR># filter line in mime.convs to allow raw file printing without the <BR># -oraw option. <BR># <BR> <BR>application/octet-stream</BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>_credo_ che di default siano commentate le 2 righe in questione!<br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Problema Samba+Cups+hp3520

Messaggioda valfe » mar feb 10, 2004 14:52

ok ora provo, avevo capito "occhio a nn decommentare" :P<br>
valfe
Linux 2.4
Linux 2.4
 
Messaggi: 342
Iscritto il: mar nov 04, 2003 0:00

Problema Samba+Cups+hp3520

Messaggioda valfe » mar feb 10, 2004 15:27

nn è cambiato nulla da win mi dice sempre <BR>accesso negato, impossibile connettersi ...<br>
valfe
Linux 2.4
Linux 2.4
 
Messaggi: 342
Iscritto il: mar nov 04, 2003 0:00

Problema Samba+Cups+hp3520

Messaggioda useless » mar feb 10, 2004 19:15

boh, ti pasto il mio: <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>[global] <BR>client code page = 850 <BR> workgroup = SUKKONET <BR> server string = Celeron 733, 128 MB RAM, 6.4+40 GB HD <BR> hosts allow = 10.0.6. <BR> printcap name = /etc/printcap <BR> load printers = yes <BR> printing = cups <BR> log file = /var/log/samba/%m.log <BR> max log size = 0 <BR> security = user <BR> encrypt passwords = yes <BR> smb passwd file = /etc/samba/smbpasswd <BR> unix password sync = No <BR> passwd program = /usr/bin/passwd %u <BR> passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully* <BR> pam password change = yes <BR> username map = /etc/samba/smbusers <BR> obey pam restrictions = yes <BR> socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192 <BR> dns proxy = no <BR> <BR>[printers] <BR> comment = All Printers <BR> path = /var/spool/samba <BR> browseable = yes <BR> writable = no <BR> printable = yes</BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR><!-- BBCode Start --><A HREF="http://www.danasoft.com" TARGET="_blank"><!-- BBCode Start --><IMG SRC="http://www.danasoft.com/sig-ita.jpg"><!-- BBCode End --></A><!-- BBCode End --> <BR>Think free @ <!-- BBCode Start --><A HREF="http://www.nyft.org" TARGET="_blank">http://www.nyft.org</A><!-- BBCode End --> <BR><BR><BR>[ Questo Messaggio è stato Modificato da: useless il 10-02-2004 19:16 ]<br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Problema Samba+Cups+hp3520

Messaggioda valfe » mar feb 10, 2004 21:28

Alla fine ho risolto, vi dico come perchè <BR>potrebbe capitare a voi un giorno hehehe ;) <BR>Allora i problemi erano essenzialmente 2: <BR> <BR>1- il comando di stampa era lpr mentre deve essere lpr-cups <BR> <BR>2- nn gli avevo detto di usare i driver locali di windows <BR> <BR>ci stavo diventando pazzo ... ok alla prox<br>
valfe
Linux 2.4
Linux 2.4
 
Messaggi: 342
Iscritto il: mar nov 04, 2003 0:00


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron